Before you pack up your WD and return it, let's talk about Copying Speeds!


#121

Hi Ralphael and others who took time to reply on this topic. My name is Johan (Dutch for John) and I am very new to WD. The MyCloud device is in the house since last week Wednesday 21st of Jan. Reason… the hard disc of my WIndows desktop came with an ATA error. Bottom line: hard disc needs to be replaced. Where to store the data of more or less 550Gb of programs, docs, vids, pics, some music and miscellaneous like .pdf’s, Outlook and other MS Office files.

Somewhere, I read about having a NAS in the house - for instance like a WD MyCLoud - which you also can connect to your smartphone(-s), tablets, a.s.o, to use it as a cloud for back up purposes, local in our appartment, but also when you are on a mountain and want to store pics or vids on your own ‘cloud’.

My very first need of this MyCloud was backing up my almost breaking apart hard disc which came up every time a restart was done with the same error. Saving my data was 1st prio. Well, it took from Thursday after purchasing MyCloud until Saturday afternoon that the 550Gb was sent over.

For proper understanding, I have a router-and-modem-in-one connected to my provider. Thanks to Ralphaels instructions in his leading topic, I found out that the internal speed is 1Gbps. Why backing-up of 550Gb took almost three days is a riddle to me. However, by reading the main article in this topic and overlooking some of the rest, and understanding this properly, this might be caused by all those very tiny files. In the back-up process I had to act on restarts.

So last Sunday - after finally backing-up- I could bring the desk top to a PC doctor to let him install a new hard drive. That is something I wouldn’t dare to burn my hands on, as we say in Dutch. On Monday evening I picked up my desk top with the new hard drive. I could easily connect and plug in. MyCloud was recognized as well. So, I started the process of restoring the back up of 550Gb of data.

We are now on Friday night (CET almost 23 hrs) and after over 30 or more hick-ups of connection, since last Monday, while the desk top was continuously trying to get a restore of back-up files, it still looks grey at the receiving side on my desk top (C:) of 462,1 Gb in the WD SmartWare Pro screen. The same screen that shows in dark blue on the WDMyCloud side 501.6Gb of other back-up.

So, I am thinking… How to get more devastated. How can I act WD MyCloud to restore files to the new hard disk? Or should I just copy and paste from WD MyCloud the files that I can see to C:…

Or do you or anyone has a clue? I just want to go back to my normal C:\ acting drive. With all it’s programs, 'cause I am a user of my video editing, that I miss alot now. Combining with the pics and so on.

And for crying out load having your PC non stop active for almost a week to restore a back-up file? That could not be the meaning of something as smart should be acting like MyCloud.

Or am I making a mistake? Please let me know!
Grtz, to you and all


#122

yes I’ve been there… yelling at WD many times for their absolutely terrible product without any tech support people on their forums.

There are many reasons that I don’t answer tech questions anymore so I don’t usually respond to this thread plus there are many capable users that are not as jaded as I am that have been answering the questions.

Today I am making an exception…

Now it all depends on what software you used to backup all your files, if you used WD method of backup, then you will have to use WD restore process to get back your files based on the fact that I’ve heard that they have encrypted the backup files now or at least appended them to each other.

Thus you have to wait for the restore no matter how painful.

If you do manage to restore, there are two things you should do…

Find out what speeds you are getting by simply copying files to and from your cloud. If you are getting less than 70MB/s reads and 40-50MB/s writes through wired Gigabit network (must be cat53 or Cat6) , then you really have to find out what your bottleneck is.

If you haven’t been able to restore completely and this restore process has stopped, then do find out whether or not you are getting those Gigabit speeds that all of us are getting; unless you are trying to do this through Wifi, then never mind.

If you are getting the network speeds, then it could be the restore process problem. You also have to remember that you are limited to the hard drive speeds on your PC that you are restoring to. The only way to test the speeds of you own hard drive is to probably use a program to test hard drive reads and writes. Yes, back in the days, older hard drives are notorious in their read/write speeds. Yes I know you have a brand new hard drive, but it could be a brand new older style hard drive. Just covering all my bases here since I’m guessing.

Plus if you have a lot of small files, the restore program will be really really slow because every file that is restored, space must be allocated, filenames created in the directory and so forth…

The main thing is to find out what your network speeds are. If they are normal, then it is everyone else’s fault; i.e. the restore program, small files, slow internal hard drive, slow CPU.

Now if your Cloud is still indexing for some strange reason, or perhaps you turned it off during the time that your PC was getting a new hard drive, then it might be still indexing files that you stored on it, thus it could be your Cloud’s fault, of which you should go in with SSH and stop all the Scan process. If you don’t want to use SSH, then refer to my stickied post on just turning off all the Scans.

It is all up to you now to find out whose fault is it.

Good luck…


#123

I just wanted to add that my cycloud was slow as can be but it was my router once I got a gigabit router it is very fast


#124

Here is what I did to speed up my wdmycloud
I made sure it was gigabit to the router first

I ssh ed into it as root
then I added these entries to cron (you can do $ crontab -e)
no problems since then
I am only using it for a Time Machine backup for our mac
it is working great now
it was totally io bound – it did not have anything to do with network – for my situation
0 5 * * * /etc/init.d/twonky stop
0 5 * * * /etc/init.d/wdmcserverd stop
0 5 * * * /etc/init.d/monitorio stop
0 5 * * * /etc/init.d/wdnotifierd stop


#125

Hi, I’m new here so please bear with me.
I’m experiencing many of the slow issues discussed here and have been attempting the solutions put forward by Ralphael in particular, in his very informative post.

Using SSH to enter wdmycloud, I have attempted to stop wdmcserverd and wdphotodbmerger. The following is the result in italics.

root@wdmycloud root # /etc/init.d/wdmcserverd stop
Stopping wdmcserver
sh: you need to specify whom to kill
root@wdmycloud root # killall wddispatcher
killall: wddispatcher: no process killed
root@wdmycloud root # killall wdnotifier

I tried to kill the wddispatcher process but as noted above ‘no process was killed’. However, the command to kill the wdnotifier process was successful.

I then tried to disable wdmcserverd and wdphotodbmerger using the following commands:
update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

The result is listed below in italics.

root@wdmycloud root # update-rc.d wdphotodbmergerd disable
-sh: update-rc.d: not found
root@wdmycloud root # update-rc.d wdmcserverd disable
-sh: update-rc.d: not found

Can someone please enlighten me? What have I got wrong? All advice gratefully received.:confused:


#126

There is a symbolic link in /etc/rc2.d/S98user-start to a file called /CacheVolume/user-start. If you put the following
lines in that file. Everytime your system reboots it will stop these processes.
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S20restsdk-serverd stop
#/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S20minidlna stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
#/etc/rc2.d/S95wdAutoMount stop
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S61upnp_nas stop


#127

Thanks so much for such a quick response.

I do not appear to be able to get access via ssh to the file. Is this a permissions thing? I used ssh to login as below:

ssh -oHostKeyAlgorithms=+ssh-dss sshd@wdmycloud.local

Does this command need to be different?

Thanks again for the fast assistance.


#128

I am getting slow copying speed when using 3TB WD elements.
When I connect it directly my computer via USB I get only 80 MB/s.

What could be the reason?


#129

A post was merged into an existing topic: Removed post


#130

Before anyone runs off and creates a NextCloud device, let me tell you MY experience. I got a NextCloud Box set up, which is not exactly plug and play, as they advertise. You will need to do some things with a monitor and keyboard connected, like enabling https for example. It took me a couple days on their forums to finalyy get an answer to the question, what is the user name and password to console in? Turns out it’s ubuntu:ubuntu by default. To change the password, you need to sudo passwd.

But the deal breaker for me is this: You download the desktop client, pick a folder to sync. Everything goes fine. Then you notice you can uncheck subfolders insite that stnc folder. Great! You can exclude that folder with the DVD rips that is filling up the HD on the NextCloud Box! OOPS! IT DELETES THE FREAKING LOCAL FILES!!!

Granted, you can recheck the box and they will show back up (after however many hours it takes to re-dl them). But delete the account BEFORE you do that and your files are simply gone. The devs seem to be planting their feet about this, although there is a long post on github where virtually everyone using it is telling them they have to change the way this works.


#131

NextCloud? Are you sure your on the right website support forum? This is a support forum for the WD My Cloud devices. Further this discussion is about copy speeds to/from the WD My Cloud device.

https://www.wdc.com/products/personal-cloud-storage/my-cloud.html


#132

I made an account just to come on here and say that this post is the absolute worst. It’s the Batman v Superman of copying speeds. Not to knock the author, you clearly put a lot of time into this. That’s commendable. But there is so little information it is more than unhelpful, it wastes time people could be spending getting to the actual help they need.

There is so much superfluous information and it rambles forever, then when it finally gets to the section titled workarounds, it gives you nothing. I mean, there is text there, but I assume you need more than a basic knowledge of network to know what “/etc/init.d/wdmcserverd stop” means. Do I type this into the command prompt? No? Oh it requires me to find an additional post with information about what SSH is, and how to use it. To the average person, you may as well have just mashed the keyboard right there under workarounds.

There is almost zero actionable information, which is surprising given the length. I probably wouldn’t care, I would have just left it and moved on, except every other post I come across about slow transfer speeds references this one. People keep asking if you have read it. As if it contains all the answers.

Every device on my network can connect to other devices and transfer at decent speeds, whether LAN or Wifi. When copying from the Mycloud I can’t seem to get more than 2MB/s. Multiple people can connect at the same time and all get the same under 2MB/s transfer speed. But no one can get faster, not LAN connected, not Wifi. I even disconnected the Mycloud, and gave it it’s own network, with only one computer connecting to it, and it still was under 2MB/s. I am using it purely as a network drive, no cloud based services are running.

Does anyone have any actual tests I can run? Something step by step, another more to the point article? Settings I can check? Or is 2MB/s the speed I should expect out of the box?


#133

There are any number of third party speed test programs one can use to test the read/write speed to/from a My Cloud. Crystal Disk Mark (https://crystalmark.info/download/index-e.html) is one such program for Windows.

WD Support Knowledgebase has a several articles that discuss network or backup speed.

More information about your network setup and configuration is needed. Simply saying “my speed is slow” doesn’t help. There is no detailed information about how your network is configured (are you using Gigabit routers, Gigabit network adapters, what is the WiFi speed, etc.), as such the information anyone can provide will be very general.

The original post to start this topic does give some general information on what to check for general bottlenecks in network speed. But due to the nature of how local area networks operate, and number of different networking products/equipment out there, there is simply no way to give detailed information on every single element/configuration that could potentially impact network speed and how to fix them. Sometimes one needs to delve into complex elements of how local networks operate to fix certain issues that may be present in their specific equipment.

Everyone’s network speeds will be different due to the makeup of their network equipment and other issues (number of files, size of files, etc.). And generally one never achieves the top (marking information) speed for their network equipment.

For example, I have one computer that has a Gigabit network adapter and one that has a 10/100mb network adapter. The speeds to the My Cloud will be different. Both are connected using Cat 5e cable to my ISP provided router that has Gigabit network ports. The My Cloud is also connected to this same router.

Computer 100MB network adapter:
Toshiba P755 S5393 Internal 100MB adapter

Computer Gigabit network adapter:
Asus P5W DH CrystalDiskMark 1gb to My Cloud 1T Internal Drive

One can search for past discussions where people have posted their Crystal Disk Mark results to get a “general” ideal of what speeds one “might” potentially achieve.


#134

In addition to Bennor’s comments, what sort of files were you moving when you measured that transfer rate? Small files will always give a low rate, due to the file system management overheads; that’s shown in the CDM results above.


#135

I was trying to get paid by the word :stuck_out_tongue:

Bottom line:
The cloud is almost never to blame with some caveats. Check out the other post that might help “Before you RMA your device lets talk about your problems” as it gives you things to do instead of SSH’ing and typing command line - commands.

if you are connected from computer to cloud end to end through an ethernet cable, either through a gigabit router or a switch, you should get gigabit speeds meaning around 80MB/s copying of a 800MB file. Note: You won’t get that speed with a bunch of small files though because this is a problem with the OS and file structure rather than the Cloud.

You will not get gigabit speeds over Wifi unless you have an AC Wifi router and even then you get about a max of 40 to 60MB/s speeds.

Average Wifi speeds is around a max of 10MB/s and less, equivalent to about 80mb/s (notice the small letters of mb/s which means megabit per second which is divided by 8 to get MB/s megabyte per second).

When you start to copy a bunch of small files like jpgs (photos), mp3s, ebooks and such, you drop to about 2 or 3MB/s even when you have a ethernet cable connected. This is just the way it is and not the fault of the Cloud.

Also you might not get gigabit speeds on ethernet cable if you have 100mb/s devices connected on your router/switch. Apparently this is still an issue as I had a lutron (light switches) bridge and a security alarm device both at 100mb/s connected on my network and this completely slows down the whole network.

In order to fix this, you have to remove them to a separate network and that is another subject altogether.

Good luck…


#136

I am not going to read all posts in this thread to have my WDMyCloud coping again at 100 MB/s when moments ago it was coping with this speed big files.
I do not understand why you need to literally hack it to make it work properly.
WD…keep doing HDD, leave the cloud business to Synology and QNap…