BBC iPlayer no longer working

This has been working perfectly for me for some time now - that is until I downgraded to the previous firmware (to get around the recent freezing problem).

Whether it is coincidence or not, BBC iPlayer has now stopped working (“Error. This content does not seem to be working. Try again later.”).

Is there a workaround for this one too please ?

Thanks

I have recently been experiencing exactly the same problem, without having made any changes to firmware

Running with 3.12.13 on my WD Live Hub

Can access Youtube but BBC iplayer has started to present ‘This content does not appear to be working - try again later’

Oddly checking for firmware also generates an error suggesting no internet connection, but a test of the connection is successful and Youtube and other services appear to be working fine

Have also tried a device reset to no effect
Regards
Steve

Well, at least I now know I am not the only one ! Thanks, Steve.

It worked until relatively recently (I can’t be sure when exactly) but it seems to be more than coincidence that this has stopped working around the same time that WD has withdrawn support for the product.

I can’t help but think that WD has taken an active decision to switch off this service…

Maybe BBC decided to do it ?

It’s happened before, that streaming services decided to “Pull the Plug” supporting WD TV devices … dunno why everyone has a knee’jerk reaction that WD is to blame everytime :neutral_face:

example: ABC iView (scroll down) http://iview.abc.net.au/support/announcements

P.S. Steve_Cullum … has a WDTV Live Hub, which has been obsolete longer than the WDTV Live Streaming FYI

Well I guess WD could clear things up with some concise information one way or the other…

Obsolete? Time for a sad face :cry:

In all seriousness the Live Hub has been one the best purchases I have ever made - absolutely love it

Given that it is obsolete, any recommendations for a replacement? :wink:

Taken from the BBC web site

All this would be so much simpler if WD simply made a definitive statement. Is that possible, or is this the wrong forum to expect such a thing ?

So, maybe the problem is at your end ?

dunno … if there is a issue, wouldn’t there be hundreds of people jumping up and down ?

Feature of the product.

Worked until recently.

Stopped working a short time ago.

Would like it to work again - sort of “what I paid for” if you know what I mean ?

Don’t think that is entirely unreasonable.

And no, the problem is probably not at my end - at least insofar as the service is still being delivered across the same infrastructure by other devices.

If I should be pursuing this via another route then I would appreciate a pointer, but failing that, I don’t really know how else to bring this to the attention of the company that sold me the product in the first place.

Thanks

Phone them (change the Country of course)

I have had similar issues and relentlessly stayed on WD Tech support. They finally offered to change out my unit but alas when I got the return paperwork they stated that if you open it up, no exchange. Well I opened mine up because I though that I had an overheating problem. I even ran a cat 5 line to my home theater because I thought that using the wireless feature may have contributed to the heat, then I installed a cooling fan. I have done so much trying to correct the problem which, BTW, started out with the box locking up or becoming unresponsive to the remote. I have many of these boxes and have given several away to friends and family only to run into a tech support wall with these bull ■■■■ problems. I suspect that some of this is their mission to either generate new product sales or there is something that they discovered in their software that is illegal (DRM copyrite police). I took one of my boxes (the one I was having the most trouble with) and installed the firmware that WD tech support recommended and now I don’t have the VuDu service and tech support can’t or won’t explain why. I know that they have stopped offereing Netflix which is pretty damned stupid. I even ask tech support if they ever read the forums because they have scads of people, worldwide, pissed off over non-functioning WDTV live boxes. Never got an answer. I am at a loss.

By way of update, I did contact WD Support. It seems that the iPlayer app requires the latest firmware (2.02.32), so I upgraded again and so far it seems to be working again.

So long as the freezing issue remains fixed, I should now be OK.

Thanks for your inputs - and thanks to Siim who dealt with my call.

John