Backup WD My Cloud to Netgear Ready Nas Over Another Network

Hi everyone, first off, sorry if this was posted into the wrong category. I’m fairly new to discussion threads and usually fight through the issue before seeking help however, I’m truly stumped here.

Overview:
I have a “WD My Cloud EX2 Ultra” and a “Netgear Ready Nas” that I bought as media storage devices. They both also run a plex server on them.
I decided to place the servers in 2 different cities, 1 at my place (WD My Cloud) and the other about 15 mi away at my brothers place, "Netgear Ready Nas).
I keep the WD My Cloud as the “Master storage device” and bought the Netgear Ready Nas as a backup of the WD My Cloud.

Problem:
The problem im having now is, I am not able to backup the Netgear Ready Nas that is at my brothers house from the WD My Cloud that is at my house; 2 different networks.
In the WD My Cloud, I set the network type to Static so the IP would not change, I also configured this in the router itself. Then I forwarded a port through the WD My Cloud and the router so that I can possibly do the backup through FTP Port Forwarding but I still cant seem to get it to work.
On the Ready Nas, I am able to configure this to backup from a device but it doesnt seem to work unless its over the same network. I thought If I forwarded a port and made my IP Static, it would give me a direct connection. What am I missing here?
Here is what is asked from me from the Ready Nas:

Type: “Remote” (Only option)
Name: “Remote: FTP”
Host: 192.168.0.*** (Host IP from WD My Cloud)
Path: Public (Path from WD My Cloud)
Login: admin (WD My Cloud login)
Password: ********** (WD My Cloud password)
And then I set the destination which is somewhere on the drive however this isnt “connecting” over another network. It only connects on the same network.

Configurations:
Router:

  • Made IP Static (WD My Cloud)
  • Forwarded a port for FTP

WD My Cloud:

  • Made IP Static
  • Forwarded port 21 for FTP access
  • Protocol is TCP
  • External Port and Internal ports are the same

Netgear Ready Nas:

  • Set source and destination info

Am I missing something? Thank you in advance for your time!

So, let’s talk about “path”.

I was expecting some reference to the destinations WAN address. It won’t be an IP address assigned by the router, it would be a (similar format but different) IP address assigned by your Internet Service provider.

So - - -FOR EXAMPLE;
Your network router is something like “192.168.0.1”.
Your destination device might have a static address like “192.168.0.10”
Your destination ROUTER may have an ISP assigned service address like “22.157.14.92”

So, in your destination router, you may have port “21” forwarded to your destination devices port “21”. (192.168.0.10)

From the HOME network, you would access the port by typing “22.157.14.92:21”
This is telling your home network to go to the web and hit up port 21 on 22.157.14.92 - - -then the destination router takes the data and shoves it towards the destination device.

Note that if you have TWO devices on the destination network, you would use two different external ports to avoid confusion.
For example,
you might assign router port 155 to port 21 on 192.168.0.10
you might assign router port 156 to port 21 on 192.168.0.11

There are two tricks here;

  1. You may need to get a static IP for the router. Some services do this for free (or a small fee). I use a service by ASUS, which I guess is a benefit of buying an ASUS router.
  2. Sometimes, software gets “unhappy” if you use non-standard ports for things. . . like not using 21 for FTP services. I had an old streaming device that got really unhappy with a network IP that was 155.10.xxx.xxx as opposed to the typical 192.168.xxx.xxx

First off, thank you for taking the time to respond to my question in such detail! I really do appreciate it!

So my network router IP is “192.168.0.1” as mentioned.

Breakdown:

  • I logged into my router and found my WD cloud device through the client list and noted the IP Address.
  • I then navigated to “LAN Setup” and took that IP Address and changed it to Static or “Reserved” through my routers settings. (THIS IS WHERE I PROBABLY DID IT WRONG!) Didnt I need to reserve the IP Address and make it static through the “WAN Settings” instead?
  • Then, I logged back into WD My Cloud interface online and set the IP Address to “Static IPV4” through the WD interface itself so now it matches with the routers IP Address output.
  • After that, I opened a port through WD My Cloud interface (Port 21 for FTP transfer)
  • Then I went back into my router, navigated to firewall and clicked, “Virtual Servers / Port Forwarding”. - - - There I simply specified the port I opened through WD My Cloud in the Router, (Port 21 for FTP).
  • After that had been done, I then logged into the Netgear Ready Nas and put all the info there for the FTP to connect and backup from the WD My Cloud NAS but it still doesnt seem to connect to the WD Cloud UNLESS ITS ON THE SAME NETWORK ONLY!

Does that make sense? I hope I didnt confuse you with the wording of my setup. Im a novice when it comes to networking so excuse the errors or miss understandings I may have!

Thanks once again for your time!

Also, here are some pics of what Ive done if that helps! (Only let me upload 2 pics, sorry)

Here’s 2 more pics. 1 more to follow.

Port 21 FTP from WD My Cloud.

yeah - - > the issue is the WAN address.

You are setting up the router correct: You are forwarding ALL internet incoming traffic on port 21 to port 21 on your NAS on 192.168.0.117

The KEY here is that the 192.168.0.117 is an internal network address; not the outward facing WAN address. So, this setup would only work if you are addressing 192.168.0.117:21 from WITHIN your the same network.

You need the WAN IP address of the router, the one that is “assigned” by the ISP (internet service provider). You should find that on the WAN Setup page on the Router (from your pictures, I would expect it to show up on the “dynamic” subpage tab on the left side of the screen.). Once you have that address, (for example: 23:123.456.78), then you would use 23:123.456.78:21 as the destination address for the WD NAS stuff.

Where you can get into trouble is the WAN address is dynamic (can change). I am not sure how you get a static WAN address from your ISP. There are ways around this - - - google “static WAN”. I can’t get to detailed at the moment - - - not on a consumer grade network at the moment.

PS: The second post shows you setting up port forwarding with the WD. . .this allows others to FTP into the WD device. Is that what you want?

Hi there. Ahh yes I see what you are saying now! That is very helpful! When I type in the WAN IP Address along with the port number, ie: “23:123.456.78:21” into the URL, nothing should come up right? Because its saying I have restricted access to this page.

So essentially on on the 4th pic I sent, where it says WD MyCloud --> ReadyNas 1.0, would I put the WAN IP Address in where it says “Host”?

Do you see where it says, “Remote” Do you think that will restrict this from working or no?

In the 2nd post, it does show that others can FTP into the WD Cloud. I did this so that I can use the Netgear Ready Nas to FTP into the WD Cloud. Dont i need that if im trying to connect from the Ready Nas to the WD Cloud via those settings?

Thanks once again for your time!

To find your WAN IP: Simply google “what’s my IP”. That will show your current router WAN IP address.

If you put the wan:21 in a web browser. . .not sure anything will happen, since web browsers are not FTP servers. You need to access the device using FTP software. (I really don’t know much about FTP. . . so. . .I can’t help much more. I generally go into the WD devices HTTPS port to access either the dashboard or files (I can’t remember which). . . it’s been a while since I did this, so I am a bit foggy on it)

Not a problem. Your suggestions are very helpful to me. I will be making these changes asap and will see how they go! I will keep you posted!

Thank you!!!