Backup Plus Slim not detected by WD TV Live

Hi,

I recently bought a new Backup Plus Slim and tried connecting it to my WD TV Live and nothing happened. It was not detected at all. I tried another cable and it also did not show up. Every other portable drive I connected had no problem being detected. Re-connected it to my laptop, no problem. Is there a solution to this to get the WD TV Live to read the Backup Plus Slim?

Thanks for any help.

Chaw

Is it formatted NTFS ?   have you tried both side and rear usb inputs on the WDTV Live & Live Plus ?

1 Like

Yes it looks to be formatted NTFS, I didn’t reformat it, used it right out of the box and had no issues until trying the WD TV Live. I also tried the USB in the front and back, doesn’t register. SHoudl I just reformat the drive? Thanks for answering.

Although your drive is seen by your PC, i would still give reformating it a try  (also refering to the link below … run a CHKDSK as well)

Found a forum discussion here with pretty much the same problem

http://community.wd.com/t5/WD-TV-Live-Streaming/Media-player-does-not-recognise-my-Seagate-Backup-Plus-Slim-2TB/td-p/707754

1 Like

Will do. I will run the CHKDSK first and see if there are any drive issues. If not, I’ll reformat and see ifthat does the job.

Thanks again for your help. I’ll report back once I go through the steps and see if the other thread has any steps to try.

Hi Joey,

So I ran CHKDSK and it found no errors. I tried a straight up format and it still didn’t register on the WD Live. I also deleted the volume and created a new one (I believe this is the re-format of the MBR that was mentioned in the other thread). That also did nothing, still not showing up when plugged into the WD LIve. I am stumped. This is the first drive that has not shown up on the WD Live. It’s only a 1TB drive too, not even a 2 or 3TB drive which I have heard may cause issues.

Let me know if you have any other solutions. Thanks again for any help.

Chaw

out of ideas … tell me, is the HDD LED blinking at all ? when you plug it into the WDTV ?

It lights up, so it is getting power, but nothing is blinking to show reading of any any kind.

Remrant had success with leo123456’s suggestion … worth a try i guess ?

http://community.wd.com/t5/WD-TV-Live-Streaming/Media-player-does-not-recognise-my-Seagate-Backup-Plus-Slim-2TB/td-p/707754

I’ll give it a go. Thanks for the advise. I was resolved to just use it for storage and file transfer, but let’s see if this works.

Thanks again!