Auto Unlock Not Working

Have a new WD My Book External Drive (Model WDBBGB0040HBK) and I cannot get the Auto Unlock feature to work. It is connected to a Toshiba Laptop running Windows 10 Home. Everytime the laptop is rebooted, I have to enter the password to connect to the drive. Originally I set up the password with WD Discovery. I removed it and added it again (No help). I think added WD security, removed the auto unlock and re-enabled it win WD Discovery. No help. I uninstalled WD Discovery and rebooted. Then removed the password in WD Security and added it back. Rebooted and no help. How can I get this to work on a brand new drive? This is really frustrating - should just work.

Hi,

Make sure you are the same “user”. Hover over the “Enable auto unlock …” message to see the defined “user”.

Cliff

I have verified that it shows the same user - there is only one on this laptop.

Same here… Even when the computer goes to sleep I have to unlock my 2 My Book 8TB drives… real pain… WD what gives? This is a completely broken feature.
Win 10 OS 18362.535
Both attached via USB 3.0 ports

WD Any ideas? HELP! Really love WD drives but the Auto Unlock for the same Win 10 computer does not work. Please fix.

Same here. Weirdly, it works on my sub laptop properly, but doesn’t work on my main laptop. The funny fact is that my main laptop is newer one. Both have the same OS system. Windows 10 Pro current build. The only different part is CPU. Main one has 6th gen i7 and the sub one has 4th gen i7. That’s all. Sadly, WD hasn’t given us any solution even though we complained about this issue for long time.