WD Unlocker & Windows 10 Pro - autorun - WD Drive Unlock (Not Autorunning)

System: Windows 10 Pro (running PLEX media server)
WD My Book - with Music files for the PLEX server

Problem: On Windows reboot, My Book is not mounting automatically. Have to manually run the WD Drive Unlock application to mount the drive. Then all is well (for a while).

What I’m looking for: Real solutions from people who got the WD My Book to mount automatically on a Windows 10 reboot. Searched this forum and found a lot problems with no real answers.

Thanks if you can help me and countless other Windows 10 users with the same problem. Please again, only post solutions – no questions or suggestions.

1 Like

Here is a workaround solution. I learned, after clicking the help icon on the WD Drive Unlock dialog, that the unlock utility does not have Windows 10 listed as a supported operating system.

What I did to get this to work is to create a batch file and place it in the Windows Startup folder.

  1. To create a batch file open Notepad and type the following:
    (Note F below is where My Book CD appears on my computer so you may need to change that.)

@ECHO OFF
START “” “F:\WD Drive Unlock.exe”

  1. Save the file to your desktop as StartupOrder.bat
  2. Open the following directory on your computer:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

  1. Copy the StartupOrder.bat file from your desktop to the above Windows startup. Windows may throw up a security message indicating System Admin privileges need to be set.

  2. Right-click the file and select ‘Properties’ at the bottom of the menu popup.
    5a. Click the ‘Security’ tab.
    5b. Click ‘Edit…’ button.
    5c, Select ‘Everyone’ in the Group or user names box.
    5d. Click ‘Full control’ and then ‘OK’.
    5e. Click ‘OK’ again to close the StartupOrder Properties dialog.

  3. Reboot your computer and log in.

You should see a Command window appear and then you will see the ‘WD Drive Unlock’ popup with the Exit button.

If you log out and back in, the same thing happens only the ‘WD Drive Unlock’ popup will tell you that the drive is unlocked.

If you only want this to run when you login, then you can put the batch file in the following user startup folder - substitute your user name for [USERNAME].

C:\Users\[USERNAME]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

Hi, glad to read that you were able to solve the issue that you were having, however did you tried the “auto unlock” feature on the software?

Hi Iluna,
Can’t see that feature on my 3TB Book. Looked in Smartware and Quickview. How is it set?
Thanks in advance

Hi, that feature is within the WD security software, mind you not all WD Drives support the WD Security, however you should check in the download section of your device.

My Book Essential is not been recognized anymore by my windows 10. please tell me how can I retrieve my data

Hello!WD auto unlock got disabled after upgrade to windows 10!the 1 TB data is locked,please help

The BAT file got me almost to where I need to go. After the BAT file runs I get the standard question of “Do you want to let this application make changes…” The default is “No.” How can I cause the “Yes” button to be actuated?

Thank you.

I’m not at a computer right now but it appears you need to run the bat as an administrator so there is no prompting.

Thanks for the prompt response. I saw a post that recommended using
AutoIt and I believe that will do the trick. A straightforward AutoIt
script called in the manner you outlined in your original reply should
get it done. Thanks for your help.

Your post is from over a year ago and it’s hard to believe that there isn’t some better answer yet. I just “upgraded” from Windows 7 to Windows 10 and the “auto-unlock” feature on my WD Passport no longer operates. I’ve uninstalled the Security software and reinstalled it (WD’s website indicates that it works with WIndows 10 - https://support.wdc.com/downloads.aspx?p=259 ). Did you ever find a better solution than the workaround you shared?

Here is a method to execute the “WD Drive Unlock” on boot or reboot and bypass the UAC “Do you want to let this application make changes…” prompt.

It is based on this tutorial:
https://www.sevenforums.com/tutorials/11949-elevated-program-shortcut-without-uac-prompt-create.html

Substitute the following values for those used in the tutorial:

Task name:
wd-unlock

Program/script:
Be sure to enclose this text in " " to handle the spaces in the path.
The entry needs to look exactly like:
“D:\WD Drive Unlock.exe”

Add arguments(optional):
start wd-unlock “D:\WD Drive Unlock.exe”

In the shortcut, use this for the location of the item:
schtasks /run /tn wd-unlock

Put a copy of the shortcut in this directory:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

On boot/reboot the unlocker will automatically “Run as administrator” and unlock the WD drive with no prompts.