App Update Available, Apps no longer in App Store

This morning I logged into my PR4100 to add a new share and noticed there was an alert from 4:00am EST today telling me I had App Updates pending.

  • Anti-Virus Essentials
  • Dropbox
  • Transmission

I always make sure I update the antivirus when it’s needed so I stop to take care of that first.
I don’t know if this is just me or anyone else’s experience but the installed apps used to have an icon indicating they needed updating and you could just click that icon and it would kick off the update. That functionality disappeared a long time ago and now to update I have to uninstall and reinstall.

That’s not so much a big issue but here is the issue.
I uninstalled the app but it does not appear in the list of available apps to install. In fact, several apps are missing. I only have about six showing at the moment. So now I just uninstalled the antivirus software and don’t know how to manually install it.

What’s going on with the app store but also, just in general, what is a good resource for the software that can be installed on a WD PR4100 without relying on the WD App Store?


The same on EX2 Ultra… report bug and we will waiting fix it and fixed new firmware


I did exactly the same in my EX2. So I can’t use any torrents now. I hope WD fix it soon


same on my pr4100 NAS … backend services issue I’m sure


Hi, guys. I’ve just resolved the problem. The thing is that the automatic firmware update checking was not working fine on my EX2 Ultra. Even though the system was telling the firmware installed was the latest one, I looked for a new version and, in fact, there was the version 5.27 available that resolved my problem as soon update it manually. So give it a try.

1 Like

tauut, thanks for the info. I successfully upgraded my 2 EX2 Ultra systems and their apps.

5.27 version also have a some bugs…

Same for me, the updates warning and the issue in the app store, I have an EX4100 but in may case there’s no firmware update anywhere, my firmware version is 5.26.300, any clue about this? I can’t find the file to upgrade de firmware manually, in my settings the automatic upgrade is on but there isn’t any advice of new version of firmware :o

I too experienced the issue of receiving a notification of application updates but no update option showed in the Apps section. Thanks to this discussion, I downloaded the 5.27.157 update and everything is no ok.

Same, here. I received the notice saying a Dropbox app update was available. I logged in to my device, tried to update the app w/o success. Uninstalled the app, and guess what…no Dropbox app in the WD App Store anymore! After seeing this thread, I went to the WD EX2 Ultra and manually downloaded the 5.27.157 Firmware update and installed it. Now the Dropbox app is back & available, and many other new apps as well! I reinstalled Dropbox. Happiness abounds.

Same here. Updating the firmware to 5.27.157 fixed it.