Advice please: can't finalize connection between MPW and iPhone

I’ve searched like crazy and can’t find an answer to this. I just purchased an MPW and successfully launched the dashboard on my Mac running Mavericks. Successfully transferred photo files from an SD card. My next hurdle was installing and launching the iPhone “My Cloud” app which in theory would allow me to verify the contents of the SD transfer folders. I installed the app on my iPhone 6 running iOS 8.1.2. I launched the app and was instructed to make sure the iPhone was connected to the MyPassport wifi network, which I verified. The instructions said something to the effect of “make sure you’re connected to  ‘MyPassport’ and then return to the app.” I did so and was then put into the same loop, never getting past that message. Now here’s the interesting thing: the web-based MWP dashboard says that the drive is indeed connected to my iPhone. However, the iPhone app doesn’t acknowledge that. The drive shows up in the iPhone app’s list of devices (under “add manually”) but tapping on the MPW in that list simply brings me back to the instructions “to add your My Passport Wireless drive, go to your mobile device’s wi-fi settings…” et cetera. Any advice is very much appreciated! Thanks.

Should have mentioned: I’ve tried uninstalling and re-installing the app several times, restarted the drive and iPhone too.

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

I assumed that I wouldn’t be able to get phone support on a weekend but I was wrong. Spent about 45 minutes with a very helpful and friendly customer service person. Unfortunately he could not resolve the problem but promised to escalate it to the next level and follow up with a phone call during the week.

prymsnap wrote:

Should have mentioned: I’ve tried uninstalling and re-installing the app several times, restarted the drive and iPhone too.

OK, we can assume the app is installed properly after a few tries, so let’s return the MPW to its factory defaults using the restore system procedure.  Once back to defaults you can set it up again from beginning.

Important – the MPW must be ON when you do the restore or you will cause major problems that are hard to recover from.  Aso, it can not be connected to a computer.  Also, MPW needs to be fully charged.

Pick up the running MPW and do the following:

System Restore (No UI):

*Do NOT have an SD card in the drive.

  1. Power ON device. Wait till both lights are solid (Fully Booted)
  2. Hold both buttons for 10 seconds (or until the device reboots)
  3. When it boots up it will be in a fresh state, with the exception of the drive. The drive is not touched with this restore.

Make SURE unit is ON before restoring to defaults.

Once restored you can set it up like it was brand new again.  If you don’t have the full user manual to refer to, first download it fron WD Support and refer it for set up procedures. 

There are Sample Media files you can play from the MPW to your phone.  No need to connect to your computer until you have confirmed the My Cloud app works to access these media files.

Be sure you are away from other electronic devices – move far enough away with phone and MPW before doing restore and then set up.  I also found using an iPad instead of an iPhone made setting up easier.

Problem solved! Was advised by WD support to manually re-install the firmware update. That did the trick.