My Cloud App can't connect to MPW (anymore)


the my cloud app 4.4.2 for iOS(9.2.1) can’t connect to my MPW anymore.
Initially it worked perfectly fine but after a factory reset the app does not find the device anymore, when i try to add it in the app. I get stuck on the screen asking me to connect to the correct wifi and come back to the app after that. If i do so, it automatically starts searching again and shows me the same screen after a few seconds.

Things i already tried:

  • Reinstall app on iPhone
  • configure the MPW via browser on both my PC and the iPhone(both work)
  • Manually install the latest firmware(v1.05.01) on the MPW again
  • connect both PC and MPW to my home’s wifi and rerun the search
  • rename wifi that MPW creates and directly connect to it. Connection works, App doesn’t find the MPW but connection/configuration via browser on the phone works fine.
  • Even directly after yet another factory reset the app doesn’t find the MPW, without having changed any setting.
  • Contacted WD customer support which made me do all the steps again, without success. After support suggested to restart my home router, our VOIP call was interrupted(naturally) and this is where i am right now.

To me it feels like the app somehow stores some faulty information, even after reinstalling it.

Can anybody help?

To summarize:

Point 3) What SSID did you gave the MPW? Hopefully not the same as your normal Wifi …

Point 2) should be fine, connect the MPW to your Home Wifi and search within the App for the MPW. This should be the solution.

Point 2) It wasn’t the solution because it also didn’t work
Point 3) Different SSID(mpw) than the one of my normal wifi(skynet).


HI, I have had a MPW for q few years and know very well how it works and how it can screw up So, let me try to help you. It sounds like you have done things right so far in this case, so I want you to check that the phone Wi-Fi can connect to the MPW Wi-Fi, and leave the MC app out of the loop at first.

Be sure the My Cloud app is completely off (not just minimized). Turn MPW off.
Move MPW and you and phone away from any potential interference near gadgets like computers and such. Be near MPW, with phone and turn MPW on.
Have phone Settings showing you Wi-Fi signals.
Once MPW has been on a minute or so and blue Wi-Fi LED is lit, does your phone show the MPW SSID signal? (Unless you changed its name the default name is MyPassport.)
If you see it, connect the phone’s Wi-Fi to the MPW.
If you cannot see it and you had set up the MPW to connect to your home network, then you have to connect phone Wi-Fi to home network signal.
In either case of connection, open the My Cloud app and tap the 3-bar menu at top of screen to be sure it will look at your MPW ( have blue bar next to the MPW on list)
If you got this far, we know your phone and MPW can connect their Wi-Fi together and the app will look in the correct location for MPW. And, if you got this far you should be able to use the app to control the MPW option.

Is this the case? If not, tell me where a problem started to occur.

Hi, thanks for the response!
As i tried to say in my initial post, one of the things i already tried is “configure the MPW via browser on both my PC and the iPhone(both work)”. So yes, i can connect to its wifi.
EVERYTHING works, just the My Cloud app does not connect.
So in your list, i get as far as opening the app(there is no 3-bar menu in mine). But i tap on “Connect to local device” and then “My Passport Wireless” under “Add manually”. Then it searches for a few seconds and doesn’t find the MPW.

OK, well, the “browser” is to access the Dashboard for info and configuration and not for general operation of phone and MPW. What I need to know is at what point in my list of steps did things go wrong?

To make it as clear as possible:

  1. I connect to the MPW wifi
  2. This is the screen i see when i launch the app after force quitting it before. I tap on “Connect to local device”
  3. On the 2nd screen, i tap on “My Passport Wireless”
  4. Then it shows me this screen for about 5 seconds
  5. Then i see this screen
  6. Then i change the wifi i am connected to or disable and reenable it and start back at point 1.

It appears to me you have not done initial setup of MPW after the reset/restore exercise,.

If after resetting the MPW to factory defaults you did not go back into the MPW Dashboard, to configure your MPW, you need to do it again. Your MPW is like it is just out of the box until you do this task. You need to answer if you are a guest administrator (you are the admin). If you want a password to access the MPW (and you should) for yourself or guests, you need to add one. This is not the same as the password to actually administer the MPW, that is an additional one.

Also, you should have the complete MPW user manual to refer to, If you don’t then go to to Support and find the manual and download it. Follow steps to set it up from the beginning.

I also suggest you do the factory reset again before hand. A lot of people do not do this correctly, so here are the steps from another post of mine:

I suggest you return MPW to factory defaults. It wll clear any passwords, and afterward your MPW will be like it was out of the box, and you need to set it up again, enter the password, etc, and be sure you remember the password. Follow these instructions carefully, and your MPW must be ON and fully booted before proceeding.

Important – the MPW must be ON when you do the restore or you will cause major problems that are hard to recover from. MPW can not be connected to a computer, and it needs to be fully charged.

System Restore (No UI):

*Do NOT have an SD card in the drive.

  1. Power ON device. Wait till both lights are solid (Fully Booted)
    2.Hold both buttons in for 10 seconds (or until the device reboots)
    3.When it boots up it will be in a fresh state, with the exception of the drive. The drive is not touched with this restore.

Make SURE unit is ON before restoring to defaults.

Once ,you can set it up like it was brand new again. If you don’t have the full user manual to refer to, first download it from WD Support and refer it for set up procedures.

There are Sample Media files you can play from the MPW to your phone. No need to connect to your computer until you have confirmed the My Cloud app works to access these media files.

Be sure you are away from other electronic devices – move far enough away with phone and MPW before doing restore and then set up. I also found using an iPad instead of an iPhone made setting up easier. So can a browser on a computer.

I am not sure if we are talking about the same product, but you can configure the My Passport Wireless via the app directly out of the box. No need to do anything before connection to it using the app.

I have the user manual and used it for the different things i tried.

Do you mean in the web interface? On mine, this question never comes up.
The first question is about SSID name and password.
You can afterwards set a configuration password somewhere in the menu.

Regardless, as i wrote in the initial post, i did the factory reset and tried to connect before and after configuring the MPW. Did not solve my issue.

I am not sure if we are talking about the same product, but you can configure the My Passport Wireless via the app…

Are you kidding me! Of ,we are talking about the same product!

True, about initial setup; from the MPW manual, page 7

Setting up the Drive the First Time
To connect and set up the drive for wireless use, do one of the following:
Use a computer and a web browser.
Download and use the WD My Cloud app on your smartphone or tablet.

I setup this way (but not exactly) I can see an iPad better than my tiny iPhone, so I use the browser method; not on a computer, but on an iPad. I can go sit down at dining table with MPW and iPad and enjoy a glass of beer at the same time I setup!

You need to answer if you are a guest administrator (you are the admin).

Do you mean in the web interface? On mine, this question never comes up. The first question is about SSID name and password. You can afterwards set a configuration password somewhere in the menu.

No, I mean in the app. Say your MPW is setup fine, and you want to add someone else as a guest user, they install the app, fire it up, and they see your first screenshot above. They click on “connect to local device”, they are asked if they are a guest or admin (they answer guest) they are asked the password you told them, they get signed in and can now use app to access the MPW. They just cannot administer like you can.

The screenshots you included indicate that you have not reset up the MPW since the factory defaults restore event. You have to do this setup. Like I said, start fresh and restore to factory defaults, then I suggest using browser, not iPhone if possible., Then turn on app to access the MPW, and you will follow same path as a guest, but you answer that you are an admin.

Dan, you posted here for help, and you lucked out and got a forum “resident expert” of the MPW to assist you. Next time I hear back from you, I want you to tell me you followed all my instructions to get this thing going again. OK? Unless your MPW is broken (and it isn’t) the procedure will get you up and running again.

I followed the instructions to set up the MPW. Like stated in the initial post.
The question if i am an admin does not come up because the MPW does not connect to the phone via the app, so everything i see is what you can see in the screenshots. I don’t have a 2nd phone at hand but will try with a friends phone on Saturday.

This is what i did in the beginning. Then again after the factory reset. Then again with the tech support on the phone as well, twice. I have reset the MPW both by pressing the buttons together for 10 seconds as well as by triggering it via the web interface.

So yes, i followed the procedure and it still does not work. Thats why i am asking here.
Was hoping somebody would have a tip like connecting via SSH and manually resetting the correct service to some default settings or changing a config file which is not accessible via the browser.
It feels like either the app is just very buggy or there is some setting deep down in the system which is stuck somehow.

Not sure what the specific connection issues mentioned here
WD support page
were, but it sounds as if there have been issues connecting to drives in the past.

Questions for you:

Right now, can your phone Wi-Fi connect to the MPW Wi-Fi? (Forget about the app for now, I want to know if the two devices can connect to one another.)

The last time you set things up again after the last factory restoret, did you see and fill-in “Secure My Passport Wireless” did you change the name of the MPW default name of “MyPassport” to something unique (example, to :Dan’s MyPassport") and did you enter a password to secure it?

I don’t believe you did, because you need the app to do the “Secure My Passport Wireless” on-screen steps, and because you can’t use the app now with the MPW, you cannot complete the initial set -up of your MPW.

This is why I asked you to do the factory reset again. We need to start at Point A again.

Also, I want you to uninstall the app from the phone again. THEN, completely shut the phone down completely. Do you know how? You hold DOWN the top black narrow on/off button for a few seconds until you see a slider on phone screen. Slid slider to the right and this completely turns off the phone. An Apple icon appears for a minute or so, and when it is gone you phone has rebooted. Now, go download and install the My Cloud app again.

Once all this is done, follow the instructions on page 11 of MPW manual entitled “Using WD My Cloud App on a Mobile Device” until the end of the chapter. Have the manual on your computer so you can follow the instructions and see the illustrations.

You have to follow my instructions starting with the factory restore again, then uninstall the app, etc, then refer to the manual. D this, in order, and your MPW and phone darn well better start working together again!

BTW, I want to know why you even did a factory restore in the very first place?

I did these steps, as i stated in my original post!
By the way, i am at work now and asked a colleague with an Android phone to download the app and try to connect:
Worked flawlessly!

So everything is good with the drive and i don’t need to restore factory defaults for the tenth time.
Maybe somebody from WD could respond and tell me if the cause might be the iPhone app and if they can fix it. There have been issues in the past with getting a connection, so maybe their fix did not fix every eventuality.

Hey, some good news. There very well could be an issue with the My Cloud app on your phone or with your phone… You can try uninstalling app, and turning off the iPhone as I described, since that clears out issues in iPhones. Another clearing out iPhone issues procedure is to hold the top button AND bottom Home buttons in at exactly the same moment. (if your timing is off you will end up taking a screenshot instead of a reboot.) Do Both of these reboot procedures, it can help.

Then, reinstall app. You likely need to be at home if you do this so you can proceed with the rest of the setup. Good luck; you now know your MPW could connect to someone else’s phone…

Tried that.

Maybe i will restore the iPhone from a backup tonight. Even if that would fix my issue, i think WD should still investigate if they can prevent keeping persistent data in the iPhone app that prevents the connection.

I know you reinstalled the app. but did your reboot your phone as described? Even so, the problem does not appear to be with the MPW now, it appears to be with phone and/or app. So, if it was me, I would do the uninstalling, rebooting on phone and then reinstall app AFTER any phone issues are cleared out.

So i tried it on another colleagues phone which is an iPhone 6s running iOS 9.2.1, like me. He downloaded the WD My Cloud app 4.4.2, like me. And he gets the same behavior that i have, no connection! So maybe it is a general problem with the iOS app.

Is there anybody using iOS 9.2.1, WD My Cloud 4.4.2 and My Passport Wireless firmware v1.05.01 successfully?
Would be very nice if somebody has the same setup and can confirm that it is working for him/her.

Now that i think about it, the app/MPW combination worked out of the box for me but it could be that i did both the factory reset and the firmware update between getting a connection and not being able to connect anymore. So it might be that My Cloud 4.4.2 for iOS and My Passport Wireless firmware v1.05.01 are not compatible.

Of course, there are lots of people that can do this. I told you that I have no problems doing this with my phone and MPW, and why I have been helping you! There seems to be nothing wrong with your MPW or your phone or the conditions you mention above.

I believe you need to uninstall app, REBOOT YOUR PHONE (with app removed) as I described to you, then reinstall MC app. THEN YOU CAN COMPLETE SETTING UP YOUR PHONE TO USE THE MPW AS DESCRIBED IN THE MANUAL. Until you do these steps your phone will not be able to be setup to use the MPW.

You have to do this to get it working, and if this doesn’t work (although I think it will) there is something really strange going on that still needs to be figured out.

So do this, because I will not assist anymore until this is done. I want you to prove to me that I am right or wrong, and in the process it may just get things fixed.

Sorry, but doesn’t it count as a fresh install that a colleague of mine downloaded the app for the first time in his life and tried to connect?
Regardless of that, i did uninstall the app, reboot my phone and reinstall the app and it didn’t solve the issue.

Are you using iOS 9.2.1, WD My Cloud 4.4.2 and My Passport Wireless firmware v1.05.01? Since you described the app interface differently, i assumed you were either using Android or a different version of the My Cloud app.

Yes, the exact same versions, and I DO NOT have an issue with any of these versions nor the previous ones. My stuff works.

I even know what build of my Cloud app version 4.4.2 is installed (it is 44253, and no, I am not going to divulge how I know that. It’s my secret.)

One last piece of helpful advice for you. Since everyone’s phone and MPW play well together but yours, you apparently have a unique issue, So I suggest you call WD support again. Tell person answering phone you have been though a lot of help-getting already; even at the forum with out getting a solution., and ask the person to