Add SSH user

Hi everyone,

I can connect to the MyCloud via SSH/SFTP without problems, thing is, using the user sshd for file transfer messes with the file ownership, producing errors on windows. For sure, I can change the file ownership with chmod back to the normal user I am using when connecting to the MyCloud via windows, but I don’t like this manual solution.

So there are two ways:

  1. Connect to the MyCloud on windows using the sshd user. That does not work.

  2. Add my username to the ssh users in /etc/ssh/sshd_config and restart sshd. First thing’s no problem, but I could not find any way to restart sshd. If I restart the whole machine, the sshd_config seems to be resetted.

Is there any way to achieve what I described?


Now tried the same via FTP. Works fine if in local network, but using ddns i get the error message GnuTLS error -110: The TLS connection was non-properly terminated.

Hi there and welcome to the WD community.

I have not tried this, but lets see if another user can share some tips or information on this mater and help you out.

I’m having the same issue. It seems that every time the device boots up, any changes to the config (including whatever I try adding to /etc/ssh/sshd_config) are wiped clean.

Anyone having luck setting up additional SSH users? I’d like to have a cron job run on my device (My Cloud Mirror) but I’d rather it not be run as root.