Remote ssh for users

I have a simple request: users should be able to remotely ssh into the drive, like normal human beings, and read/write files.

root ssh works fine, but user ssh tells me I entered “incorrect password”

Is this too much to ask from a network drive that I paid $400 for? Apparently so. I called tech support and they explicitly said that ssh is only supported for root. Users MUST use their GUI to access their shares. Why? Just so that we can all make MyCloud accounts and meet WD’s email registration quota? This is absolutely ridiculous. My “users” are a group of MIT researchers and they need to be able to ssh into the drive, so that we can share and synchronize data. I cannot give them all root access, because there are certain shares that are only open to certain users. I don’t understand why this is considered above and beyond the specs of the product.

So I am hoping someone in the community has figured out a fix for this. I don’t mind hacking the drive settings as long as it’s been tried and tested. 

I appreciate any suggestions. I am very frustrated with WD right now after paying so much money for this device.

Thank you,

Better question is why do we have to rely on WD authentication at all?

I suspect you are in the wrong forum, this is for the single drive mycloud only. for $400 dollars I suspect you have somthing else

the different myclouds are very different

I am using MyCloud single drive.

I thought about being sarcastic since you really got taken avantage of if this is the basic single drive mycloud

there are a number of different myclouds, the base(just called mycloud), mirror, EX2, EX4 and maybe others and they are all very different underneath so you need to see what you actually have and post in the proper area. as any help here may not work for you

if you want to , its pretty simple to setup new users for ssh.

Yes. I want.

The most expensive single-drive WD My Cloud (6TB) retails for US$319.99 in the official WD Store.

I believe you have a different product, and User clarification is recommended in order to move this thread the the appropriate board (WD My Cloud Mirror, EX2, EX4). This will allow for more Users to better help you.

If you did pay US$400 for the regular/single-drive WD My Cloud I’d recommend requesting a refund from the current retailer and obtaining the device from a different retailer using appropriate/fair pricing.

On the other hand, your post sounds more like a good Feature Request; the best place for this, is in the Ideas Exchange section. However, I would first search and make sure that there are no other active Feature Requests suggesting the same or similar improvements. If there is, then you could add your post and vote on it.

Personal Cloud Ideas

OK I just checked our receipts (I didn’t purchase the device myself), and yes it was around $200. So maybe my problem is half as important now, but yes I have listed the correct device.

I am not looking for feature requests/personal cloud ideas – this seems like basic functionality, and I am hoping that someone else who has this product managed to make it work. There is obviously some sort of hacked linux running on the device, so I don’t see why enabling user access would be a problem. I find it hard to believe that the WD devs made a special effort to remove this functionality on purpose.

ssh mods will “void” warranty. I’m not liable for any of your loses. I assume if you are talking about ssh, you have some knowledge about it. Proceed at your own risk.

I have set that up for myself and one other user but i made that change a long time ago.

in any case it should be as simple as adding a user by running

useradd username

it will as then ask for a password.Set it to the same as the password set for the user via the dashboard for share access

Create home folders for each user:   mkdir -p /home/username

Then you will probably have to give those users ownerhip and access to the the group “share” by using the chown command

e.g   chown -R tom:share /shares/tomdata    

1 Like

Thank you, this is what I was looking for!

I will try it out later. I don’t really care about warranty for a product that doesn’t work.

Hi alirz1,

I tried your suggestion, and it does not work.

I tried two versions:

ssh root@ 

useradd guy     ← this does not actually prompt for a password

passwd guy 

mkdir -p /home/guy

chown -R guy:share /shares/stuff

ssh root@

adduser guy     ← this does prompt for the password and other info and created the home dir

chown -R guy:share /shares/stuff

In both cases the result was the same:

ssh root@ 

guy@’s password:

Permission denied, please try again.

So it seems to be doing the right thing, but maybe missing a step for the actual ssh connection.

Any suggestions?



I tried to do this previously by messing with my .ssh authorized keys:

But it completely messed up the firmware, and I had to do a factory reset.

sorry forgot to mention before that you will then have allow ssh for those users

nano /etc/ssh/sshd_config

Look for “AllowUsers”. Add all usernames there separated by a space.

Then restart the ssd daemon

/etc/init.d/ssh restart

1 Like

Thanks, I finally got it working.

Had a bit of a scare over the weekend because the DHCP reset and nothing worked, but I changed it to static IP and it’s working properly now.

Just one more question: is there similar steps I can take for FTP access? Right now my own user has FTP, but the users I created with “adduser” do not.

Anyway, thanks for your help! ssh was the main thing that we needed, and we always scp our files.

I am able to access.
you need to enable ssh from dashboard first. And then if you using mac.

ssh root@IP
password → whatever you configure while setting up ssh.
User is default - root.
IP - You can go settings, same place where you enable ssh, check the IPV4 IP. Use same while doing ssh.