Accidentally connected 19v supply to 2TB WD Elements and now pretty dead :(

I have read about other people doing exactly this and have read some of  fzabkar’s replies. I do hope that you are around and can maybe help me.

As per the subject line, I have connected my 2TB WD Elements HD to a 19v laptop PSU by mistake and the drive has blown. I have read about the diodes and resistors that can blow but I am unsure which they are on this drive. I have worked in electronics service for most of my life but have never dealt with hard disks.

The drive is dead, and even when plugged directly into a caddy without the input board attached it is dead. Are there any components on the input board that may have gone or is it more likely to be the main board attached to the HD?

Any pointers would be gratefully accepted. 

Thanks

 

Welcome to the Community.

I would recommend assistance from a specialized data recovery service.

http://support.wdc.com/recovery/index.asp?wdc_lang=en 

Try searching the posts by fzabkar . He has guided people throught by passing burnt doides on the boards.

Joe

Thanks for the reply.

I had already read a few of fzabkar’s posts and realised he was the main contributor with the knowledge to help. I can’t find anything relevant to my drive so I hope he pops along sometime soon :slight_smile:

Try sending him a PM and see if he responds.

Joe

1 Like

The foam obscures the component of interest. However, the typical result of an overvoltage to an external drive is a shorted 12V TVS diode plus open zero-ohm resistors.

I would examine D4 and R64, plus R60 and R88.

http://i00.i.aliimg.com/wsphoto/v0/1919316664_1/Free-Shipping-2060-771945-001-HDD-PCB-Board-For-Hard-Drive-Logic-Board.jpg

If a PCB repair turns out not to be feasible, then the most you should pay for a “data recovery” is US$50. All you would need to do would be to purchase a compatible PCB and transfer the chip at U12 from patient to donor. Some PCB suppliers include such a service for free.

1 Like

Many thanks for replying.

I will get back as soon as I have had chance to check the components.

Well, I finally got round to checking the components that you suggested may be at fault. All were OK apart from D4 which was s/c.

Removed the diode and tried the HD in a caddy. Drive spun up but computer reported that it needed formatting. Reconnected the USB interface board and tried USB and 12V psu and hey presto, it works!!

A big big thankyou to you, fzabkar.

I have reclaimed nearly 2TB of data that I thought had gone forever and it is now safely copied to another HD.

A Merry Christmas to all on the board and thanks for the best present I could have wished for :slight_smile:

The caddy appears to be configured with a different sector size. Some external drives use 4KB sectoring while others use 512 bytes. When you mix them up, sector 0 remains in the same place, so the OS still sees the partition table. However, the boot sector will be at a different location, so the partition appears unformatted.

You can determine the physical sector size by executing the following command at the CMD prompt:

fsutil fsinfo ntfsinfo X:

… where X: is the drive letter.

A disc editor such as DMDE (freeware) will show the range of sectors at the top of the screen. This range will be less by a factor of 8 for the 4KB enclosure.

Congratulations on recovering your data, BTW.