80TB G|SPEED Shuttle XL STOPPED working on my 2019 Mac Pro

Mac Pro (2019)
Processor 3.5 Ghz 8-core
160 GB Ram
Running macOS Monterey Version 12.4

I own a USB-C 80TB G|SPEED Shuttle XL.

The shuttle was working fine, and my 2019 Mac Pro suddenly wouldn’t recognize the Shuttle.
My 2019 Mac Pro doesn’t even recognize the Shuttle in Disk Utility.

I changed the USB-C cable to a new one. Did not work.

The USB-C 80TB G|SPEED Shuttle XL has no red warning lights. All the hard drive lights are blue, and the main light on the outside is white. It sounds like it’s connecting and starting up when I insert the cable, yet none of my computers will recognize my shuttle in Disk Utility.

I have tried connecting the shuttle to my old Macbook Pro using an original Thunderbolt 2 to Thunderbolt 3 USB-C adapter. Doesn’t work. It’s not even recognized in disk utility.

I tried hooking the G-Tech Shuttle to my new MacBookPro M1. Doesn’t work. It’s not even recognized in disk utility.

Any help would be appreciated.

Hi @Chatra3,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: