4TB My Passport for Mac takes forever to load

Hello all, thanks for viewing my thread, any help greatly appreciated.

Running Mojave 10.14.1 on a 2018 15 MacBook Pro with TB

I was trying to transfer files from my old WD desktop external HD to my newly purchased 4TB My passport for Mac. The ETA for transferring 10K files was about two hours. The first hour went well but suddenly the 4TB for Mac stopped responding about an hour later. I forced quit the drive and since then the 4TB for Mac takes looooong time to load, read and write.

I can still access all the files on the 4TB for Mac, but it takes one to fifteen minutes to see the drive shows up on the desktop. And in each folder most of time only “icons” show up, not the preview.
Sometimes the drive even cause the Finder frozen (wont even relaunch), from time to time I have to hold down the power button to shut the MBP down (or restart)

What I have tried

  • Disk Utility’s First Aid, result is completely fine X
  • Used another cable X
  • Used an new account X
  • Reset the NVRAM X
  • Updated from High Sierra to Mojave X
  • Used different ports / with/without hub X

I wish I have another MacOS device to try but unfortunately it’s hard to find one ATM.

There is one thing that my old WD external HD works fine after the crash, but all the icons also don’t show image or video preview like the 4TB for Mac, so I’m wondering if it is still 4TB for Mac’s problem, or the MacOS?

About six months ago I purchased a 2TB My Passport (not for Mac), and it also can’t recognize my MBP (it worked when I purchased it, on a different MacOS device which I can’t get access to ATM)

Many thanks in advance!

You can install the WD Discovery on your Mac and let it update the firmware on your My Passport for Mac drive.

Moreover, You can also run the Exteneded Test through the WD Drive utilities on your drive to find out whether there is any issue with the drive or with the MacOS.