403 Error when trying to connect to WD MyCloud via Android appp

I am unable to access my My Cloud drive from my Chromebook using the Android My Cloud app from Playstore. It used to work but has stopped.
One error is “User does not have permission (403)”
I successfully logged into the App but when I try to access the drive the error appears.
If I remove the drive and try to add it manually with the access code, I appear to connect and I am asked if I wish have to back up photos and videos.
I decline and get to told the user does not have permission.
If I remove the device and try to add from Available devices I get an error "My Cloud is having trouble connecting to WDMyCloud. Please update Firmware.
…but accessing the drive service interface, the Dashboard tells me the Firmware is up-to-date date

I run the same app with an Andriod phone and I have no problem

All help greatly received

@dguy What version of firmware do you currently have?

Generation One should be, 04.05.00-334 .
Generation Two should be, 2.31.183 .

I have 04.05.00-334 firmware

best regards

David Guy

@dguy Have you tried the Mobile app provided by WD?


Hello Cat0w,
I have used the Android app on my andriod phone and the apple app on an ipad and both work fine.

My Chromebook used to work with the same android app as my phone but now it does not. I have exactly the same problem with my Windows 10 laptop.