3 Hours to transfer 1.27 GB file

A few weeks ago I bought a WDMyCloud 3T, and hooked it up to my Router. I was able to transfer data to it for about a week, mainly my iTunes music and movie libraries, and the performance wasn’t good, but it was acceptable. 

Using a MacBook Pro, a CenturyLink DSL model/router/WiFi, and the WDMyCloud. 

It’s now taking 3 hours to transfer 1.27 GB and it frequently fails halfway through a transfer of several movie files so I have to start over. 

This device seems to get lost from time to time, so attempts to log in and find the device fail after timing out. I unplug it and wait a while and plug it back in and if I wait for about 30 minutes, I can again log in, but it will sleep again and be lost.

I use iNet on my Mac to see all my network devices, and I can see the WDMyCloud when I’m able to log in, but when I can no longer log in, it is gone from my network. Only after hard reboot will it show up in my LAN and I can log in again.

I hope WD is working on this flaky system. Theoretically, it could be great, but practically, it’s not worth the money. I will not recommend this product to anyone. 

BTW, I also use iPad, iPhone, a network printer, a PC, a Surface Pro, and a Samsung Galaxy Express on my network and they all work perfectly. I’ve also swapped out the network cable to the MyCloud drive, an nothing makes this thing work right.

Researching firmware upgrades now, but it said it was updating it when I installed everything a couple weeks ago. Well, anything this buggy may have firmware upgrades hourly.

Nice try WD, but no cigar. I also posted an email support request two days ago, and no answer yet. They are probably very sorry they released this product before it was ready. Maybe these guys are working closely with the Obamacare website engineers and sharing their quality metrics and when it works for 1/2 the people, QA signs off for production release. LOL.

Well, it appears I have fixed it. It is now up to about 30 GB per hour when uploading. Here is what I did…

  1. Installed the latest firmware release (3.01…) - result: no improvement

  2. Changed from DHCP to Static IP since it appears that if the IP changes, the desktop app can no longer find the drive - result no performance improvement but after installing the desktop app again it should never lose it like before after a power outage or if another device isn’t on the network and this device reboots. You cannot guarantee what IP address will be assigned with DHCP and that certainly seemed to be a problem. I also set the MyCloud drive to never sleep for now so it won’t magically disappear after some non-use like before.

  3. In Settings, I turned off all media streaming. I use my Mac with a Shared iTunes account for streaming to my Apple TV, and don’t need the media sharing directly from my WD My Cloud just yet. 

 #3 appears to have resulted in HUGE difference in file transfer speeds. It went from about 0.5 GB per hour to 30 GB per hour transfer speeds. So for whatever reason, it appears the Media Streaming Server functionality of the WDMyCloud interferes with file transfers to the Public Video Uploaded folder.

So for now I’m happy enough. 

OK, spoke too soon. The file WDMyCloud desktop app’s transfer dialog made huge progress with the first 3 or 4 movies (about 1 GB each), knocking them out in no time flat, and the remaining time was showing about 30 GB/hr, but like before, it starts stalling part way in. 

It now shows 17 hours left to copy the remaining 20 GB or so. Oh, wait, now it’s showing 9 hours.

Well, I’ll let it complete and see what the actual throughput was in the end, but in the past, this is where it eventually fails, and the drive disappears from my network, and most of the files are zero length on the device so I have to do it again.

I think my first message was the more accurate. I did get some improvements from my actions, but it’s still a mighty unreliable product from WD, something I wouldn’t expect since I’ve used WD drives for decades and they always perform well.

Maybe this was just too much for their development team or product management pushed for a release before it was fully tested.

The rest of my network is not in question. It works beautifully, and I work as a software engineer remotely from my home for three Menlo Park, CA firms, and have been doing this for 8 years. My network has stood the test of time getting about 10 hrs/day average hard use, and then serving to provide Netflix and iTunes from my Mac at night.

Are you doing these copies over the internet or something?

FWIW, I noticed that when I copied a full TB of data from one drive on my Win 7 PC to the MyCloud, it took almost 3 days.  It started out fast, but after a while you could see the Mb/s dropping until it was in the Kb/s range. The next time I copied that much data, I did it in smaller batches, maybe 10-15 movies (3-8 Gb per) and the transfers were much quicker.  I completed (2) more 1 Tb drives in a day.

Maybe there isn’t enough free space/buffer space in either Windows or the MyCloud to handle such large numbers of big files?

The other thing I noticed is that using WiFi to do the transfer is useless, I was getting transfer rates similar to the orignial post.  I always come off WiFi and hook directly into the router now, much better transfer.

I was going to retest using FTP instead of Windows copy, haven’t had a chance yet.

I am experiencing same **bleep** performance uploading files to the mycloud drive, form my mac and through wifi.

I haven’t figured out how to fix it either, but logged a call to support.

I have the 4To version and updated the firmware straight away to 03.01.04.139…

I wonder if this is a wifi, Mac OS (10.6) or a drive problem.

Same issue… slow transfers, that often fail, and the device unmounts itself and the computer has to be forced to go look for it again.

Some things that have helped… static IP, turning on SSH, setting re-scan on Twonky to “0” (so it only rescans folders when the device is rebooted, not as any file is changed), and plugging a gigabit Ethernet cable directly from my Macbook Pro to the drive (to bypass wifi and router all together). 

I’m moving over about 800gb from another device, and it’s getting closer to USB 3.0 speeds when I did the above.  But it’s still flakey and annoying and if I could return the drive for a refund still I would.  But I didn’t start running into these issues in the first 15 days I owned it!!! :stuck_out_tongue:

Good luck

I’m hardwired direct to the router with 1Gb card from my PC. All my previous frustration was on my MacBook Pro, but now I’m trying to back up my PC and it’s taken 3 days of restarting copy operations. I’ve logged in the web interface to mount drives, and I’ve gone through the desktop app and dragged folders to the WD MY Cloud target folders, and in every case, if the drive was just woken up or was restarted, it starts copying at very good speeds, but after about a GB of date, it slows down.

I’m looking now at a message telling me it’s got 2 hours and 45 minutes left to copy 1.7 GB remaining files.

So, Gb network, all hardwired, using static IP for the drive, turned off all media streaming in the dashboard, am using latest firmware, and nothing changes this performance issue.

I’m going to try rebooting the drive after every GB copy and see if doing one GB at a time will get the work done faster.

But my conclusion from personal experience–spending endless hours just trying to copy about 500 GB from two computers to this 3TB drive–and from reading the woes of so many others, WD really blew it on this product. Stick to their main product lines, just hard drives and stay away from this BS.

My experience with their technical support is about like most people describe, which is getting a boilerplate response by email, totally unhelpful, like “be sure the unit is plugged in” kind of garbage.

Anyone know of a competitive product that does the same thing (personal cloud accessible from lots of different devices) but actually works as advertised? I will gladly replace this WD junk with anything else that works.

Oh, and the other thing. I copied a bunch of folders in one operation from my PC (ethernet cabled to the router), that was going to take all night, so I left it to finish. Next morning I found that it had arbitrarily ignored much of the content. It appeared to have completed successfully but when I compared the content from my computer to what made it over to the drive, about 1/2 was missing! But the computer was not restarted, nothing failed to explain this. I repeated the process with less data, overwriting the previous and it did it again, not copying much of the content, but this time it missed different data!

So I’m copying one folder at a time now (repeating all the previous work), and then eyeballing the diffs and manually copying whatever didn’t make it the first time. I’m afraid to use a diff tool on the mounted drive since everything is so incredibly slow it will probably take days to do the diff.

WD should just extend a recall on this product and refund everyone’s money who wants a refund. I suppose there are a handful of folks that have the exact same network topology as the WD QA team uses to test so they probably get good performance, but my guess is there is one little thing that is causing all this pain, and they can’t find it or fix it.

Hold on a sec.   Why are you using the Desktop app if you’re on your local network?

OK, so there are two ways to access the drive for copy operations that I know of. If there is a third, please enlighten me with your great wisdom.

So the two methods I know of are to:

  1. log into the web client ( https://www.wd2go.com/logout.do),,) select view shares from the device menu, wait a while, and then click the folder I want to mount (Mac), or map drive (PC). This then gives my OS access to the device directly and copy operations are native OS operations.

  2. install the desktop app for Mac or PC. This provides greater control over the device by providing a shortcut to the dashboard which is where I can control the various settings, update firmware, etc. It also provides a shortcut to a native app (or probably java) that allows more convenient access to the device shares, and one can drag and drop folders onto the target folders and let the WD app control the copy operation rather than the native OS.

I’ve used both methods many times always hoping for better performance from one over the other but they both work the same, after a reset, I get good performance for the first GB of data, and then it starts to slow, eventually taking many hours to copy as much as 5 or 10 GB.

So, please share your wisdom rather than question my approach, eh? Be a good guy and share instead of asking inane questions. Thanks for your help.

Erik_J_Thomas wrote:

OK, so there are two ways to access the drive for copy operations that I know of. If there is a third, please enlighten me with your great wisdom.

 …

So, please share your wisdom rather than question my approach, eh? Be a good guy and share instead of asking inane questions. Thanks for your help.

Oh, sorry.   I made the assumption that someone who works as a software engineer for three Menlo Park firms for eight years would know the basics of network storage.  My bad.

Just map a network share using Finder.   While I don’t use Mac personally, I’ve seen lots of comments here that performance is much faster if you use Samba instead of AFP, but your mileage may vary. 

Something like this for Macs, or this, via WIndows:

cap1.png

I think that he is saying that if you are on your own local network which also is connected directly to your MyCloud then why don’t you just map the Mycloud on your computer and transfer directly to it, instead of using apps or web clients.

By the way he has got great wisdom and sometimes the way to find out answers to problems is to ask questions which some people may find inane.

Later. Appears that he did mean that.

Here’s my typical performance from My Cloud on my PC:

Untitled.png

Heck of a lot faster (and more predictable, consistent speeds) than using the WebDAV apps.

And yes, as you already discovered, before I start doing any significant transfers to the NAS, I disable the media server as well.

If the MyCloud is on on your local network and you are using a PC, you could try TeraCopy, its much better at copying than windows. It replaces windows copy and all you do is drag the file to your mapped mycloud and teracopy opens and copies the file. You can see what is going on and how long its going to take etc. Its free so if you don’t like it or it gives you no improvement you can just delete it.

http://codesector.com/teracopy

Could also be a router issue if transfer speed is dropping. Try another router with just the pc and my cloud connected to make sure no other devices are using bandwidth.

"I made the assumption that someone who works as a software engineer for three Menlo Park firms for eight years would know the basics of network storage. "

IT professionals are not software engineers. Networking expertise has nothing whatever to do with the vast majority of developing native, web and mobile apps.

And mapping a drive using ‘net use’ (or the equivalent way of mapping a drive using UI like you show) makes no difference whatever! What do you think the web client login is doing? It is just proxying calls to the OS to do the same thing as if you open a cmd window and type ‘net use …’ to map a drive. How can you think that this is actually different and will affect performance?

Once your drive is mapped, you can drag and drop files or use cmd.copy or xcopy. I’ve done all these things and there is no difference in performance.

This is a problem with the product. And think about this mister smarty pants: if the only way to get good performance out of the device is to follow YOUR advice, don’t you think WD would instruct users to use those methods?

And why would they spend time creating web and desktop clients that make mapping the drive easy if “their” mapping is different from “your” mapping? It’s all the same dude! There is no difference under the hood.
And the performance **bleep**.

I’m going to try some of the suggestions I’ve read from other folks that I haven’t tried, and maybe I’ll get lucky.

But the product should work well “out of the box” and with the least amount of hassle. If every person who purchases this **bleep** has to have YOUR well of knowledge in order to be successful with it, then to heck with that. I don’t need more learning curves just to use a stupid consumer product.

Hello,

Hey guys, please keep it friendly. We are all just trying to help each other.

You brought your experience into the argument… If it has nothing to do with the discussion, then you should not have used it as a “merit badge.”

Uhm, no. The web login and mobile apps both use WebDAV. A native mount uses Samba or AFP. Two totally, distinctly different protocols with completely different performance characteristics. WebDAV uses encryption to protect your data out on the Internet. Encryption is very resource intensive and slows things down. Neither Samba nor AFP employ encryption and are thus much faster.

They DO recommend the method I described. And further, they recommend the apps for mobile and remote connectivity, not local connectivity…

Yes, if you use the “desktop app” it’s using WebDAV, but when you log into the web client just to map your drive, once it maps, it’s just a mapped drive.

I can see the drive in cmd window mapped as my “z:” drive. I can use commands exactly as I would any mapped drive. I can see it mapped in Explorer and any app that can access a drive.

So what you’re saying is that when this drive is simply “mapped” as a drive in my OS, because it was mapped by a client app, that it’s using WebDAV? I don’t think so. How can it “hook” the OS in such a way as to redirect all the OS commands you can make regarding that drive? I’m not saying it’s not possible, just unlikely when an app can just map the drive and let the OS take care of the rest. 

Anyway, where are the WD docs that suggest doing it this way? Can you provide a link to this documentation? Note that when I unpacked this device it had no instructions at all. I went online and perused the docs I could find but never found what you’re referring to. 

Thanks for your help.

Erik