3 day old WD my cloud turns to red LED

hi everyone

my cloud turns to RED LED after 3 days of use.

My analysis

When powering up, LED is blinking white for less than 10seconds and steady white for almost 1 minute then it goes Steady RED

My troubleshooting

  1. Tried live reset

  2. Tried 40-45 seconds reset when powering on

above troubleshooting all result in nothing

This is very upsetting for me, i went through the forum and i rarely see WD contributing to helping the community in their problems. Wanted to call WD helpline but today is labour day so i will call tomorrow.

If they RMA this thing, what about my data inside? I loaded alot of photos and can the recover and restore into the RMA set? anyone has similar experience?

Any suggestion for me will be greatly appreciated.


Simon Goh

It looks like a disk failure indeed, and a certain RMA. About the data, you don’t have much of a choice. If you open the enclosure to wipe the disk “manually”, you void your warranty. Since you cannot do a ful system restore, you’d have to send the disk as is, with your data… We have seen users getting units repackaged through some retailers with data from other users… No easy way out.

1 Like

thanks for reply

can i know is this a common thing? i mean this is first time i brough a product and use it for 3 days then faulty.

would a replacement solve this issue? i updated to latest software on first day i brought it and last thing i hope is it is faulty again after replacement

I’d bet a replacement would solve the issue. We have seen a few users with red lights in this forum, and plenty with some issue or another, but then, happy users don’t tend to show up in forums :slight_smile:

I am plenty happy with my unit, for what it’s worth.

How long have you left it off before trying to start it up again?

See the User Manual, Table of Contents, LED’s.


Posted by,
cat0w (USA)


same here…I bought a few days ago my 3TB device. Had no issues to plug it in and be recognized by computer and devices.

Transfer speed was **bleep** low (2 MB/s)…

I turned DLNA server off and the device was still indexing for its database snapshop. this took 4 days (!).

I came back home the lst day and I had a solid white led…

Good…no response over dashboard…I plugged it out/in again… red light!

This remained red  after I think 20 attemps…soft/hard reset…cooling down overnight, etc… I found there were two behaviours of the hard drive (you can hear it).

1 - spinning shortly at the beginning (solid white led) an then in around one or two minutes red light

2 - spinning repeatedly for several minutes (solide white led) and then stopping

After “2” happened, I decided to leave the device as is and go to sleep… I woke up and it was blue. All data here, etc… transfer speed up to 50 MB/s…wonderful I would say.

What did I do just before?

Led was red

  • I made a soft reset (4 seconds)

  • I plugged the ethernet cable and the power cable out for a few seconds

  • plugged the power again

  • half a second later the ethernet

  • harddrive was spinning…in the end as option “2” above

  • closed all the open browser windows I had (to avoid computer memory failures)

  • left everything running for a while…harddrive stopped (no sounds anymore)

  • went to sleep

I just tried the first steps again and again.

I do not have any trust in this device. It cannot be that many of the customers that buy it, have similar issues…either the device needs an initialization period to get “ready for the world”, or it is a bad designed device.

I will restore factory and give it back and buy a standard USB…who tells me what will happen when I will sutdown the device?

I had a WDMC 3TB that was nearly DOA out-of-the-box yesterday.

Installed and spun up fine, initially.  Could reach out to the Web admin interface… for about 20 minutes.

Then, it stopped responding.  I went to look, and Red LED.  No ambient temperature issue here, no mis-handling.  Just stopped working.  While doing the immediate action steps (leaving off for hours, trying again, soft-resets, hard/40sec resets, etc.), I noticed that the drive was making the tick-tock of platter/head death.  It was click-clacking.

So, after the boot-up/white light, it would immediately go solid RED, although the network lights seemed to be working.

New device & no such problem so far, but just noting it happens, apparently.

Once I got over my annoyance of losing a few hours of productivity, my only solace was in that it happened for me right away, at least–not a week (or 3 days) later… :slight_smile:

Since when were WD drives so delicate/problematic?

Yeah, you’re out of luck. Same thing happened to me and a score of other users, if the forum is any indication. Since companies stopped investing in good customer relations a few years ago, forget about getting any kind of real help. You’ll be told, like I was, to do the standard things like resetting, changing the power supply, letting it cool down, etc., etc. None of them worked in my case and I’m willing to bet not in your case either.

The only last resort you’re offered is to send the product back to get a replacement, and lose all your data, or send it first to a data recovery company which will cost you over $1000. Yeah, those are your only options. 

I’d like to see options like agreeing to void your warranty and getting instructions on how to access your data by connecting it directly to a computer using a SATA cable and disconnecting their control board, which is probably the cause of the problem to begin with. Of course this option is difficult because of the way WD made their firmware. You can’t just connect your device to a computer and it will recognize your data. You will have to do all sorts of Linux programming to get to your data. Unfortunately the forum people who describe this are like most other Linux pros who find it demeaning to explain the details of how they accomplished what they did; expecting everyone to have the time to learn the ins and outs of Linux, and if you don’t or can’t get it, too bad.

Reply to taolove,


First a little about me, I am not a Linux pro, the computers I have had or used had Apple OS (7.5 and 9) or Microsoft Windows XP and OS7.


When I decided to buy the WD My Cloud I started doing some research. Looking at the Best Buy web site I found this, http://content.webcollage.net/apps/cs/mini-site/bestbuy/module/wdc/wcpc/1380204748603/tab/demo-eebd01c1?enable-reporting=true&showtabs=&channel-product-id=1219079080973 . Take a look at it and be sure to look at My Cloud │How it Works. I also downloaded the WD My Cloud User Manual and read it along with the WD Smartware User Manual.


After picking up my WD My Cloud from Best Buy and bringing it home I followed all the instructions for setting it up and so far I have not had any problems other than the downtime on WD’s end. I have had mine for several months.


Here are links to the User Manuals.






There is a lot of Help information provided in the Dashboard and the Smartware Help tab too. All one has to do is read it.


Yes, I eventually bought a Linux book, Linux ALL-IN-ONE for DUMMIES 8 Books in 1 at Barnes and Noble. Yes it helps to understand about Linux but it was not used in setting up my My Cloud.


Posted by,
cat0w (USA)


I’ve brought home two of the 3TB versions of this My Cloud drive in a row - both red lighted. In both instances, I have set up the drive, put my time and effort into adding all the shares I want, users, naming, updated firmware etc, tested access from multiple machines…and over night, I started to load the drive with my data. I only have about 99Gb in family photos, a few hundred Gb in movies and shows, and 50+Gb of music. TWICE now, I’ve started my transfer (first time just the photos via mapped windows drive, second time just the music via the My Cloud Desktop app), only to find that at some point in the process over night (seems bad that 90gb takes 9 hours on a wired connection!!! (My research seems to indicate WD said bad firmware 4.0…607 is responsible for the slow speed…but I digress), the transfer stopped with a “computer or drive is not connected to the network” message. Blue light on, all connected well, computer on the network, network and router all fine (checked status, network had not dropped connection over night) - and I then tried accessing the drive from the app on an iphone, from my Windows 8 and Windows 7 PC’s that are both set up and tested with the My Cloud “software” - nothing. Drive frozen. So press reset…white light, then red. Pulled plug and rebooted it. white light then red. My Cloud Dashboard status says “critical - could not mount volume”. Not cool.

Returned to the store, thankfully they took it back since it bricked after 2 days, despite being opened (after threatening to return $2,500 in hardware that I purchased), but the exact same thing happened with drive #2. Kind of a joke - 2 drives, 3 days - not a reliable place to store your precious data!

After digging around, support indicated there might be a bad batch of 3tb drives out there and I should return again…if the same issue occurs a third time, WD will replace with a 4tb…but I’m a little fearful of WD quality control if a “bad batch” has been floating around, unchecked, for a year, without recalls!!!

And as far as the comment on “WD not monitoring this community and helping out”…they’re too busy replying to all the NEGATIVE 1-star reviews of these drives on Amazon (check it out)!!! Tells you they’re focused on the “SALE” and marketing - ensuring they don’t look too bad on the reviews section at amazon - not so concerned with post-sale customer service and support! Having a product with 400 x 5-star reviews and 200 x 1-star reviews on Amazon is atrocious… 


I have the same problem; 3 week and the red light appear. I do every thing the manual saids

My biggest concern today is the information, really i need it;  I dont understand how WD can sell a dispositive to “save and secure” your information and easy lost them. 

I dont live in USA and really dont know what can I do

please help! ´thanks!

what if anything were you doing when this happend?

one thing it can indicate is high tempature, try unplugging it for a few hours

what are the rear LEDS doing? can you ping it? if you don’t have a static IP check the router for the current IP

Any Linux experiance? do you have SSH enabled?

there is no device or service that can keep your data safe, devices fail, people make mistakes, disaters etc. Always have a backup

1 Like