2TB WD Caviar Green sector write issue


2 Years ago I decided to buy one 2 TB Hard drive. My choise was WD because I had prblems with two drives from Seagate. So I bought one 2TB WD HDD (model   WD20EARX-00PASSB0). After one year I have trouble when the OS write to drive.

It takes almost 1 hour until a 1GB is written to the drive. The transfer rate falls below 4MBytes /s. The SMART feature doesn’t report any trouble. When the transfer rate drops it seems that the drive seek the secors where to write.(Moves the heads back and forth)

At first I thought that can be a driver issue but is not be ,because  I have another two drives (500 GB each) on the sane SATA Host and I don’t have this issue. I tried on different SATA ports (6 and 3 Gb). 

The SATA interface settings in the BIOS is set to AHCI and NCQ is enabled.

My configuration is:

Mainboard: Intel® Desktop Board DX79SI

CPU: Intel Core i7 3930K

RAM: 32GB Geil Veloce (Quad Channel)

HDD: 1 x Intel 240 GB SSD (520 Series)

          2 x Seagate ST3500320

          1 x  WD20EARX-00PASSB0

OS: Windows 7 SP1 64 bit

 If you have some idea what else can I do, tell me please. If I find a solutin I will wrie it down. Thank You

Seems a bit simple, but have you defrag’d the drive?

Yes. I use defrag (incuded in Win 7))once a month, because i don’t write to often (the drive is used just for monthly backup) Drive usage is 60 percent. 

I will low level format the drive with Data Lifeguard Diagnostic after I backup all the data. I have this issue only when I write to drive.

I tried to format the drive with DLDIAG in dos mode and windows to. The time needed to complete was to long. (38 hrs in dos and 80 hrs in windows). I decided to put the the drive into another pc and rerun the utility. This time was better (just only 4 hrs, what seems to be normal).

Not the drive is the problem. The BIOS firmware have bugs.

Thank You