2Tb MyCloud Disaster?

I am at a loss about what happened - after a firmware update and reboot from the WebInterface, nothing - just a white light which flashes off and back on every 40 secs or so.  I left it for many hours (overnight) thinking it might be re-scanning media, etc. but still nothing (just that white light).  I tried the various forms of paperclip resetting, but still no joy.

It is geographically difficult for me to physically send this unit back (still under warranty) so I decided to go the techy  way - disassembled the case and connected the HDD to a USB port via a Sata interface.   I’m an experienced (not expert) Linux user so, using Gparted I was amazed to see that the disk has no partitions (showing empty!) - I understand that the partition table is GPT so using gdisk I printed the following:

gdisk -l /dev/sdb
GPT fdisk (gdisk) version 0.8.10

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: not present

Creating new GPT entries.
Disk /dev/sdb: 488378646 sectors, 1.8 TiB
Logical sector size: 4096 bytes
Disk identifier (GUID): CE5B805D-FCFE-4562-B482-2AAF6EDE2CE4
Partition table holds up to 128 entries
First usable sector is 6, last usable sector is 488378640
Partitions will be aligned on 256-sector boundaries
Total free space is 488378635 sectors (1.8 TiB)

Number Start (sector) End (sector) Size Code Name
[root@Z830-10F USB]#

This looks disasterous, am I doing any wrong (apart from breaking the warranty)?   Are the partitions perhaps hidden in some logical volume? 

From a regular firmware upgrade and a simple system reboot, this is not good.

try photorec it could guess the partitions offsets , have you modified the partition scheme ? If not I will give you the exact positions to create them again …

please show ls -l /dev/disk/by-id/

sudo parted  $disk -s print


sudo parted /dev/sdc -s print
Model: ATA WDC WD20EFRX-68E (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
3 15,7MB 528MB 513MB linux-swap(v1) primary msftdata
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
5 4624MB 4724MB 99,6MB primary msftdata
6 4724MB 4824MB 101MB primary msftdata
7 4824MB 4826MB 1049kB primary msftdata
8 4826MB 4828MB 2097kB primary msftdata
4 4828MB 2000GB 1996GB ext4 primary msftdata

OK many thanks, I’ll try that and report back … doing a cylinder scan at the moment but all looks fine …

I earlier ran TestDisk and it reported 5 partitions thus:

Disk /dev/sdb - 2000 GB / 1863 GiB - CHS 30400 255 63

partition          start                  end             size in sectors

P MS DATA          129024                 628975          499952

P MS DATA          628992                 1128943         499952

P MS DATA          1178624                488378623       487200000

P LINUX RAID       4503599623999856       628991          3999632  [md0]

P LINUX RAID       4503599624499824       1128959         3999632  [md0]

I haven’t touched anything yet, the above is a read only report so that is how it came “out of the case” (after the failure) …

then you can create them again I would not let testdisk revert them

(the not formated one will miss)

but do it  my own using parted and the data I shared at :


If it works please share the parted command lines , I will copy them for others

rzrfreefr, Many thanks, I have written anything to the HDD yet and have disconnected from TestDisk. This will take some time so I might have to wait until weekend to acheive this. In any event, I’ll report back.

Thanks again for the assistance and ideas, I still have to see if any data is still retreiveable - at least I can see data on the partitions.

I’ve been doing more research on this disk and using Testdisk and PhotoRec, all the data (and file structures) are intact and recoverable (whew!) - so the qusestion is before I write anything to the HDD, is there a way to reconstruct the structure and return the disk to its normal state with destroying the data?  It looks like the partition with my files is intact.

Sorry this is a bit layman but to recover 2TBts of data would take forever and also I don’t have backup space to accopmodate this.

I had simmilar problem this morning.

System was unaccessible because I tried to intall wake on lan and I’ve got - wake on never :smileyvery-happy:

But my disk partissions were untouched. I mounted disk on my desktop computer through SATA cable and restored disk images on two RAID disks.

Data was untouched.

I’m tediously backing up all important data via a SATA / USB interface before I start meddling with this.


Any chance of explaining clearer how to reimage the disk partitions without destroying data - although it may not matter if my back-ups finish in time.

I must say I’m not very happy with WD, this situation should never have happened!

Very grateful for any help.

Here are the manuals


You only need the part with RAID disks.

Just restore two disks images with rootfs files and it will work.

The bad part is you must remove your hdd from box and loose warranty.

It’s ok to kill Linux from time to time when you are playing with everything, but things like disabling apt-get command in firmware 4 are really not ok.