2TB hard drives showing up as only 1TB

I have 3 Western Digital external hard drives that are 2TB, and all over a period of a month are blank and show up in Disk Manager as only 1TB.  I am thinking the onboard controller on these fail.  Anybody else struck this, and … got a fix?  SMART data is fine … ??

Welcome to the Community.

Does this happen with any computer you have tried?

Hi Trancer.  Thanks for the response.  Yes.  Shows up on any computer.  I have also tried many adapters as well.  Just comes up as 1TB Raw and wanting to be formatted, which is understandable seeing as the drive size/partition info has changed.

cheers.

Have you tried a low-level format (Write zeros)? This will completely clean the drive’s sectors in case there’s something wrong with the RAW partition.

Additional information is available in the following link:

http://wdc.custhelp.com/app/answers/detail/a_id/1211/

Tried that for the day.  Windows re-registered the disk, through disk manager, but it still is showing up as only 931gb (1TB).  I’m thinking it’s a lost cause. :slight_smile: