2 3Tb drives PC will only see 1st one

I have 2 My Book 3 TB drives. Both work. If I hook up one or the other to my pc (windows 7) there is no problem. however If I hook up both of them at the same time my pc will only recognize the first one I hook up. When I hook up the 2nd drive it can’t be seen in “my computer”. It does show up in device manager but I can’t access it. It makes no difference in which order I connect them or which usb ports I use. It will only recognize the one that is hooked up 1st.
How can I get it to see both of them at the same time?

first thing to check is if there is a Drive Letter Conflict


I’ve had up to 4 3TB external hard drives connected at the same time in Windows 7 with all of them being recognized and all access to them.

Thanks for your reply. So I went into disk management and changed the 2nd 3TB drive letter to N: The other 3 TB drive is M:, then ejected the drive and waited a few minutes. I then hooked up the 1st one which showed up as drive M:. The I hooked up the 2nd one and it still would not show up in “Computer”. I opened Disk Management and the 2nd drive did not show up there either. However, when I clicked on “safely remove hardware” it showed up there but only as a USB mass storage device. So I ejected both drives, waited a few minutes then hooked up the 2nd drive (N:) first. When it showed up in “Computer” the drive name was changed back to M: ! I again changed it to N: using disk management then tried to hook up the 1st drive but I had the exact same result.
I have several hard drives but they all show up as different drive letters when I hook them up. Why is it that these 2 drives keep showing up as M:? What keeps changing it back and how can I resolve this?

When you change the drive letter, there’s no need to eject the drive … it should automatically appear in Windows.

dunno, sounds odd … personally i would try the 2 drives on a different computer just to see if the drives behave normally at the same time.

if they do, then at least you will know it’s a PC/OS causing the problem and not the drives … then you could search the problem on Windows forums

i was just wondering if I should uninstall / reinstall the WD software. Maybe that’s changing the drive names?
I just hooked up both drives to my old laptop. I did have to install the driver as neither had been hooked up to it before. they show up there as 1st drive is M: & the 2nd drive is G: even though I have repeatedly changed that drive name to N: