WD 3TB My Book 2 hard drives in computer and one not showing up

I have never had this problem before, but I have 2 3TB hard drives of the exact same make and model as I have been using one for the past few months and was happy with it and decided to purchase another to use as a backup. When I plug them both in, only one shows up under My Computer directory. When I go into devices and drives, they both show up as WD my book 1140 media, but the second drive won’t display anything. Also tried them both individually and they work flawlessly. Any suggestions?

Have a look at the thread below


Hope this helps you.

Tried doing that and if I plug only one of the drives in, it shows up in disk management, but if I plug both in, only one shows up (whichever one was plugged in first). Also tried to rename drive letter individually and that didn’t work either. Tried the previous suggestion and none of the drives show up in the diskpart system.

I have just developed the same problem. I have two WD 3TV MyBook Essentials connected via USB 3.0. Both have been working, although I sometimes get an error message on the one I use for backup saying I must reformat before using it. This morning, the one containing all my photo images, is not recognized by the system. When I plug it in, Windows 7 doesn’t even know it’s there. The green light is on, the USB connection is solid, but Windows Explorer does not recognize the G drive. 

Before I follow the instructions in  http://community.wdc.com/t5/Other-Externals/Problems-with-having-more-than-one-USB-2-0-WD-2-TB-Elements/m-p/285728#M4260 with the exiting drive, I want to make certain I’m not having another problem. 

Does anyone know what the warranty is on these drives? Mine is less than a year old and it seems to have died. At first I thought it was an issue with having two drives on one machine, but when I swapped USB cables, the troubled drive was not recognized by Windows 7.