Computer Fails to recognize 2 MyBook Essential 2 tb drives at once

Hey everyone,

I have been using a 2tb My Book Essential external for about a month now and have filled it up about 90% of the way. To avoid slowing it down too much, I purchaced a second one. However, when I go to plug in the second one, it won’t register or come up at all. The VCD will come up, but the hard drive itself will not.

The bizarre thing is that if I unplug my old My Book Essential drive, then plug in the new one, it opens up perfectly well, as if nothing is wrong. If I plug the old one in after that, it does the exact same shenanigans, and won’t be recognized by my computer. I’m currently running a 64 bit Windows 7 on an Alienware M15x. I have about 4 external hard drives, and they all work well together, but the two WD drives won’t allow themselves to be recognized together, which frankly ■■■■■ and is quite annoying.

When go to manage my disk drives (my computer>manage>disk drives) only one will ever show up, whichever is plugged in first. When I go to the Device Manager, though, both drives show up under hard drives, but it always says the one plugged in second is offline.

And I know the problem isn’t a limit on number of external hard drives, because I tried the whole above process having only the two WD Essentials hooked up, and I’ve had as many as seven running before.

Any ideas? I don’t want $150 to go to waste.

I am thinking drive letter conflict on Windows OS.

Have you tried re-assigning the drive letter to 1st drive?

For example if 1st drive is letter K:  Assigned to T: or something never been used before.

2nd drive should automatically assigned to K:.

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. This may help someone else.

Tried that, didn’t work :-/

ya i to have the same problem and alot with alot of my other friends here. seeing as how thats  about the only hard drive that the PX’s in iraq have. i will never ever buy another WD product again.

What does Windows’ Disk Management show for the drive that doesn’t have a letter?  Can you make the offline drive online by right-clicking on it?

i cant i got the same problem and a few of my friends here in iraq do also

Do you see both drives within Disk Management?  What happens when you try them together on another computer?

Hi all,

 I purchased my 2nd WD My Book Essential 2TB External HDD today and like the others in this Post,

upon conection, my Windows 7 64bit said “Loading New Drivers” and then just the Virtual Drive came up but not this drive.

Previous to installing this 2nd drive I had one WD My Book Essential 2TB HDD, a Maxtor 3200 200GB External HDD, and another External Maxtor 750GB HDD all up and running and via USB 2.0

I removed the two Maxtors previous to installing my new 2TB My Book, so I just had the two My Book Essential 2TB External Drives connected via USB.

With the three External Drives before, they all were automatically given a new drive Letter amd nicely shared the same USB 2.0 rear connectors.

In the product advertisements for these external My Book HDD’s, it even advertises the fact that we can bundle up multiple drives as easily as books on a shelf! 

Well, I guess it’s not quite as easy as advertised!

So in Summary…obviously there is a known problem with these HDD’s working together…

So, as the others, that is my $64,000.00 question…

Anyone know what the solution is!?


      Buddy B

See if this will help   I think it might have the answer to your problem.


1 Like

Yeppers that did it…

Along with this from another post…

"Control Panel / System and Security / Administration Tools / Computer Management / Disk Management

then, you click on the disk of interest and click online"

So my second My Book actually did show Offline and I just clicked Online and a Letter was assigned!

Thanks for that Help.

  Buddy B