WD 2TB USB 3.0 Essential will not install correctly

I have 2 MyBook Essential 3TBs and 1 MyBook Essential 2TB drive. All are USB 3.0 drives.

The two 3TB drives work fine.  However, the 2TB is no longer recognized by my desktop computer.  It works fine on my laptop (USB 2.0 connection, not 3.0).  It’s worked fine on my desktop for quite a while, but started flaking out by sometimes not being available.  Thinking that the cable might be bad, I replaced it.  The computer still will not recognize the drive as a harddrive.

I’ve deleted and reinstalled the USB 3.0 drivers (NEC/Renesas).  I’ve used an older driver package and  I’ve used the latest driver package for my ASUS P7p55D-E Pro motherboard, but it simply will not recognize these drives.  Again, no problem with the 3.0 TB drives.  I’ve tried it on the built in 3.0 ports and ports I have on a card that I’ve installed, no dice.  It doesn’t work on the USB 2.0 ports either.

When I plug in the drive on my desktop, Device Manager shows two entries under the USB Controllers section for “Unknown Device”.  The other two USB 3.0 drives show up as NEC Electronics USB 3.0 Host Controller and NEC Electronics USB 3.0 Root Hub (one of each driver per drive, so two sets of entries).

As I mentioned earlier, it worked fine for a long time and still does on the USB 2.0 port on my laptop.  My desktop, however, refuses to acknowledge that whatever is hooked up to the port is a harddrive.

I’m really not sure what to do at this point.  I’ve done all the troubleshooting I can think of doing.  Any suggestions?

I had a similar problem connecting two 1TB external drives via a USB, only one drive would appear at a time, found the soloution in MS Windows forum folloowed instructions to put the drive “on line” -


Hope this helps


Thanks, but this situation isn’t the same.  Here, the drive is not showing up in Disk Management because the computer is not identifying the device type correctly.  It shows up as an Unknown Device under Universal Serial Bus controllers in Device Manager.  For this solution to work, it would at least have identified it correctly.  I could then assigne it a letter.

It worked fine for quite a while and now doesn’t work with this computer.  It works fine on a USB 2.0 port on another computer though.

I have the same problem I’ve tried many things but WD software seems to be blocking the drive information . I opened a ticket with WD 4 days ago still waiting .

I believe I have solved this issue.

Windows keeps mis-identifying the device, regardless of me uninstalling the device in Device Manager.  Remember, it keeps identifying it as “Unknown Device”.  Windows was remembering what driver it was using on this device in the Registry, even though I uninstalled it.

The trick is to make Windows forget that the device ever existed.  To do this, I followed the instructions on this link:


The same solution works for Windows 7.  You can safely remove any device that is greyed out, since they are not hooked up to the machine and Windows will look for a driver once you reinstall the device.

Anyway, the drive is now showing up after following the instructions and it works fine now.  I hope it stays this way.