18.5MB transfer speeds on gigabit LAN

I have been going through a lot of posts here and around the rest of the internet. Outside of this forum the info seems to be from 2015 and earlier so I have been taking it with a grain of salt. I have a Netgear Nighthawk R7000P router with all gigabit ports. I have removed my gigabit switch because I have tried to go to bare bones. (nothing else is plugged in, just PC and My Cloud Home) I have a brand new computer with an Intel gigabit port and a realtek 2.5gbe port. I have tried both of these ports. I have gone in and enabled Jumbo files, disabled Large Send Offload (both IPv4 and 6), and even disabled auto tuning through the command prompt. I turned off every power saving option I could find both in power management and the individual device configurations in the device manager advanced tab. My router lists both my computer and my My Cloud Home are connected with a 1000MB connection. I have gone into my My Cloud Home settings and disabled the PLEX server to make sure it hasn’t been indexing non-stop since I installed it 5 weeks ago.

I have yet to see transfer speeds higher than 18.5MB/s and feel that it is kind of ridiculous to wait almost 4 minutes to move a 3GB file with today’s technology. I have seen posts and videos of people actually getting up to 90MB/s speeds on this device and I have to wonder if it could be something wrong with my network or if I just wasted ~$200 on a device that is almost what I wanted.

I do like the ability to get to the drive when I am not home, and I can still stream content at home, but it should be better. This drive should have been more than I needed for just me and my storage needs, hence why I did not go out and buy a diskless NAS for $400 + drives. The only thing I have yet to try that I have seen in these forums is disabling the internet connection. I would hate to think that even with a connection status of “Local” that my files would be uploading and then downloading again. I would have so many issues with that, privacy (where is this data routing through and what are they logging from it) and this could go against my softcap explaining some major ISP throttling I have experienced lately.

Anyway, should I expect more from this drive?

2 Likes

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/15542

18.5 MB/s on large file. Restart does not help.

1 Like

Hi!

I have the same problem. It worked fine for a year. After the latest update the speed dropped for me as well. Now a get around 16 MB/s. For a few weeks ago the transfer speed was around 70 MB/s.
Device: WD My Cloud Home 3TB with Firmware 7.1.0-101
Link speed in router: 1000Mbit/s, tried new cables etc.

Hope they will fix it in a update?

1 Like

So… My Cloud Home 8TB came in today…

My first setup was kinda bad (had 3 routers between PC and Cloud).
Now, there’s only 1 Asus RT-AC68U router between my PC & Cloud, and the speed is still 18.3MBps. It is this for small and big files. Biggest file i had was 98GB, took 1 hour and 35 minutes…

Using a freaking High-Speed PC, 64-Bits, Gigabyte internet Cat6, Gigabyte Router, etc etc to boost the performance…

And it’s still low. HELP?

1 Like

same problem since firmware update speeds steady at 18.5mb/sec
refresh reset did not work, or better worked for a few minutes
my drive has nly 40 gb left - perhaps it is related to the drive being full ???
honestly i think that since this occurred since the firmware update - the problem may
be coming from there

martin

1 Like

I have 1.5TB left on my drive… 16-18MB/s

1 Like

I purchased a new MCH device 2 days ago. I too am getting transfer rates of around 18.5MB/s and I suspect the issue is with the Windows/KDD application. The following explains why I suspect Windows/KDDFS interface (noting I’ve only had the MCH for two days and still trying to understand what it does and how it works).

I understand the MCH supports two file systems… NTFS and KDD.

NTFS (which is native to Windows) is used on the MCH for the “Public” folder. Transferring to this Public folder using Windows Explorer, Task Manager shows the Windows Explorer task reading the data off the disk (an external USB drive, nothing exceptional) at 83.8MB/s and then transfer that data at 693.1Mbit/s over the network (1GB/s wired LAN connection to a dedicated 1GB/s switch to the MCH connected at 1GB/s).

KDD (definitely not native to Windows) is used on the MCH for the “secured” personal folder, mapped to Windows as drive Z:. When transferring the data to a personal folder (Z:) on the MCH, Windows Explorer reads off the disk (same USB drive) at 18.2MB/s but doesn’t send to the network. Instead, a different process, “KDD” (part of the WD Desktop App), is responsible for the data transfer over the LAN at 149.8Mbit/s.

I understand that the KDD process may be dealing with higher security protocols, but a 78% hit on performance is not very flattering. WD need to improve their game.

This test shows that the MCH is capable of data transfer rates of at least 83MB/s, meaning the throttling issue is not being caused by the network setup or disk throughput. At 83MB/s, I’m comfortable with that, noting that was writing to the MCH. I suspect that the MCH is capable of more.

I will do more testing later to try and determine if the bottleneck is the Windows/KDD end or at the MCH end (and maybe try to max it out)

3 Likes

A couple of more time trials… Attached the USB external drive (NTFS formatted) to the MCH and copied files using the My Cloud app. Transfer rate was around 87MB/s. No problems there.

Added files from the Windows computer to the “secured” personal folder on the MCH using the My Cloud Home web interface (using Brave browser). Transfer rate was worse than using Windows Explorer

WD: Is there any solution for this problem? New firmware ? It’s more threads were they are talking about low transferspeeds.

1 Like

I update my cloud home app - WD discovery 3.8.229 & My cloud desktop 2.1.0.308 & reboot it. After that problem resolved. it shows 60 to 90 MB/s. Hope this time it will be stable.

No. it was not stable after 1 day it reaches to 18.5 MB/s again. Hope WD will provide solution.

Hi! I’m surprised. My file’s transfert on network is now 35 Mb after update of differents apps (PC and phone).
I suggest you to use ethernet cable which is came with product; it’s a Cat5e (1000 Mbps). Of course, it’s very short but is faster than Cat5 (10/100 Mbps).

bad news. after restart the speed is returned at 18 mb. i sound like the problem is definitely the software and/or may be the WD’s servers

I get those same speeds locally as well so I think that it is more WD limiting the drive read/write so they have less drive failures. Would be nice if they came out and said it though…I got 80/90MB transfers for the first few days before I updated the software months ago when I wrote this

asco, a little help: So, all I want is a traditional NAS experience within my LAN. I’m only one hour into owning this thing, but I don’t see a network drive with a share that has a public folder on it. I want to run my own backup software (Syncback Pro), and it works only at 18MB/s when feeding data to the “My Cloud_lksdjfljoeoefo…” mounted drive. Should I just return this thing? My 7 year old Buffalo NAS is five times faster…

I would take it back and save up for a traditional NAS and then configure for remote access. This drive, to me, is an attempt to provide a remote service for people who dont can’t do better. Its slow enough that I find that I dont even use it and will be upgrading later this year.

I’m still using the WD MCH, but just as a straight up NAS and getting good transfer rates of around 80MB/s. Using Windows 10 Explorer, the link is \\MYCLOUD-xxxxxx\public, where xxxxxx is the last six characters of the serial number for the device (found on the bottom of the device). I mapped drive P: (for public) to that link.

(I too owned a Buffalo NAS which was an excellent device considering I found it in the bargain bin at an electronics store, thinking it was just a USB drive. Network attached file server, web server, MySQL server and more, all wrapped into one neat package the size of an external USB drive. When I bought the MCH, I thought I would be getting something similar but clearly I didn’t do my homework.)

If you’re only getting 18MB/s data transfer rate, I can think of a few suggestions to try…

  1. Make sure you’re not using the WD MyCloud software to access the MCH. If you’ve installed the WD software, remove it completely. Then just load Windows Explorer and enter the link described above. Explorer will then use the Windows file system protocols to access the “public” NAS on the MCH, rather than the considerably slower proprietary WD file system. (If you really have to, you can always access the MCH via home.mycloud.com, noting that the “public” directory cannot be accessed this way.)

  2. Your network might be the bottleneck, particularly if you’re accessing the MCH via WiFi. If wired, make sure the link speeds for the MCH device and your computer are both 1Gbit/s. The LAN port on the back of the MCH has two indicator LEDs. The LED that flashes green is the network activity indicator. The other fixed (non flashing) LED is the link speed indicator and will be either green or amber. Green means 1Gbit/s which it what you want. Amber means 100Mbit/s, which is not what you want. Try a different cable, a different switch port, stand on your head, whatever it takes to get the LED to green. Having both the MCH and your computer on the same 1Gbit/s switch gives optimal transfer rates.

  3. Whenever the MCH gives me any trouble, I show it a spare USB hard drive enclosure that I have lying around. I’ve come close to converting it a few times, but we seem to have a common understanding now.

I’ve effectively abandoned the “MyCloud Home” function of the MCH product as it is too slow. It would be nice to have some secured network attached storage, but I decided I don’t need it. Given it doesn’t cost me any extra, I have the MyCloud Home app installed on my phone (Android) just in case I want to save something to the device via the internet. But the WD software has been removed from my Windows computer, never to be installed again.

At one stage, I loaded and registered the Plex Server on the MCH. It worked fine until I added more than a few videos. This made the MCH unresponsive as the limited processing capacity of the device was devoted to the Plex Server for encoding the videos. It took me a while to figure out what was going on as there is nothing in the MyCloud Home administration interface that gives any indication about the processing status of the device. The Plex Server encoding might have caught up eventually, but I don’t have the patience so the video files are in the “public” folder.

As for what you should do, try the above (including a threat to turn it into a USB drive) and if that doesn’t help, consider returning the device. I wouldn’t settle for anything less than near network speed for data transfer rates.

asco,

thanks for spelling it all out like that. being on the same network I didnt imagine there was a whole second directory structure inaccessible to the app (or that the drive would be accessed differently). I am able to transfer to the Public folder at ~115MB and thats great!..but not all that great. I would like to use this drive from home and while away without having to duplicate all of the date between both directory sets. I will have to re-evaluate my timeline for a better solution, but in the meantime this will work out fine enough. Thanks again!

Kungfumonkeyman

From my reading of the forums, the ‘public’ directory function was not on the original version of the MCH. It was bolted on later after customers complained, thinking they were purchasing a NAS device (which is what I thought I was getting).

Just checking that your aware that the “public” directory is not accessible via home.mycloud.com or via the MyCloud Home app. So if you’re wanting to access the “public” directory on the MCH remotely, you’ll need to try something different.

Edit… I just re-read your post, it looks like you’re aware of this limitation. The problem is made more apparent when copying files from one file system to the other. Has to be done via a different computer, and at the ridiculously slow transfer rate.