XP Network Share Issue, some show some don't?


#1

Okay, I searched and didn’t find anything that was specific to my issue.

I purchased a WD TV Live, and planned to share from my computer to the device over the network.

I have two shares on my computer, a folder on my D:\ drive, and my entire M:\ drive.

When I log into to the Network Shares on the Live, only the folder on my D:\ shows up, and the M:\ drive share does not show up at all.  Also, when I go into the D:\ folder, it tells me that there is no supported media in the folder … when there is supported media.

This was all working in the past, but I recently formatted and reinstalled Windows.  I enabled the shares on my machine the exact same way I did in the past and it worked fine before. I have no idea why the M:\ share is not showing up at all, but the D:\ folder does. It seems like either both or neither should work.  Also why all the sudden would the live not see files it supports?

Any ideas?

Thanks.


#2

Can you see those shares from another computer?  That’s the first thing I’d try, just to try and identify where the problem is (if you can see them and also see the files in that D: folder then it’s probably a Live problem, but if not it’s something with your shares, which is what I suspect).

I’d also try making one additional share, something you haven’t had before, just to eliminate something being cached in the Live.  Share another folder on your D: for example and see if you can see media in it.

Finally I’d definitely try resetting the Live back to factory defaults.  There’s also something about pulling out the power cord while it’s at a certain screen, but I don’t remember the exact details (RichUK will know since he posted the technique once and I’m sure once it gets to be the right time in Jolly Old he’ll jump in here with better advice).


#3

I figured it out, it was this:

To resolve this issue, increase the value of the IRPStackSize registry entry. To do this, follow these steps:Click Start, click Run, type regedit, and then click OK. 
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
If the IRPStackSize entry is not present in this subkey, follow these steps:Click Edit, point to New, and then click DWORD Value.
Type IRPStackSize, and then press ENTER.

Note Type IRPStackSize exactly as it appears. The value name is case sensitive.
Click Edit, point to New, and then click DWORD Value.
Type IRPStackSize, and then press ENTER.

Note Type IRPStackSize exactly as it appears. The value name is case sensitive.
Click IRPStackSize, click Edit, and then click Modify.
In the Data Value box, type a larger value, and then click OK.


#4

Did you have like a TON of folders on that M: drive?  Because otherwise I don’t know why in heaven’s name you’d have to go through all the trouble of editing the registry (I’ve shared a drive or two on my XP machines and never had that problem).


#5

essential wrote:

I figured it out, it was this:

 

To resolve this issue, increase the value of the IRPStackSize registry entry. To do this, follow these steps:Click Start, click Run, type regedit, and then click OK. 
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
If the IRPStackSize entry is not present in this subkey, follow these steps:Click Edit, point to New, and then click DWORD Value.
Type IRPStackSize, and then press ENTER.

Note Type IRPStackSize exactly as it appears. The value name is case sensitive.
Click Edit, point to New, and then click DWORD Value.
Type IRPStackSize, and then press ENTER.

Note Type IRPStackSize exactly as it appears. The value name is case sensitive.
Click IRPStackSize, click Edit, and then click Modify.
In the Data Value box, type a larger value, and then click OK.

Where did you find out about all this. I share with windows XP and its simply opening the properties box on the drive and telling it to share. If it works for you then OK but I would personally advise against messing with the registery.


#6

Yea, my M:\ drive has a ton of folders.  It’s basically all my Media since I started with computers, and my file structures are detailed, so paths can be very long.

I found out about this because mkelley originally asked if the M:\ drive could be seen from another computer, which I didn’t think of.  When I tried to map the drive to my laptop I received a Windows error, which I then researched and led me to the solution I used.

Everything is working great since.


#7

This actually IS useful information, although it’s also pretty obscure (meaning to say that I doubt whether one person in 1000 will have the same problem).  I kind of thought you might have a ton of folders and long paths if you needed to edit the registry.

It reenforces my believe that shares should be kept to either single folder level or, at the most, one layer nested down.  I have a drive that also has a ton of stuff on it, but I manage it with multiple shares which I think is best.  But glad you found your solution and perhaps it might even help others.