Wireless Setup Problem Solved

Last November, I bought a WDTV Live Plus WDBABX0000NBK-00, firmware 1.06.16, hoping to use it primarily to watch movies from Netflix.  I have a hybrid network that has been cobbled together over a period of several years, starting with a Netgear FVS318 wired router,  I have CAT 5 cables strung through my attic to several rooms in my house, with several devices connected, including two Windows XP workstations, a couple of printers, and a Windows 7 desktop.  Internet access is provided by a DSN modem connected to the router.  In July 2011 I finally joined the wireless world, which I had postponed for years after frustrating experience with early wireless systems, and installed a Belkin F9K1103 as a wireless access point.  This system works well for a shared printer and an HP Envy laptop, both with built-in wireless.

I spent many frustrating hours trying to get the Live Plus to work on the wireless network.  It simply could not automatically detect the network, and I could only get it to work by manually entering the IP address and other parameters, which, unfortunately, are not saved when the system is powered down.  What was particularly aggravating is that, when it tried to search for and failed to find a wireless network, it hangs up the Live Plus at some point in the menu, and it becomes completely unresponsive to the remote – even the power button does nothing.  The only way to restore the system is to unplug the power and then plug it back in.  Another irritant is a flashing red rectangle covering a large fraction of the TV screen when the system is powering up.

Unfortunately, I do not have an Ethernet cable drop in the room where I want to use the Live Plus, and I am too old to climb around in the attic.  To check out the system, I strung a long CAT 5 patch cable from the hub in my wife’s office and plugged it into the Live Plus.  The wired connection worked perfectly (except for the flashing red screen) – setup and connection was automatic.  So, I was faced with either drilling some holes in the wall, abandoning the Live Plus, or getting the wireless connection to work.

Yesterday I spent several hours on the Forums – this is the best feature by far for user support.  I concluded that the problem must have been with my wireless adaptor, a TP-Link TL-WN822N Wireless N USB Adaptor.  My big mistake here was buying the adaptor before checking out the tested hardware list.  Unfortunately, I can’t remember which contributor to the forum suggested it, but someone suggested using an adaptor that plugs into the Ethernet port of the Live Plus, instead of the USB, but did not suggest any specific manufacturer or model.  This suggestion solved my problem – I did not know such gadgets exist, but it prompted me to look for one.

I got a Netgear WNCE3001 Universal Dual Band Wireless Internet Adaptor, followed the installation instructions, plugged it into the Live Plus Ethernet port, and it works perfectly.  I already had the Live Plus set up for a wired connection, and no change in settings was required.  The Live Plus thinks it has a wired connection.

I am submitting this long story in hopes that it will help someone else avoid many hours of frustration.

Good information, thank you for sharing.

Thanks for this information, really helpful.

I have had the WDTV live for a while, I found my old USB dongle that never worked before at more than 2KB/s and it worked int he WDTV live, I had it streaming h.264 but moved to another room and noticed it doesn’t do so well streaming XVID. Suspect it’s just the dongle.

Was looking for another one, but realised i can’t get any Atheros chipset ones (to match the chipset of my router) cheaply and the AVM fritz WLAN stick N is not officially supported (AFAIK), so not going to even bother trying that lol.

In the past I would have gotten a new router with OpenWRT and set up that, but I cbf :stuck_out_tongue:

I would love to know if the WNCE3001 it is working ok for u (I know that is subjective but I don’t expect you to conduct a load of speed tests as that takes time), what sort of content have u managed to stream so far? (type, size/bitrate)


I’m glad you found the information to be helpful.

So far I have used my setup only for streaming Netflix, and have had no trouble with the data transfer rate, except one occasion that I suspect was a server problem on Netflix end.  I haven’t tried streaming from files stored on my network, but suspect it will work fine once I get that option set up.  I don’t know what bitrate is being used.

I hope this helps.

Cheers to you, too.

Thanks,  I too spent some time with different usb adapters. I am glad I came across your post. So far so good and easy configuration. I found the adapter at Radio Shack for $65.00. Thanks again!!!