WD HD Live Plus fails wireless setup on the last step

So, I was trying to set up a HD Live Plus at a friend’s house, yesterday, and I ran into a strange problem when trying to get the wireless going.

First off, it has the latest firmware. Secondly, I’m using a 3rd-party USB wireless adaptor which worked fine with my Live Plus on my wireless network.

When I go to set up the wireless, it scans for access points, it finds my friend’s wireless, I enter the wireless key… that all works fine.

THEN, it comes up with a page to manually or automatically set up the network settings. On the page, I’m able to see  the IP address which was assigned to it, the address of the router, the name of the wireless network, etc. Everything looks fine, YET… the Live Plus still asks me to automatically or manually set up the network.

Whether I tell it to do it automatically, or if I do it manually, the Live Plus tells me that it is unable to communicate with the network.

I don’t understand how it can get that far (getting a valid IP address from the router) and then claim that it can’t communicate.

Has anybody run into this problem before?

Can be the encryption or incompatibility between the adapter and the router, what encryption is he using?

hi there

  • exactly [as above]

  • check coding and change it in all units  [wpa/wpa2 codes/ change them or disable for a while to check]

  • check with the other adapter