Windows 8 app and my book live


I am trying to access the content in my book life connected to my home ethernet network from the Windows 8 application downloaded from market place. This takes place in a windows 8 RT machine.

When launching the application it mentions:

" No supported WD device found - please connect one to use this app "

Still I am able to access http://mybooklive/ without issues. Also able to acces twonky media server.

Can I access My Book Live content from this app?

If not, are there any ways to stream content from the network drive to the windows 8 rt machine? Accesing twonky media ask to donwload the file instead of start streaming.


  • Antonio

if you read carefully, that app is not meant for MyBook Live, but for a MyBook with USB 3.

I myself am eagerly awaiting an app from WD for my MBL and even for my WDTV Live, though I am starting to doubt it will ever come… silly WD…

To access media content try using an app like My Explorer…

I don’t understand why the IE10 does not play files into browser, while Chrome, for instance, does play using flash, when I access media content via TwonlyMedia (I have even set up remote access to Twonky and play media files into browser, but IE10 would not help).

Thanks for the tip nicopizza.

This is really disappointing. I dont understand why I cannot browse content in MBL from my windows 8 machine with a native support in a nice and fluid manner.

Opening files from My Explorer do the trick but is a really poor experience. Cannot even add those to the video libraries.

Just bought the MBL couple of days back and thought the product was more mature and would be providing this basic support already.

WD please make this happen!


  • Antonio


I’ve bought a WBL yesterday and set it all up , upgraded the firmware to the latest version and such.

Then on my MS surface Pro installed the app from the store, which worked well untill this morning

I have no clue why it’s not detecting the device anymore ( this is why am browsing the forums) but it worked perfectly until this moring and was able to see photos, videos and such.

There must be something ( a config or such ) to do to get this work properly

Any idea someone ?