Windows 10

#1

I have tried to use Windows 10 preview releases on at least 4 computer on my home network. I have read and tried the solutions to access my 3tb WD MyCloud on all of them. ( reg, fix and Windows credentials). These worked somewhat in the earlier releases of Windows 10, although sometimes it required the installation of WD Desktop utility, accessing Mycloud once with desktop utility and then I could get to files on Mycloud.

As later releases of Windows 10 became available, I kept trying them ( full fresh installs). The last one I tried was 10125, but it and the previous coulple of builds, would not allow me to access Mycloud no matter what I did. I mean I could see drive with WD desktop utility, but could not see or access it on network homegroup as I could easily do on all my Windows 7 and 8.1 computers on my network.

I like Windows 10, and would like to go with it when it becomes official, which is coming very soon, but if I can’t use WD Mycloud on it, that is a deal breaker!

Either I am missing something, or Microsoft needs to make changes, or WD needs a software change to address this issue.

Any help or news would be greatly appreciated.

#2

Have you tried this Fix?

#3

Just downloading build 10130, will try that when I install, and let you and community know if ut works for me.

Thanks!

#4

Did a fresh install of Windows 10 10130. Applied all 3 “fixes”, credentials, dword and Windows 10 shares fix, still can not access Mycloud. Network shows mycloud as a storage device and a Media device, but not as a computer as it does in windows 8.1 and 7.

#5

Hello:] can you please try in file manager on the top bar select computer and “map network drive” and try to connect to it either via \driveIP   or \drivename\

#6

Ok thanks, after a few tries getting address correct, managed to map mycloud drive.

Seems windows 7 and 8.1 will show mycloud as a computer, but windows 10 only as a network location.

#7

I’ve tried everything suggested here without success. I tried entering the \myip and as well as every single fix and nothing the WD Discovery tool can find my WDMYCLOUD but the buttons to create a network drive are disabled. Why isn’t a realiable fix from WD available? the issue seems to be quite known yet apart from fix by the users here there is nothing else officially done on WD part. I’m quite dissapointed now.

#8

aruantec wrote:

I’ve tried everything suggested here without success. I tried entering the \myip and as well as every single fix and nothing the WD Discovery tool can find my WDMYCLOUD but the buttons to create a network drive are disabled. Why isn’t a realiable fix from WD available? the issue seems to be quite known yet apart from fix by the users here there is nothing else officially done on WD part. I’m quite dissapointed now.

Isn’t Windows 10 still a preview product? If Windows 10 has not yet been officially released, I can see why WD may not have made resolving such issues a priority, even if they are known problems.

#9

SilverLining wrote:

Isn’t Windows 10 still a preview product? If Windows 10 has not yet been officially released, I can see why WD may not have made resolving such issues a priority, even if they are known problems.


Thank you for your response. I know that Windows 10 hasn’t been released yet but that doesn’t mean companies don’t have to care about there products support. I’m a developer and one of my highest priorities is to make sure our software continue working on newest Windows versions. In fact, that’s the reason why Microsoft roll out preview/developer-preview versions so that we can test our products and make sure they work when the new version is released. The reason why i’m dissapointed is because the issue is well known here and we have posts from january and all we have are workarounds made by people. Sure that’s a good thing but is not a solution in the long run and i was expecting something coming from WD to fix the problem and so far i haven’t seen anything here.

On July 29th i’m planning to upgrade 2 Windows tablets, a VaioTap 20 and my HTPC to Windows 10. As of now all those devices aren’t going to be able to access my shared information and in short my WDMYCLOUD device is going to be rendered useless from that day on. Sure i can keep my Windows 8.1 but i definitely want to upgrade to Windows 10. I already had some bad experiences with Netgear which is the reason i switched to WD and now i hope the story doesn’t repeat again.

As previously said i’ve tried every single fix mentioned in this forums and nothing seems to work so far. I’m using the preview 10130 just in case that helps.

#10

aruantec wrote:

… I’m a developer and one of my highest priorities is to make sure our software continue working on newest Windows versions. In fact, that’s the reason why Microsoft roll out preview/developer-preview versions so that we can test our products and make sure they work when the new version is released. …

You make a good point. Perhaps WD should kick it in gear & help developers get ready for the big rollout. Maybe they got sidetracked looking for Windows 9    :wink:

1 Like
#11

I’m having this exact issue with win 10 on Jan 7 2016, I hate microsoft sometimes. Why have they ignored this problem ?

#12

Have you tried the solutions found in the following thread that is tacked to the top of this subforum?

#13

Yes, Lord yes I’ve tried. I have been somewhat successful at accessing the files in the drive, BUT , now my wife cannot access her things. ( movies mostly, using a sony smart DVD player. Plays a few seconds, then says file is corrupt ) ( also, she is mad at me because it’s all my fault, of course ). Does anyone have a clean copy of windows 7 I can download from you ???

#14

Please note that what you ask may be illegal. You can download Windows 7 direct from Microsoft however you will have to have a valid product key to activate (as one normally would) the Windows OS. See the following Microsoft link:

Download Windows 7 Disc Images (ISO Files)

As to the file corrupt issue that has cropped up, what exactly did you try? What setting changes have you made on the My Cloud?

#15

microsoft is refusing to let me download a copy saying I should get it from my manufacturer. As I said earlier, sometimes I hate microsoft.

I started by changing the network settings on the win 10 laptop. No change I did there had a positive effect. Then I logged into my router’s setting page and made the suggested changes there one at a time, changing them back when it did not help. Finally I changed some settings on the WD drive. This helped the windows 10 PC. I was able to see the files and directory structure I had set up on the drive. All was fine for a few days until my wife tried to access her files. I have forgotten exactly what setting I changed.

No, the files are not corrupt. I can access them on the 10, but not the 7. And they REPORT corrupt on the DVD player after a few seconds.

#16

Ps. I don’t care at this point if mucrosoft thinks anything is legal.

#17

But you should still care about the WD Community User Guidelines and Terms of Service while posting in the WD Community.

Keep it legal.

- You remain solely responsible to comply with applicable law in using the site. Accordingly, you should not post any material that would infringe on any intellectual property rights of any party including, without limitation, patent, trademark, trade secret or copyright.

On the other hand, did your computer come pre-loaded with Windows? If so, then it’s an OEM copy and the reason why Microsoft is recommending for you to contact your computer’s manufacturer since your computer’s Windows license was sold to them as a company, not to you as an end-user.

#18

That’s it exactly. Lanovo has a copy on the way to me for my PC.

This will be my final comment on this post: as a end user, one should not have to TRY fix after fix to have a simple network drive work. I do not know if the reason it doesn’t work properly is a WD developer issue or a Microsoft win 10 developer issue, but I do know all was fine with 7 and I’m going back. Thanks all,
Ibewcountry.

#19

For me it was 100% a Windows 10 issue. It was after the November Windows 10 Update when I started having trouble with Windows File Explorer finding the My Cloud on the local network.

Answers.microsoft.com a dozen (or more) of threads about the November update having problems with NAS devices.

2 Likes