Windows 10 Cannot access My Book Live with File Browser

I had the same issue with My Book Live after migrating to Windows 10…

After searching through the internet, I think I solved the issue (or at least mine).

What I did was to change my WD name to all CAPS (e.g. not ThisWDC, but THISWDC)… yes, it seems weird but Windows 10 windows explorer only recognizes network names in CAPS.

Let me know if it helps

Thanks for the reply.

This issue is of very recent onset (last week or so) on a computer on which File Explorer has successfully accessed both MyBookLive and WDMyCloud for well over a year without any issues.

I am starting to wonder if it may have something to do with one of Microsoft’s ubiquitous surprise updates. I remember that a day or so before I noticed the issue, the computer had restarted itself and was awaiting entry of the password. I hadn’t noticed that an update was pending, but I probably missed it.

That fixed my problem! Thanks.

When attempting to map a drive to the WD device as suggested in another post, Windows 10 responded with:
System error 1272 has occurred.

You can’t access this shared folder because your organization’s security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network.

Googling that (not Bing as it turns out this is a MS initiated bug) discovers that Windows 10 turns off access to “unsecured” devices by default.
https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016 from Microsoft discusses how to use Group Policy to change the “Enable insecure guest logons” so that you can once again access the WD device.

WTG M$! Unbelievably frustrating that this would be changed and set as a default without any sort of notification, work-around, or notation in release notes. Regardless, hope this helps someone else.

My fix is, use a sftp client to login the driver with root/welc0me, then navigate to the folder you have permission issue, change the properties to all control 777, set to recursively.

Amazing! This works! Such a simple solution…after sooo much reading!

Hi. I had same problem for a week and I found my own solution.
All your threads helps a lot so I would like to share my solution as well.

I have been using MyBookLive with Windows 7 and had no issue.
and I bought a new laptop with windows 10 pro and I couldn’t find MyBookLive from browser.

My solution has two steps.

  1. To see MyBookLive in File Browser : In Windows Features, turn on ‘SMB 1.0/CIFS Client’

Now you can see MyBookLive in File Browser as computer.
But, if you click it, you cannot access.

I have a few computers and all computer has different situation.
My old laptop, upgraded from windows 7, works well.
My desktop, clean install with windows 10 pro, works well.
My new laptop, factory default with window 10 pro, didn’t work at all.

Only difference between two laptops is simple.
I used local account with my old laptop. After I upgraded to windows 10, I am using Microsoft account.
However, in my new laptop, I don’t have local account, I have Microsoft account only.
(My desktop is using local account only)

So, second step is simple.

  1. On my new laptop, I change it into local account and open File Browser.
  2. I can see MyBookLive and open it.
  3. Use MyBookLive account to log in and Please click the box to keep using same confidential.
  4. Go back to Microsoft account and you can use it normally.

I hope this helps other people.

Thank.
Huey.

Hello everyone!

//this is a copy-paste from a similar thread in WD community//

I tried every solution listed here and on Windows forums. The only one that worked with my WDBookLive is this:

After these seps MybookLive appears in “network” sub-folder on the left of win explorer under its ip-address. No credentials required

Hope it will help.

Best,

1 Like

Hi Paul

I’ve just been trying to use this, as I’m hoping it will cure the glitch that is causing my MyBookLive Duo to ■■■■ me about on one of my computers. I tried entering both commands as you suggest, but for both of them, I got back the following error messages:

[SC] OpenService FAILED 5:

Access is denied

I tried a reboot anyway, but it didn’t make any difference!

I have two computers that I am accessing this with. A desktop that is connected to the router by ethernet cable, and a laptop that is connected by WiFi. So far, I’ve NEVER had a problem accessing it from the laptop via WiFi - it’s only ever the desktop!

My MBLD is attached to the router. Much like other posts above, on the desktop it shows up (mostly, but not always!) in the Storage and Media Devices sections of NETWORK in a Windows Explorer window. If you click on either of these icons, it will always open a browser window, and I’ll always be able to access the MBDL User Interface - so it’s clearly always there on the network, and the issue seems to be exlusively related to something going slightly wrong with the desktop. It is set to DHCP, and IP address is always the same. I can always access the UI by entering the IP address in a browser window.

When I’m having problems, sometimes this is following a restart, or re-awakening from sleep (most recently is from a Win 10 auto-upgrade). As I’ve been typing this, after 4 restarts, the computer has now accessed it again! It’s typical… it’s not even a repeatable problem all of the time.

For some reason, I suspect that this is linked to the fact that MBLD does not appear in “Computer” section of the NETWORK section of Windows Explorer. On my laptop it does. On my laptop it’s there showing in “Storage”, “Media Devices” and “Computer”. On my desktop, it’s only “Storage” and “Media Devices”.

The difference is, that when I double click the MBDL icon in either the Storage or Media Device sections, it will open a browser tab and take me to the UI. When I double click the MBDL from the “Computer” section on my laptop, it will open up the filing system on the drive (Public, Smartware and TimeMachineBackup), and I can properly access all of the files within it as you would want to. Indeed, I seem to recall using this to map the Public folder in the first instance, on both computers, to create properly accessible tree link in Windows Explorer, so that the MBDL permanently appears as a network drive along with all other drives on the left-hand tree of Windows Explorer!

Incidentally, I’ve had no bother accessing the drive remotely on my Android phone either, using either “MyCloud” (a WD app), or “File Manager +” (a third party app).

I have found WD Discovery to almost entirely hopeless though. On my desktop, when I run WD Discovery, it will only ever find WD drives that are connected to that computer via USB. When I run WD Discovery on my laptop, it will only ever find drives that are connected via USB and 1, much newer, WD MyCloud Home (white and silver box - single drive). The desktop cannot see the MyCloud Home via WD Discovery.

Therefore, I’m a bit confused as to where to take this next to be honest. I’d like it to just be a properly reliable NAS drive, that I simply want to use as a media server for the family, so that it can offer up films and music to all devices on the network. (The MyCloud Home is going to be used as a back-up device for all devices on the network).

Also - I’ve followed the WD advice on this link here:

I’ve checked all services, and they were already all on Automatic and were all Running.

This works! What a frustrating experience. Finally a solution! Thank you so much… I’m re-pasting the link that Ki_Ki_Ki provided: https://www.techcrumble.net/2018/03/you-cant-access-this-shared-folder-because-your-organizations-security-policies-block-unauthenticated-guest-access/

Hi all

I’ve been searching all week for a solution to this having recently setup my (old) WD MyBookLive on my home network and trying to access on a newly setup Windows 10 machine (running 20H2 update).

I’m pleased to say I just found a solution and wanted to share my experience as clearly I’m not the only one facing this problem and it’s apparent the suggested solutions (of which there are many) aren’t working for everyone - myself included, until now.

Like many of you, I was finding it impossible to map the NAS drive and access the public folder. In fact, my new machine wasn’t showing any other computers on the network - the NAS would only appear as a Twonky media streaming device, or under network, which would only allow access to the NAS UI via my browser.

So, I tried every solution I could find online, including;

Changing drive name to all CAPS

Resetting machine/drive multiple times

Check network & sharing settings (all private enabled)

Check Workstation service (set to automatic and running)

Check lanman workstation settings under group policy editor (all set to “not configured)

Check netbios settings under network adapter>IPv4 settings (set to default)

Check windows features (all three SMB 1.0 options enabled)

Check lanman workstation entries in registry (deleting the “dependonservice” entry as recommended by some)

I’m sure there are others I’m forgetting… however, nothing worked.

In the end, I decided to dig out an old machine in storage running an old copy of Windows (pre 2004 update). To my pleasant surprise, it immediately recognised the NAS drive on the network and I could map it without issue. I subsequently went out comparing every single entry and setting on the two machines to rule out possible causes.

At first, it seemed like everything matched between the two machines - all the same settings applied, same service status etc. I also updated the old machine to 20H2 and it carried on working …

I was about to give up until I got to the final check on my list - the lanman workstation registry entries. All entries appeared identical except for “displayname”. On my old (working) machine it was pointing to “wkssvc.dll” (similar to the “description” entry above but with “-100” in the data string instead of “-101”). Whereas on my new machine the displayname data string simply read “Workstation”.

I changed it to match my old machine, restarted and the NAS drive (and all other computers on network) appeared in explorer, all working as expected.

HUGE RELIEF.

The full display name key is “@%systemroot%\system32\wkssvc.dll,-100”

I’ve no idea why the two machines would have two different entries, but I hope this helps someone!!

Ps. To be clear, the various settings/service status listed above represent what it’s set to now with the NAS functioning correctly (except for “dependonservice” registry entry, which I restored to it’s original state)

You almost made my day when i first read your post but, when I delved into the Registry, I realised I was potentially being led into a dragon’s den.
My search of the Registry to find the key @%systemroot%\system32\wkssvc.dll,-100 led to multiple entries, all having varied numbers at the end (1010, 101, 102, 1003, 1004, etc.), so i’m no better off than before.
Although my problem isn’t mapping to a MyBookLive (which did serve me for many years but has long been mothballed, in favour of a FreeNAS Server), I’m unable to map to that Server since a few Windows 10 updates ago which go as far back as May 2020.
The irony is that I’m able to successfully map to 2 other NAS drives (even though that episode has been inconsistent for my LaCie and D-Link drives - both of which are long serving, simple IP devices), but since some time back I’m unable to get through to the FreeNAS Server (which worked fine until Microsoft started their campaign of destroying any semblance of Windows 10 continuity or reliability).
As I said, your post offered glimmers of hope until I looked into my registry and saw the potential for completely stuffing up everything due to the various inconsistent values in my registry key you reference in your post.
Any further assistance or recommendations would be very welcome.

I have done everything listed here but still not able to add files to the drive from a Windows 10 system. I can see and access the drive from all Windows 10 systems in File Explorer but not add files to it. though. What started this was our SONOS music library was on the MyBookLive drive and all of a sudden we could not access it. Oddly I can still see and fully access the drive from a Windows 7 workstation?

I have worked with WD support without success. They basically say the MyBookLive is a legacy product and is no longer supported! Ok so my question is what system do I purchase to replace it. The answer is one that has been out for years now and I am concerned to spend good money for a new system that will become legacy shortly after purchasing it.

Is it best to go with a Cloud back up system instead of having hardware which will become obsolete?

Hi all,

So my MyBookLive was working fine, on Windows 10 Home, as a network drive (\MyBookLive\Public (z:)). The other day, I had to update Windows and I’d also powered down the MyBookLive drive for another reason. But when I switched everything back on, my laptop couldn’t find the drive. Like most others, I tried similar actions, but with no luck. I could access the remote drive through the IP but that’s not what I wanted. I wanted it to show up as a drive on the pc.

I have to say WD tech support was useless, basically told me it wasn’t their problem and I needed to contact Microsoft. So not impressed.

After much scouring the net, I narrowed in on the SMB1 and Group Policy issue. It seems that Microsoft revoked the Group Policy access in this latest update. Without access to it, you can’t ammend the thing that is restricting MyBookLive from being found as a drive. In any event, I tried to find something such as a download to reinstate the Group Policy funtionality and eventually stumbled upon this link and a bat file.

https://www.ghacks.net/2019/01/07/how-to-enable-gpedit-msc-group-policy-on-windows-10-home-devices/

I downloaded the zip file, extracted it and ran it (please do your own checks on the file to ensure you’re happy to run it). The script ran through a series of installs of Group Policy files, around 5-6 of them. Once done, I rebooted my laptop. I then went to gpedit.msc via the “run” command and "computer configuration > administrative templates > network > Lanman workstation > right click on Enable Insecure Guest Logons and set it to Enabled. Close everything, restart your computer.

As soon as I did this, I was able to locate my drive using \MyBookLive\Public and then mapped it to a drive. Perfect.

Well not quite, I suspect enabling the Insecure Guest Log ons creates a security weakness but I’ve never had a problem with it.

Hope this helps someone else. :slight_smile:

Hi ahughes, thanks for a clear explanation of the group policy reinstall which I’ve tried with partial success (if there’s such a thing) but, like many others with this problem, the mapped drives (not just MBL) inexplicably disconnect after restarting, so going through the napping process is required at least once reach day - more often if the Windows PC goes into standby or sleep state.

Its almost unbelievable that Microsoft support is silent on this, particularly given the number of users complaining about this very annoying issue.

But thanks again for your very helpful description. Maybe some day soon Microsoft will wake up to the fact and do something about it.

Geoff Whiteley

Hi Geoff,

Thanks for the reply. I have restarted my home pc and laptop a few times and each time, the drive still shows up for me.

I’ll try it a couple of times tonight and see for sure. WD seem not to care, maybe because its a legacy product and Microsoft definitely don’t care.

But in reality, I can only see Microsoft increasing the restrictions from external network services. We’re living in a world of growing cyber crime and hacking.

Microsoft no longer supports SMB1 in Windows 10. Even enabling it in the Enable Windows Features doesn’t work any more. I’ve had to resort to using FTP mode to access my files and create an FTP link in the Network area. If anyone knows how to update the SMB protocol on the MyBookLive WDBACG0020HCH-00 please let me know. I can’t seem to get Linux Ubuntu 20.10 to view it either.

Update: I got FTP access working on Ubuntu. At least I can get to my files with Linux now. But still, if anyone knows how to update the SMB protocol on the MyBookLive, please let me know.

So weird that I had the same issues on the same day. I also wanted to access my MyBookLive from Windows 10 and was able to do so after Enabling the SMB protocol from the Features and Programs area. But, there were three settings I needed to verify (see attached figure) …

The SMB Automatic Removal had to be DISABLED as well as enabling the other two settings, as per the attached screen grab.

1 Like

Ok for SMB 1.0/CIFS Client
But why enable also SMB 1.0/CIFS Server? Do you need to expose some resource of your PC using SMB1?

Not necessarily, but since I have remote access turned off, I assumed that the only potential access would come from inside my own network. I’ll disable that setting and see if it adversely affects my ability to access content.