Windows 10 and WD Elements

I use the USB hub in my monitor - via that, Windows 10 is able to recognize the drive. Using a different USB 3.0 connecting cable also solves the problem.

1 Like


Try this…

Then goto device manager and register the drive with a Letter and you are done

1 Like

Same here: my Elements drive has been working fine with Windows 7 but i’ve “upgraded” to Windows 10 and all that happens, regardless of which USB port i use, is that the disk shows 100% activity for a while then Windows 10 tells me it needs formatting! I have an old XP machine which reads the drive fine and it disk checks with no errors or bad blocks and it passes all WD SMART checks. I too have tried all the usual uninstall driver, reboot, adjust system settings etc. with Windows 10 and it still won’t read my WD Elements. There seems to be no other problem with my computer’s USB - i am happily using several USB devices including memory sticks.

1 Like

My WD Elements drive was showing in Windows 10 Device Manager having been recognised when plugging in via the USB, I could even eject using the Safely Eject feature but try as I may I could not read from within Windows Explorer or a Dos Prompt. I tried all the tips given on the WD Support page even downloading the recommended troubleshooting software which I found wasn’t compatible with WD Elements! Drastic action called for, I went into Disk Management and found the drive shown, it recognised a partition so I deleted, then re-setup a simple partition using the defaults. It should have automatically re-formatted but didn’t so I carried out a quick format. Problem solved, drive now showing. Fortunately I had nothing on the drive worth saving, had I it would have been lost so recommend trying the drive on another ‘Non-Windows 10’ computer and saving your files if important beforehand. As per normal with Microsoft Windows new releases and/or updates half of your hardware is made redundant or next to useless making mugs of us all.

1 Like

When my PC updated from Windows 8.1 to Windows 10, three WD external hard drives vanished from Windows explorer. Since then the computer has broken down and Dell sent it back as Windows 8.1. I can see the letters for the drives, but when I try connecting the drives I get an error message that the USB device isn’t recognised. I can’t see it on a second W10 desktop or a W7 laptop. It looks as though W10 has corrupted the drive in some way.
Has anyone found a solution to this problem?

1 Like

For me it stemmed from Win10 64bit system seeing the drive in the hardware manager but not showing it in Explorer. Here is what worked:

  • Download and install AOMEI Partition Assistant Standard (it is free) -

  • Start the application and take note of the drives displayed

  • Plug in the WD external drive

  • Click the “Reload” icon in the AOMEI toolbar

  • The WD drive should now appear, and you will likely note that it is not assigned a drive letter.

  • Right click on the WD’s partition and select “Advanced” from the drop down menu.

  • From that menu Select “Change Drive Letter”

  • Assign a drive letter (I pick a letter deep in the alphabet so as not to interfere with drives or devices to be installed later).

In some cases (like moving or changing partitions) you have to click on the “Apply” icon in the menu bar. Also, if you connect or disconnect drives, click on “Reload” to repopulate the drive display.

That should do it!

1 Like

Yes. The same with me…

This worked for me:

Look for section:

2] Change Driver Start Values via Registry Editor

If You Get A Laptop/PC with windows 7 then transfer the data to it then plug the WD elements drive into the win10 PC and reformat it, it should work. all you need to do after that is copy the data back over. !EDIT! If you have rufus then you can make a windows to-go drive and then boot to it and see the drive as long as u connect it whilst it is detecting hardware.