Windows 10 and WD Elements

Windows 10 doesn’t recognize WD Elements. No new drivers listed. Any suggestions?

1 Like

Welcome to the Community.

Is your hard drive detected within Windows Disk Management? Are other external hard drives detected by your system?

1 Like

I’m having the same problem. Once I upgraded to Windows 10, I noticed my external HDD is no longer detected. I went to my Device Manager and noticed there was an icon indicating an issue with my USB Mass Storage device which I assume is my external HDD. Also, my device isn’t being read by Disk Management either. The error code reads…

**Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38) **The driver could not be loaded because a previous version of the driver is still in memory.

I read that restarting your computer helps resolve the issue but it doesn’t. I have important information on my external HDD that I haven’t been able to access since yesterday when I upgraded to Windows 10. The device I have is a WD Elements Portable External HDD WDBU6Y0020BBK.


Unfortunately Windows 10 still has a lot of bugs in it because MS was in a big hurry to release it. Also I am not a fan of upgrades they frequently have problems. can you post a screen shot of the Device Manager?


1 Like

I also am having massive issues with Win 10 & Elements drives. Just upgraded from Win 7. The drives are showing in disk manager as active but RAW not NTFS. I have tried them on another Win 10 machine & they read fine, NTFS. Its just my main PC which cant read them. Tried everything, uninstalling in device manager, reassigning a drive letter, nothing works. I’m desperate here. Dont really want to go back to Win 7.

1 Like

If they work on other Windows 10 machines the problem is obviously the one machine. Upgrades are notorius for causing problems. Try going into Device Manager find your Elements delete the driver for it, disconnect the Elements then reboot the system and reconnect the Elements. That should load a fresh driver.


1 Like

Having the same problem, but the uninstall the device>disconnect it>reboot pc>reconnect device process still results in unrecognized device.


Same here!

  • Updated from Windows 8.1 to Windows 10
  • External Hard Drive Western Digital WDBAAU0030HBK-01
  • Formatted as NTFS, shown as “RAW” in disk management
  • reattaching Drive-Name / Drive-Letter did not resolve the problem
  • reinstalling the WD USB Drivers did not resolve the problem
  • Drive is recognized by my old Windows XP Laptop without problems

I tried several things to resolve the problem, none worked:

Another member of 10forums asked WD support for help. They relegated him to Microsoft support. But it cant be coincidence that so many WD External Drives have problems.

Testdisk is able to read the files even on the Windows 10 PC.


Thank You

1 Like

Up front: no solution

It seems not to be limited to Elements though.

I have a 3TB MyBook that is not listed in Windows 10 either.

So, I have 4 WD-external drives, 2 are being displayed, 2 not.

The ‘My Book’ 3TB drive is my backup drive, so until that is fixed I can’t run backups.

Initially none of myl 4 drives were not displayed, but after the 3rd reboot, 2 were, 2 not.

I returned to Windows 7.

Very weird …


1 Like

To sum it up: Some WD Volumes work, some do not work.

Maybe we can compare the drivers. I am running my Western Digital WD Western Digital Desktop 3TB WDBAAU0030HBK-01 on a Dell Optiplex 740 DT. The Volume is recognized after plugging it in. If I try to open it, the following message promts (incorrect parameter):

Bild 1.jpg

The driver details:

Bild 2.jpg

1 Like

Hi there,

today I -again- upgraded from Windows 7 to Windows 10.

during the setup the external drives were switched off.

after the upgrade and after some reboots (had to re-install my security suite)

and after some time, I started to switch them on, one by one, but waiting in between until the drives/drivers, whatever, was installed before switching on the next one.

I did the same during the previous sessions.

This time all drives showed up, including WD Elements.

Strange . . .

That said, frankly, I am not really confident they will show up the next time (after a reboot or a re-install).

FWIW the drives I use:

My Book 6TB Model WDBFJK0060HBK-EESN incl. WD Green model WD60EZRX-11MVLB1 Firmware 80.00A80
My Book Essential 2TB Model WDBAAF0020HBK containing WD Caviar Green model: WD20EADS-11R6B1 Firmware 80.00A80
My Book Essential 3TB Model WDBACW0030HBK including WD Green model WD30EZRX-00MMMB0  Firmware 80.00A80
Elements External USB Drive 1 TB Model WDE1UBK10000 incl. WD Caviar Gren WD10EAVS-00D7B1  Firmware 01.01A01

1 Like

Re-install driver and/or reboot didn’t work for me. But was able to fix the issue with these steps.

Assuming that you just don’t have a drive letter to show contents of the Elements external hard drive:

  1. Go to Disk manager
  2. Identify the drive
  3. Right click and assign a drive letter, and apply changes
  4. You should now see the drive from the file explorer, This PC.

Hope it helps.

1 Like

My 3TB external (My Book Essential) isn’t even showing in the disk manager.

1 Like

Hi. There is clearly an issue with some WD Elements drives under Windows 10. My 1Tb drive was fine under Windows 8. It is about half full of data. It shows up in Device Manager under W10 but not in File Explorer or Disk Management. I have tried various things: Update Driver (it tells me I have the up to date one); Disable; Uninstall; Reboot with/without WD drive plugged in; Tried each of 3 USB ports… and maybe a few things I’ve forgotten. There are clearly a few things which work for some people but not for others, as evidenced by this forum (and others). Has a definitive fix yet been established? If so, can someone point me to it? If not, can anyone help in any other way? Thanks in advance!

1 Like

I have the same problem, is there have been fix it ye?

1 Like

Same issues here 9yrs of photos that will no longer open :frowning:

1 Like

same issue here, upgraded to last Windows 10, my wd 1tb Elements is not to be seen anymore from the (Datenträgerverwaltung) Device Manager. Tried to a different pc with Windows 10.0 update no Problem!
Another old Dell Laptop with Windows 10 upd. no Problem too… I’m sure abt one Thing the wd Elements seems to be fully ok, The way my first laptop asus is handling the WD Elements is not correct.

Tried already the different solutions described here, but not succeeded.

Any idea ?

seems to be not so so unusual…

1 Like

part success (Teilerfolg)

assertion 1: When my multi port USB, 4-Port USB Hub is plugged in, my WD Elements attached to it, the external hard drive is recognized without any Problems.

assertion 2: When my wd element 1 TB is plugged directly to the laptop usb port, then no recognition at all …at all

any idea ?



1 Like

So I got my 3TB External to work! I got it to work with the same Win10 PC I was having a problem with when I made my post here in this thread. And I believe the answer was the original USB 3.0 cable that came with the unit. I switched it out with a normal USB-to-micro USB cable (like the one you use to charge your android phone) and it worked just fine. I guess Windows 10 has a problem with the format of the original cable? Not sure…


This is way more common than you realize… This exact thing happened to me and a few of my friends. My external 4tb raid drive is bricked with RAW showing as partition type - windows detects it and it has a drive letter… it reports the my drive is corrupted… To throw this out there, im going to go out on a limb and say i believe its has to do with USB controller failure caused by Windows 10 OS and NOT Western Digital drives. After questioning all my friends the one thing they all had in common was the drive is always external… Second they all report odd USB errors ( having to unplug and replug USB devices like the gaming mouse button assignments not working, things like that… I believe the MBR/ Partition is being corrupted just like a usb stick or hard drive gets unplugged while its writing or updating the file allocation table in the background. just my .02 – so now ive tried every utility on this website ( including WD Drive Utilities ) and it errors out saying no drives present…funny windows ID’s a WD drive volumn… I have tried other utilities like Drive_test… 6 hours of scanning and no fix… Looking for some answers from Microsoft but im just a number… How about you guys at WD… after all its your drive and you guys are the storage experts… someone pipe in

1 Like