Wifi setup no longer available

I’ve been using wifi for a couple of months with a compatible dongle, then one day it was just not there anymore. There is no wireless setup menu–it just goes to the “Automatic/Manual” setup for wired connections.

I’ve made sure all cables and dongle are snug; confirmed the dongle still functions by trying it with a computer; tried the dongle in the 2nd USB port; reset the WD Live to factory settings; done a paperclip reset; and unplugged for half an hour…but no luck. Other devices, including iPod Touches and a friend’s laptop, have no trouble connecting to my wifi router, and all other wifi devices here work fine.

What am I doing wrong?!


Hmmm. You might try testing the USB PORT by plugging in a USB flash disk or something…

Thanks, nice idea! But the USB ports both work fine with a USB disc!


Did you upgrade or downgrade your firmware on the WDTV when this happened? What is the make, model, and revision of your Wifi dongle?

I’ve never upgraded/downgraded the firmware.

The wifi dongle is a Buffalo WLI-UC-GN that I bought because it was reported as compatible. As far as I know, there is no version/revision for this dongle. In any case, it worked fine for months and has not been changed in any way.

It’s harder to imagine a failure mode of the WDTV where wireless isn’t available but everything else works than it is to imagine something about the wifi dongle is fried or screwed up. I may try another compatible wifi dongle, if I can get my hands on one.

Yeah, I also used to use the UC-GN;  It didn’t break, I just needed a 5GHz adapter.

I know you’ve tried a bunch of stuff, but maybe the ORDER is important.

Try this:

REMOVE the Adapter.

Do a factory restore.

Turn on the WDTV, let it completely boot.

Plug in the Adapter while it’s ON.

(Any blinking lights on the WDTV or UC-GN?)

If that doesn’t help, what you’re describing sounds like some bizarre failure in the WDTV.   

I would recommend you call WD Tech Support and have them walk through their script.   Ultimately, they will probably RMA your WDTV for a new one.

Thanks, Tony, for all your great advice. I tried it all in that order, but still no wifi setup was available. There is no blinking light on either the WDTV or the dongle–both show a steady blue glow. 

At this point it does indeed look like a bizarre failure of the WDTV…or the dongle…or the combination of both.

I’m living in Tokyo right now and calling WD Tech Support and/or mailing or having a friend forward a replacement device is going to cost more than the device itself did.

So I think I’ll try another supported wifi dongle to see if my UC-GN is the flake here.

If that doesn’t work, then I’ll live with a wired connection for awhile. There sure is a lot going on in this segment right now, but I haven’t yet seen anything as perfect as this little WD Live box when it’s working right.

Buy the way, why’d you end up going with a 5GHz adapter? Interference?

Not so much interference, per se, but congestion. I have about a dozen WiFi devices that are B/G only, and doesn’t leave a lot of room for high performance HD streaming.

Tony, the end of the story: it was a couple of bad wifi dongles. I got a brand-new one and it all works fine now. Thanks again for your great suggestions!