Why does WD My Cloud EX4100 have so many problems on MacOS? This time, unexpected error prevents file copy

Once again, another problem with this very pricey storage solution.

Tried to transfer a little jpg, it immediately gives an unexpected error, and leaves a file with zero bites. I am able to delete the zero byte file.

Further testing shows that no matter what drive I try to move files from, this happens.

WTF folks? This system cost $1500, why are there so many problems? And do we know what this issue is? I notice that the drive usually takes about 30 seconds to a minute to initially spin up, could this be it? I am also using this drive for Time Machine, for my internal drive, does this impact my usage.

Because this is getting FRUSTRATING.

@simpleknight

  1. What “unexpected error message and code” is presented by macOS when this occurs? Posting a screenshot helps.
  2. Does the issue occur when you are connection via AFP or SMB or both?
  3. Are their time differences between the My Cloud and the macOS?
  4. Any macOS or network firewall, malware, anti virus or data security software that could be preventing the data transfer from completing?
  5. Have you tried connecting the My Cloud directly to the macOS ethernet port (if it has one) and then doing the data transfer eliminating the external network from the picture?
  6. Have you powered off the macOS and My Cloud (not reboot) and powered both back on and have the same results?
  7. Have you contacted support with the above information and system logs from the My Cloud?

Answers to your questions:

  1. When I did a search for the error, it didn’t come up, but I think it was something like 10000093 or similar.
  2. I have only connected via SMB
  3. No, the time is the same
  4. No anti-virus software. Standard firewall on with default settings. Would be annoyed if I can’t use the default firewall.
  5. I have not directly connected the unit. This would also be annoying, as it would disconnect my internet while the transfer is occurring, and would partially defeat the purpose of having a NAS.
  6. Rebooting both the computer and the drive did solve the problem. However, that doesn’t change my annoyance at this happening at all. Again, this is a $1500 piece of hardware, I don’t think it unreasonable to expect it not to have these kinds of errors. I should have to reboot the system multiple times a week for reliable access, which is what has been required so far.
  7. I have not yet contacted support. Previous contacts about other issues were not particularly fruitful, so I thought I’d try here.