Why can't I see anytying in MEDIA SERVERS, but can in NETWORK SHARES?


#1

i can’t see my MEDIA SERVERS on my WDTV?

when i hit VIDEO>MEDIA SERVERS>BRUCE-PC it says “No Media in the current folder”.  i do NOT have a USB or HD plugged into it, i only stream (via hardwire cable) to my router.

but when i go to VIDEO>NETWORK SHARES>BRUCE-PC, my media shows up (but not always)

i have my WDTV up-to-date on the firmware, and running W7 Pro and connect my WDTV LIVE to my router with an ethernet cable.

anyone know how to fix this?  it works fine, but it’s a couple extra clicks and was just wondering if this is normal or do i have something set up wrong?  although, sometimes when i hit “network shares, bruce-pc” it can’t find my network.   usually  just turn the WDTV off and back on and it recognizes it, but i should have to do this when my PC is up and running all the time.  it’s very annoying when i’m trying to start a movie for my wife or kids and it won’t work, i have to reboot the PC, unplug the WDTV LIVE and then sometimes it works, but not always.

is it too much to ask for a device like this to correctly ALL the time?  i shouldn’t have to reboot, unplug or fart around with stuff, when it’s set up it should work the way it is supposed to all the time.


#2

brucered wrote:

i can’t see my MEDIA SERVERS on my WDTV?

 

when i hit VIDEO>MEDIA SERVERS>BRUCE-PC it says “No Media in the current folder”.  i do NOT have a USB or HD plugged into it, i only stream (via hardwire cable) to my router.

 

but when i go to VIDEO>NETWORK SHARES>BRUCE-PC, my media shows up (but not always)

 

i have my WDTV up-to-date on the firmware, and running W7 Pro and connect my WDTV LIVE to my router with an ethernet cable.

 

anyone know how to fix this?  it works fine, but it’s a couple extra clicks and was just wondering if this is normal or do i have something set up wrong?  although, sometimes when i hit “network shares, bruce-pc” it can’t find my network.   usually  just turn the WDTV off and back on and it recognizes it, but i should have to do this when my PC is up and running all the time.  it’s very annoying when i’m trying to start a movie for my wife or kids and it won’t work, i have to reboot the PC, unplug the WDTV LIVE and then sometimes it works, but not always.

 

is it too much to ask for a device like this to correctly ALL the time?  i shouldn’t have to reboot, unplug or fart around with stuff, when it’s set up it should work the way it is supposed to all the time.

media server = needs a media server installed and operational on the server that is sharing your files.

network share = needs a file server installed and operational on the server that is sharing your files.

I would say you only have a file server configured on your W7 Pro.


#3

First , If you see bruce-pc under the media server this means that you have a media server active on bruce-pc otherwise you won’t see it.

A media sever brodcast a message on the network saying “hey, I’m a media server, come here”, if no media server is installed no brodcast message is sent and the WD doesn’t report anything.

So for you, the good news is that you have a media server and the WD see it.

Now what is the media server you are using and what are the files type that you are trying to share ?

This is important because for example if you use windows native media server and have only mkv files as video, this kind of files are not supported by this server (even if you can play them on the PC installing third party codec) and so the media server will report nothing to share to the wd.


#4

didn’t even know i had a media server.  i’m running W7 PRO with a 1TB internal HD attached as well as the stock 160GB on  Dell Vostro.

how can i turn OFF the MEDIA SERVER, so i don’t have that option.

i use the WDTV to play .iso and .mkv files only and am fine doing it thru the NETWORK SHARES, unless the MEDIA SERVER option is better.


#5

Can’t help, I’ve not Windows 7 and I’m using my NAS media server not a PC one. It should be linked to windows media player from my understanding.

The media server option (dlna) is sometime better because it has better network performances, you don’t have to care of sharing folders,users access, etc… but the WD can see only what the PC/NAS mediaserver can handle. Windows one doesn’t handle mkv and the WDTV doesn’t handle ISO through media server. As I prefer using dlna with my NAS, I’ve converted my DVD iso to mkv using makemkv.


#6

the external msdn link below explains how to configure the media server function of windows 7.

http://blogs.msdn.com/e7/archive/2009/05/12/media-streaming-with-windows-7.aspx


#7

well i tried setting it up and it still doesn’t work.  i added some folders with .mkv and some with .iso and it still says “NO MEDIA FOUND…”

oh well, i need it to play .mkv and .iso files, so the media server thing is probably not a good option for me.

i’ve disabled the SHARING on my WMP setting on both mine and my wife’s side, so now it doesn’t allow us to click on that option on the WDTV, so it’ll make it easier for her to get to our movies.  no wrong buttons anymore.  NETWORK SHARE is best i guess.

hopefully WD can figure out the ALL MEDIA showing up in NETWORK SHARE settings, then i’ll be really happy.  no double thumbnails, no music in my video library etc.

thanks everyone.


#8

Hey can anyone assist me here? I have vista and I am not seeing media servers at all. I have 2 running on my PC and have turned off all firewalls.  I can get to my shared folders on network shares however nothing shows up on my media servers.


#9

I have the same problem each time reboot the system (XP pro - share folders). I need to also to reboot all routers and wait for more then 10 minutes to let the media load to the share. I have Gigabit network. The wireless is junk never work correctly (Belking N+ and USB adapter N+,). I think we need to use 5 mhz wireless to be able to stream it correctly. Hope this help


#10

I think this has been answered in several threads already, but here is a quick recap:

  • there’s a media server included with WMP, you enable it in the control panel> network center, however you cannot play files with extensions without native support in WMP - that is a WMP restriction, not WDTV’s. That means, ISO, MKV, FLC files, which are fine for the WDTV, will not be accessible from WMP’s media server. Even if you used one of those apps that hacks the library in WMP to add flac/ogg etc… it will do nothing. The only thing that may work for MKVs using WMP as a media server is Divx 7, that adds native WMF support for MKV files, though I haven’t tried it.

  • what does work is installing a 3rd party media server (DLNA server) like TVersity, Wild media server, Twonky, etc… You need to be careful with TVersity, because by default it adds new folders as “transcode only if needed”, but it tends to transcode things that don’t need to be transcoded.


#11

mcupp77 wrote:

Hey can anyone assist me here? I have vista and I am not seeing media servers at all. I have 2 running on my PC and have turned off all firewalls.  I can get to my shared folders on network shares however nothing shows up on my media servers.

it is very difficult to help you when all you said is it doesn’t work.  I have Tversity installed on my PC and it works wirelessly with my WDTV live. 

What media server are u running?  What OS is yr PC?  What is yr network setting?

If you don’t know what is a media server, google is your friend.


#12

mcupp77 wrote:

Hey can anyone assist me here? I have vista and I am not seeing media servers at all. I have 2 running on my PC and have turned off all firewalls.  I can get to my shared folders on network shares however nothing shows up on my media servers.

Have you got any media servers running? If you do not have a media server then obviously you will not see it.


#13

I am ruuning vista home premium. I have it set up on my wireless net work. For WDLive I have a Belkind USB Wireless attached and I am using a netgear router. I can get into the network drive I have attached I can also see my shared folders on WD Live under medishares. My issue is the media servers. I have playon and tversity running on my PC. I Ran device spy and it recognized the servers running but wdlive can not pick them up. Hope this helps…Thanks again


#14

brucered wrote:

i can’t see my MEDIA SERVERS on my WDTV?

 

when i hit VIDEO>MEDIA SERVERS>BRUCE-PC it says “No Media in the current folder”.  i do NOT have a USB or HD plugged into it, i only stream (via hardwire cable) to my router.

 

but when i go to VIDEO>NETWORK SHARES>BRUCE-PC, my media shows up (but not always)

 

i have my WDTV up-to-date on the firmware, and running W7 Pro and connect my WDTV LIVE to my router with an ethernet cable.

 

anyone know how to fix this?  it works fine, but it’s a couple extra clicks and was just wondering if this is normal or do i have something set up wrong?  although, sometimes when i hit “network shares, bruce-pc” it can’t find my network.   usually  just turn the WDTV off and back on and it recognizes it, but i should have to do this when my PC is up and running all the time.  it’s very annoying when i’m trying to start a movie for my wife or kids and it won’t work, i have to reboot the PC, unplug the WDTV LIVE and then sometimes it works, but not always.

 

is it too much to ask for a device like this to correctly ALL the time?  i shouldn’t have to reboot, unplug or fart around with stuff, when it’s set up it should work the way it is supposed to all the time.

The following steps should help with your problem

I assume you enabled sharing of the folder you want shared.

  • I think you have Win 7 right?  But those that do have Win XP, make sure you have Network DDE DSDM and Network DDE set to automatic and started. 

  • Make sure you DISABLE your firewall SERVICE in Windows.  Not the check box in Windows that disables the firewall.  That won’t do it.  You have to disable the actual firewall SERVICE in SERVICES.  Don’t worry about your security.  That windows firewall is only good for LOCAL traffic.  It doesn’t do much for the internet.  Having this SERVICE on could give you a headache.

  • Turn Guest account or a user account you created to ON

  • In your router, do not use the DMZ.  Use application support (port forwarding) instead. If you don’t know how to do that, don’t worry.  Here is a website that will guide you for your exact router or modem/router on what exactly to do. Pictures included of inside your router or modem/router settings.  This website is at  www.portforward.com.  Scroll down, select your modem and the rest you can do with your eyes closed.  Also at that website goto “port List” and the same tutorials w/ pictures will guide you on opening up ports in your modem/router setting for your addon like Tversity, and Crackle, a Playon plugin and other things you may have connected to your network.

-  If there is a setting in Win 7 like Win XP where you have a setting for simple file sharing, make sure simple file sharing is OFF.  You may have to reboot, can’t remember. Next step is go to your PERMISSIONS for each folder that you have as shared.  I don’t know how you do that in Win 7. So for those with WIN XP, I’ll explain. For WIn7, you’ll have to find that out on your own, But the same principle applies.

In XP, right click your shared folder. Click on sharing and security. Then click on PERMISSIONS.  If you just see “everyone”, you will need to add more user permissions but just having permissions for just “everyone” will not cut it. Its too long to explain why “Everyone” really doesn’t mean everyone. So to ADD, click on ADD.  Then click on ADVANCED.  Then click on FIND NOW.  What will happen is all your USER Accounts wilol pop up.  Because most wouldn’t know which user or users to select, just to be sure you get the right one you will do the following to each USER…From the beginning…

1 - Right click your shared folder (do steps for each folder you want shared)

2 - Click on “sharing and security”

3 - Make sure Sharing is enabled

4 - In same window click on PERMISSIONS

5 - Click on ADD

6 - Click ADVANCED

7 - Click FIND NOW

8 - Highlight first USER 

9 - Click OK

10 - Click OK again

11 - In PERMISSIONS window, select your new USER added and ALLOW all the permissions by placing checkmarks in the ALLOW boxes.

12 - DO step 4-11 to add the next user and keep going back and doing 4-11 until all users are added.

Then reboot the modem/router first because of the changes made, then the PC or PCs, the WDTV LIVE in that order. After that it won’t matter which order you boot up unless you make drastic changes as indicated above.

Doing all these steps should resolve just about every network issue you may have with WDTV LIVE.


#15

"How can i turn OFF the MEDIA SERVER, so i don’t have that option?"

In Windows 7 this is controlled by the Windows Media Player Network Sharing Service service.  If you disable it, then your PC will stop advertising itself as a DLNA media server.  Note that if you merely set the service to manual start, then WMP will re-start it automatically!