Where can I download OLD FIRMWARE

This unit was so buggy from day 1 it’s a wonder it hasn’t been thrown off the balcony already :smirk_cat: 

Did the latest firmware update (2.02.32) for SMP Gen 3 and well, well, well, more issues:

(1) can’t get the unit to power on now with the remote (this started immediately after the update and nothing had changed otherwise) - I have to manually unplug it to start up

(2) when it gets to the end of a video, if I don’t stop it myself before the very end, it will linger and freeze the unit

(3) no longer visible on my network unless the unit is actually on

(4) had the screen saver on while on pause and once again, froze and locked up

(5)  Youtube?  Forget about it

Question: where can I actually download a version of the 2.01.86 firmware???  I want to rollback to something that was at least “usable.” 

http://download.wdc.com/wdtv/wdtvlivegen3_2.01.86.zip

using notedpad open and edit the   wdtvlivegen3.ver    

(change 2.01.86 to 3.02.32 , because the number has to higher than the firmware you’re currently running for it to detect … and perform a “Rollback”)

VERSION='3.02.32’

LOCATION='wdtvlivegen3.bin’

PKG_LOCATION='wdtvlivegen3.pkg’

ROOTFS2='wdtvlivegen3.bi2’

2 Likes

According to this site, i don’t even have to bother changing anything.

http://wdc.custhelp.com/app/answers/detail/a_id/5860/~/how-to-roll-back-the-firmware-on-a-wd-tv-live-hub-media-center,-wd-tv-live

Wouldn’t that work?  Guess I can just try and see

That site has all the wdtvlivegen3.ver files already edited.

But since there is no 2.01.86 listed there (have a look … 1.16.13 is the latest available on that link)

so you have to manually edit the wdtvlivegen3.ver for yourself

from the download  link and instructions i provided…

recap: your OP asked how to Rollback to version 2.01.86

Thanks for your help.  I followed what you advised in your initial post and it worked like a charm :wink: I can finally turn the unit on again with the remote!

Now arises another question: is it possible to turn off automatic updates?  In that, every time I turn it on now it tells me there is new firmware available.  It’s annoying :angry:

Thanks

Yes, you can turn that off in the settings.

here’s WD’s official rollback link:

http://download.wdc.com/wdtv/wdtvlivegen3_rollback_2.01.86.zip

LMNOP wrote:

Now arises another question: is it possible to turn off automatic updates?  In that, every time I turn it on now it tells me there is new firmware available.  It’s annoying :angry:

 

Thanks

To disable the notification:  Setup > System > Auto Detect New Firmware > Off

This is documented in the User Manual  (Page 199)

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705062.pdf

Thank you Joey, my current WDTV is a Live Plus, so I have bought a new gen 3 SMP, haven’t hooked it up yet, but knew I did not want the brand new firmware and went looking for the previous one.and your info was what I needed.  Glad to know there is a way in the SMP to shut up the new firmware nag screen!  Never install the new FW, automagically!

I presume that wdtvlivegen3_2.01.86.zip is the best one to install if not on unit already, yes?

I cannot believe things like this are released by a major company like Western Digital. This new firmware is shameful. Did no one test it? I tried to roll back to older firmware and now this [Deleted] cannot even connect to my USB drive. What am I doing wrong?

You can give this a try …

1. small flashdrive (2,4,8 GB) formatted FAT32 … completely empty

2. download rollback firmware: http://download.wdc.com/wdtv/wdtvlivegen3_rollback_2.01.86.zip

3. extract all 4 files onto the root of the flashdrive ie. No Folders

so you should only have these on the flashdrive

wdtvlivegen3.bi2

wdtvlivegen3.bin

wdtvlivegen3.fff

wdtvlivegen3.ver

4. Before inserting the flashdrive … check the detect New Firmware setting is “On”

Setup > System > Auto Detect New Firmware > On

5. Power off the WDTV (Press and hold Standby button for 5 seconds … switch off at the mains power)

6. Insert the flashdrive into the front or rear usb input

7. Power On the WDTV

8. New Firmware should now be detected … press OK to proceed

9. wait until finished

  1. when finished to a Factory Reset   Setup > System > Device Reset > Restore All Settings Back to Factory Default  

  2. when finished (optional) disable the New Firmware notification

Setup > System > Auto Detect New Firmware > Off

2 Likes

It finally worked after I power cycled the unit (unplugged it and plugged it back in after a few minutes) and used a clean thumb drive as you mentioned instead of the hard disk drive I use for my movies. Still, this is a shameful situation and as this update has been labeled as 4.something, I wonder if I will be notified when and if WD decides to put out new firmware that fixes the issues. Just terrible all around, shame on them. I would switch in a heartbeat if Google/Amazon made something that was geared towards streaming locally and not from online services or they put DLNA in PS4, it’s obvious WD are amateurs. I’ve been having problems with Youtube and Windows Shares since day 1 with this [Deleted]

Dear JoeySmyth,

I have the same trouble as everybody here: a lot of .mp4 and .wmv ARCHIVES stopped running on my WD TV Live when I updated to the firmware 2.02.32.

I did everything I wrote on the net but JUST U has described EXACTLY WHAT TO DO in your post “Where can I download OLD FIRMWARE”.

The USB Drive must be formatted in FAT32 as you say. Everything was perfect for me and now I can see ALL MY VIDEOS, doesn’t matter the format, as before updating to the new firmware.

Is dissapointing a company as WD (I have a lot of products of this brand) go one step back in a new updating worse than the older one. I don’t understand it!!

THANKS A LOT JoeySmyth

Aconradescu

from SPAIN

Joey;s process works well… I lost ability to play mp4 file and by reverting back to previous firmware am now able to play them again. best result to detect new firmware via USB for me was to turn off all wireless and wired connections and to device restart… thank you Joey for the great info !