Where can I download a working disk image?

Hi,

The HDD in my My Cloud (6TB single bay, 1 gen, WDBCTL0060HWT) is dead so I need to replace it with a new one.
Have been searching for a working disk image but all links in previous threads are dead…

Thanks.

One really doesn’t need a “disk image” if one is replacing their My Cloud hard drive or fixing a bricked hard drive. Instead one can “unbrick” their single bay My Cloud unit using the methods posted by user Fox_exe. Note you will need to know which single bay My Cloud version you have (first gen v4.x firmware or second gen v2.x firmware) as the unbrick directions are different for each version.

The main Fox_exe repositories for multiple My Cloud models can be found either here:
https://fox-exe.ru/WDMyCloud/
or here:
https://drive.google.com/open?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE

First gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
English: https://drive.google.com/file/d/0B_6OlQ_H0PxVbzZac0plbkZKeGM/view
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD.txt
Russian: https://drive.google.com/file/d/0B_6OlQ_H0PxVakNZMjFvdzloRVk/view
The img files needed for the first gen Fox directions can be found in the WDMyCloud-Gen1/Backups folder in the main Fox_exe respoitory link above.

Second gen directions:
English: https://drive.google.com/file/d/0B_6OlQ_H0PxVQVhnLVJOdDZISUU/view
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://drive.google.com/file/d/0B_6OlQ_H0PxVazVOdWNSejFXV2s/view
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
Various files used in the second gen Fox_exe unbrick directions can be found in the WDMyCloud/WDMyCloud-Gen2 repository.

@Fisolle Maybe this link will help, the size disk you use to replace the old one is up to you.

Thank you! I followed the instructions (for first gen) - But it doesn’t seem to work. I only get a fast flashing red led.
I’ve tried holding the reset button for >40 seconds while plugging in the power cable. It flashes blue for a few seconds and then starts flashing red.

Any ideas?

Edit: It does not show up in the routers settings - so I dont think it boots up to the point where it connect to the network.

I’m redoing all steps in the instructions.

This part: “dd if=kernel.img of=/dev/sdb5”

dd: writing to ‘/dev/sdb5’: No space left on device
194561+0 records in
194560+0 records out
99614720 bytes (100 MB, 95 MiB) copied, 21.4046 s, 4.7 MB/s

Should it really say that there is no space left?

Edit: I proceeded anyway and finished the instructions.
Still the same problem. The My Cloud has flashing blue led for a few seconds and then start flashing red.

Really don’t know what to do now :frowning:

Couple of suggestions, having messed around replacing the hard drive on a first gen a number of times.

If using Fox_Exe’s first gen directions, make sure to use the exact values when it comes to creating the partitions. Do not adjust them to the size of your hard drive. Make sure to remove all partitions first before creating the new ones.

3. Type "print" for see what partitions exist on disk
4. Remove all: Type "remove 1" (where 1 - number of partition)
5. Crete new table:
mklabel gpt
mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M 100%
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
set 1 raid on
set 2 raid on

6. Ok, type "quit"

Not sure why that “no space left on device” error comes up. Seems to happen if the “.img” file is slightly larger than the created partition. Have had it come up from time to time myself. Not sure the cause or what actually fixes it. Most times if I restart from scratch and remove all partitions then recreate them the error tends to go away. As a troubleshooting step one could try using the img files from original_v03.04.01-230.tar.gz rather than original_v04.01.02-417.tar.gz.

With respect to the red front LED after performing the unbrick procedure, try accessing the My Cloud Dashboard even though the front LED is red. If you can access the Dashboard then navigate to Settings > Utilities and perform a System Only factory restore. The My Cloud should then reboot and after a short period of time boot to a blue front LED.

I copy/pasted the commands so there’s no chance I mistyped the values.

Will it be possible to upgrade to v4 if I use the v3 firmware?

It does not get an IP address so I don’t think there’s any way for me to connect to the dashboard.

Thank you for your support so far.

Yes it is possible to upgrade to the very latest v4.x firmware after unbricking to the v03.04.01-230 firmware.

Few more suggestions. If using a new hard drive try creating a single partition and formatting the drive on a Windows PC first. Then run through partitioning and formatting on Linux. I found using a Linux boot disc was the easiest method when it came to performing various unbrick steps. Make sure to perform the apt-get update && apt-get install mdadm parted command on Linux.

And when entering in the following mdadm command, make sure to follow it with the watch cat /proc/mdstat command that follows that line. You have to wait for the value to reach 100% before continuing.
mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2
# Type “watch cat /proc/mdstat” and wait 100%. Then - [ctrl] + [c] for close.

Tried with the v3 firmware now, and at least there’s no “No space left” error.
I still get the flashing red led though :frowning: .

Is it supposed to start flashing red at the first start?

Edit: Can it be a compability issue with the drive? It’s a shucked WD Emelents 8tb.

Once you have the flashing red front LED after performing an unbrick, try accessing the My Cloud Dashboard with a web browser. Assuming you have connected the My Cloud to a local network router. Then perform a System Only factory restore via the Dashboard. Then you can try updating the firmware to the very latest v4.x firmware.

If you cannot access the My Cloud Dashboard after unbrick, try performing a 40 second reset via the reset button on the back of the My Cloud.

Yes a WD elements drive that’s been shucked will work. Experimented with an 12TB WD Elements drive in a first gen My Cloud a while back before moving to a Synology NAS.