Weird trick to get WD Backup to work on Windows 10 with Long Paths

Here is a little hack for making WD backup to work when you are getting unknown errors. I was not aware of my backups failing for a few MONTHS! Then when I needed an EXCEL file that I overwrote, it was unavailable in the backup.

This is some hard to figure out backup software, I might add. I don’t like it. I am, unsure why I wasn’t notified that it was broken for many weeks.

Anyway, I tracked down the error. A lot of old messages indicated that a portion of my User Profile might have had long, deep, directory structures. the BAD program takes these already deep folders and makes them deeper, under my WD Passport drive. So, for example:

G:\WD Backup.swstor\Admin\ZLJjNvXiMzDaZjUyNDkgZW\Volume{1763b753-9739-4cb4-97d7-134c3506495b}
is the base for
D:\

That absurd extra deep path makes already long paths exceed the 20-year-old and well-known 260 character limit for pathnames in Windows. But I found a simple solution for Windows 10 users. I tried this and it worked without a reboot:

Try out a few tutorials about this: Here’s one: Long paths Group Policy and here’s an even better one with some explanation: Enable NTFS or Win32 long paths policy to remove the 255-260 characters limit in Windows 10

I did the Group Policy on my Enterprise version of Windows 10. A lot of folks may have to use the registry hack. I think WD needs to let users know of this problem and test it. I haven’t seen any compatibility problems with it, but just so you know, M$ has not enabled this by default… yet.

Example logfile that told me what the problem was:
1/28/2018 5:42:55 PM Severity=INFORMATION Message=The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.
1/28/2018 5:41:44 PM Severity=INFORMATION Message=Exception of type 'System.OutOfMemoryException' was thrown.

I found another kind of error, too. I tried temporarily removing a folder from my Profile backup due to numerous errors like this:
11/16/2017 7:04:20 AM Severity=INFORMATION Message=Message: (3) File \\?\Volume{7d059d39-f5f0-4417-a437-3d412579fd6e} \Users\Admin\AppData\Local\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy\LocalState \AppIconCache\100\{36709D58-D761-4376-B66D-1DA1FF879AB0} has problem in it creation as child obeject

Maybe this helped? There was something in the Cortana settings that WD Backup didn’t like. I will report back if this alternate fix helped WD Backup to run.

Long path tool was always there for me in this type of problem. I’ve been using it for months now and it is really helpful