Web Access and app install issues

When I go to wd2go.com and log in, it shows me my share drive, then when I click to view shares, it simply shows me a screen to download the app.

The App, unfortunately, hangd on install on OSX 10.8.5…

it gets to the Select Destination screen and won’t let me select anything… it’s just greyed out and I can’t go further. 

But I’d greatly prefer to be able to share via browser anyway. I was hoping to share files with a client and don’t want them to have to install some proprietary software in order to use the share.

Please advise



Screen Shot 2014-04-06 at 7.14.40 PM.png

1 Like


A web client is available at https://www.wd2go.com/

When I go there and log in, it only takes me here

and the here


Screen Shot 2014-04-09 at 6.34.00 AM.png

no option to see any web clients

am I missing something?

same thing happens in Safari or Chrome

After you see your device through wd2go.com, you should be able to log in and use the java plug-in to see the shares of your NAS.

still getting the same results…

where does this Java plugin present itself?

All I get is the screen asking me to download the app…

in chrome and Safari

I just downloaded the latest Java update… no change

surely I’m not the only person having this issue

When I click my share after logging in on wd2go.com, this is all I get… in Firefox, Safari and Chrome…

Screen Shot 2014-04-09 at 6.34.00 AM.png

and when I try to install the app, I get this:

Screen Shot 2014-04-06 at 7.14.40 PM.png

Can’t go any further.

I’m on a MAC with 10.8.5

I’m in Australia and my WD drive is at home in LA, but it works fine on my Android tablet and phone… just not the mac.



Russell Spurlock

You should try the EX4 dedicated forum. You are here in the MyCloud forum.


I know this seems totally silly, but have you tried clicking on that blue bar area

maybe it’s not really selected?  need to try to see if it selects

then you can click “continue”

otherwise, I don’t know what to tell you since I never liked using a 3rd party app or cloud based service

just to get back to my device at home.

I prefer the VPN method.

I vpn into my home network and I use regular file manager.

yeah… it’s not selectable… 

I really am amazed that there are no answers on this from support even… I’ve been waiting for about a week … had 1 lame canned response from WD Support that simply pointed me to the FAQ and can’t get another response

I’m not normally on a MAC… I find this kind of dead end happens a lot on Macs… no explanation of why you can’t do something… you simply can’t…

Give me a PC anyday…

However, I’m in australia for three weeks, need to access my files from this mac laptop and can’t do it.

I can access from my android tablet and phone

I’m trying the 2d2go page now on a PC and it does the same… won’t let me view shares… just says to download the app.

Is the problem maybe that the EX4 doesn’t allow Web access?

Correct… The EX4 is not use the WD 2go web access. I guess since the EX4 can be configured directly with WebDAV they decided there’s no specific need for the web service.

I do not believe that’s true.

EX4 does come with CLOUD access option

it’s just not working well for the poster

webdav would be great if it WORKED but even that is a bit of a struggle

not because of EX4 but because of Windows 7 or mac and what they support natively.