WDTV+ Not Showing Up In Workgroup


#1

Got my WDTV Live Plus successfully connected to my wireless network and have no trouble viewing YouTube & Netflix and other internet-based services, but cannot access the shared drives and folders on my three desktop XP PCs.  The WD does not show up when I view  my network places.   All three computers and the WD are assigned to  the network workgroup WORKGROUP (all caps on all four machines).  When I run  LANScanner, the WD shows up under WORKGROUP.  Why doesn’t it show up on my PCs?  I presume that this is why nothing happens when I try to access network shares on the WD (yes, sharing is switched on on the WD)?

For clarification, two of the  PCs are conected via cable to my wireless router and the third machine is connected wirelessly to the same router which also serves the WD.


#2

And we assume that all three PCs can see each other’s shared folders, right?

Make sure you turn off passwords on the shares, and that they are available to everyone.  You may also have to name each of your Live units differently so they don’t step all over each other (but Tony’s the network guy here so he’ll have better instructions).  And, of course, make sure you don’t have Windows Live assistant (or ANY of those new XP updates which include them) installed.  If you do, you’ll need to roll back your computer to before they were installed (as just uninstalling them won’t work anymore).


#3

Generally, this issue occurs when the “Local Master Browser” refuses to accept a node (the WDTV) into its list and doesn’t propogate it out. 

To troubleshoot, go shut down all but ONE of the PCs that have shares.   With the final one, REBOOT it.  

Let it sit a few minutes, then go turn on the LIVE.   Wait about 5 to 10 minutes. 

If that still doesn’t show up on the WDTV, it can be determined by doing a wireshark capture, if you’re up to it.


#4

Tony,

Did as you outlined, but the WD player still is not showing up in my workgroup.

And Mike, yes, all the PCs talk to each other and share the shared folders and drives.  Also, the shared items are not password protected and are available to all users.  Finally, Windows Live is not on my machine.


#5

You didn’t by any chance upgrade the Live’s software?  If so, try resetting the Live and then logging into the network again (you’ll need to start over with your settings at that point).


#6

No, I’m using the firmware “as is”.

I did take the unit to a friend’s place and hooked it up to his (much more extensive) XP network.  It found his computers and shares just fine.  So it’s something with my network setup.    However, all my networked XP boxes communicate with each other with no problems.  At this point, I’m stumped.


#7

If you’re comfortable running WIRESHARK software on one of your PCs, and get a packet capture, I can take a look.  PM Me if you’re willing, and I’ll tell you how to do it.

I was helping another guy with the same issue, and unfortunately couldn’t discover the reason (but his was Win7,) but Wireshark proved that the network had no master browser for one reason or another.


#8

Sure, I’ll give it a go.  I’m (obviously) no network specialist, so you’ll need to tell me what to do, but I’d very much like to get this figured out.

BTW, checking windows services shows that the computer browser service is running on my main machine but is turned off on the other machine currently on my LAN (my third PC is powered down  While I work on this so as to minimize variables).


#9

Before we go there, let’s make sure that NETBIOS is running correctly.

Go to CONTROL PANEL

NETWORK CONNECTIONS.

Find your Network adapter in the list.

Right Click it, and select PROPERTIES.

Select INTERNET PROTOCOL (TCP/IP) and click PROPERTIES.

Click the ADVANCED button.

Select the the WINS tab.

If there are WINS addresses listed, STOP.   You need to find out WHY there are servers there; that’s a special case, and moving forward would likely BREAK something.

At the bottom, under NETBIOS:

If it’s set to DISABLED, set it to DEFAULT.

If it’s set to DEFAULT, set it to ENABLED.

OK or APPLY all windows until out of control panel.

Restart your PC, then Restart your WDTV.

Did that fix it?


#10

"fraid not


#11

Tony,

It’s dinner time here on the west coast and tomorrow I have guests arriving, so I’ll be AFK till Tuesday.  If you send me the Wireshark instructions in the meantime, I’ll follow them  and report  results Tuesday.

Thanks for your persistence.