WDTV Live Hub Remote Issues

I recently had to replace my original WDTV Live. The replacement came with no remote control which I didn’t see as a problem since I had a duplicate.

At first the remote functioned well, after I made the device part of my NAS, the remote ceased to function.

I tried the software remote on the device homepage & tried the iOS app which didn’t detect the device at all. The same app worked fine with my original device. I’m no stranger tu repairs with the original device, several years ago I was forced to swap the 1TB Scorpio Blue for a 750 GB replacement. I’m very happy with the device but an at a loss as to what could be causing this.

The only changes I made conf the replacement were to sync an external WD 500 GB external USB. This never was an issue with my original box.

Any ideas? Also I’m pretty sure the new box doesn’t have the latest firmware WD released around 2013.


Hello! A year ago my remote stopped working. I found a replacement on Amazon… It works well enough for me… I’m including the link. Good luck.

1 Like