WDTV Live cannot turn ON with a remote !?

Hello,

from recently I have a problem, when WDTV Live latest model is OFF I cannot turn it ON with the remote. When I unplug it and plug the AC back it starts and the remote works flawlesly. Then I can turn it OFF and right back ON. But tommorow again I cannot turn it ON with my remote ? Batteries are new, everything works great when I start it but like it freezes when it is OFF over night. Tried Factory reset to default, same problem. Latest firmware version.

I really cannot imagine what the problem could be ? Why is WD so arrogant and gives no updates for a year, at least.

Thanks

Mine had quite the same problem, but the control did not work flawlessly. I just put the player in other location and the problem solved, I guess was some interference coming from somewhere.

I observe exactly the same problem since recently. I have changed nothing in the setup. It just does not respond to the power on signal from remote. Because after unpluggin and plugging to the powersupply it really works

Hi, am experiencing the exact same issue since today.
It was perfectly working before and I did not move my device on the shelf.
Did you find a solution? except unplugging the power which works as well for me
Thanks a lot

Hi, have you tried rolling back the firmware? What is the exact version of the firmware that you have installed?

I had the same problem. I downgraded Firmware from 2.02.32 to 2.01.86 and the remote will now turn the WDTV Live on. I followed the instructions in a previous post here…

All Three of my players behaved in a similar fashion,lock up so remote doesn"t work or freezing during playback. I’ve downgraded to 2.01.86 and all is fine. Yet when I look for the latest firmware I cannot find 2.02.32 in latest firmware. Just a note when downgrading. You must have autoupdate firmware enabled and the new files on your usb (formatted as fAT32) must be a higher number to be recognized.
I really would like to find a list of all firmware updates for these units

Sorry guys for late reply. Funny thing is that it can turn ON few seconds after I turn it OFF but after few hours is a no go. I will try to flash older firmware but this a a disgrace for WD, they have done nothing for a year about this device, no updats or anything, they dont make new 4K players and they have completely forgotten about this one, got our money and FU.

Why does nobody from WD reply on this subject. Is this a WD forum or just a collection of information of type “help yourself”

Today I have turned it ON with a remote. Will try few times tomorrow, this is some scary Big Brother s**t.

Try guys on yours.