WDTV Freezes, Unable to read WD Elements SE 1TB USB 2.0 Portable Hard Drive!

I purchased the WD TV Live HD Media Player (WDBHG70000NBK-VESN) from Future Shop last week and was so excited to set it up and use it with my WD external hard drive which holds all my video and audio backups.

The WD TV does not recognize my WD hard drive and keeps on freezing and the only way to get it back online is to unplug the power adapter. When I reboot the device, sometimes it recognizes my hard drive and gives me the wait message to index the library. Since this is a 1TB HDD, I figure it takes sometime for the device to go through all my files so I leave it ON and after a few hours when I return back to it… it’s frozen! I reboot the system and my HDD is not recognized again.

So frustrating… 

Any idea?

What firmware do you have?

The latest firmware.

Plug the HD it into your PC.

It probably has errors that need to be corrected (can happen if not shut down properly.)

Also delete the hidden .wd-tv folder that is at the root of the disk contents.

Connected HDD to my laptop, ran scan. HDD is working perfecty on my PC.

Deleted the hidden .wd-tv folder from the root. Reset all WDTV settings to factory default. Attached HDD to the WDTV, still shows “No storage present” under local storage!

How is power supplied to the HDD?

Power is supplied through the power adapter that came with the WDTV. Both laptop, TV and WDTV are connected to a surge protector.

The thing is WDTV sometimes detects the HDD after rebooting and disconnecting the drive a few times,… and when it does, the LED on the box keeps on blinking which I assume it’s going through my files and as a matter of fact I am able to see my files and folders at this point, then a message on the top of the screen appears saying that it’s compiling the library or something… I select “I’ll wait” and then I usually leave it alone until it’s done scanning my HDD because my archive is huge. Then after an hour or so when I return back to the TV, the WDTV box is totally forzen, though the LED light is still blinking.

At this point the only thing that return the box back online is unplugging the power adapter and plugging it back!

If your HDD is USB powered, I’m just wondering if there is insufficient power being supplied to the HDD.

I have tested with a USB powered WD Passport Drive this morning, The LIVE SMP was freezing and the drive light was constantly blinking!

1 Like

It’s a possibility but the users guide or WD website doesn’t say anything about not being able to use a portable WD HDD with their WDTV.If that’s the case, then WD is to blame for not warning customers with portable USB drives.

Bought this 5hrs ago.

Plugged in. Auto Updated firmare as advised by WDTVLive immediatly.

Pkugged in a 2TB Seagate USB 2/3 HD with 2200+ movies and waited, and waited, and waited, and waited, 10mins later the first directory began to appear. I ended up selecting folder view somehow and began watching a 2hour movie while I heard the drive working in background, I figgured it was indexing or doing something while I watched the movie.

To make a long story short I shut off the WDTVLive made supper and came back to watch a nother movie but NO.

When I turned it on I had to wait all over again. 10minits before the remote unfroze and I could navigate to another video to watch.

From the ABOUT screen I see “DEVICE Info  1.12.14"” I guess thats the firmware revision.

The reset switch will not return to factory default 1.10 or whatever it was. I think from some reading I have done that this new firmaware is broken but I can’t confirm since I let the machine auto update on it’s initial startup, nor can I find or figure out how to install previous reviosion.

PS I am a linux user, dont ask me to buy lame-o windows to fix this piece of **bleep**. I have a 10 year old Pioneer DV-410 dvd player that reads any of my hard drives in 5 seconds flat. All are FAT32 and <=2TB. This WD was supposed to allow me to read more video formats other than divX or Xvid because MP4 and MKV are more common now than the old days. I can’t be bothered to recode to xvid. but I’m not interested in this toy if it is this slow on boot with a single USB drive connected. I tried to restart it with 2 identical 2TB drives connected but gave up after 60 minits of waiting for the WDTVLive to boot. I guess life is simpler and faster to recode my downloads and use the decade old DVD/DivX player to watch 'em.

I will check here tomorrow after work for a fix otherwise I will return it 10 minits later while I can still get my money back. There’s plenty more manufacturers to choose from.


Factory reset (or pressing the reset button) does not rollback the firmware.  It only puts it back to factory defaults, meaning in a state that it would be if it came from the factory if it were running the current firmware that you have.

MKV’s and MP4’s play fine, all my movies are mkv’s and I have no issues playing them.  Your problem most likely isn’t with the files, especially if you were able to watch a movie.

The waiting that you are doing is waiting for the the Media library to compile (creating a cache of all your files).  Depending on how many files you have, it can take a while for it to compile.  You don’t have to wait for it to compile though, as you can use folder view to view your files or switch the content source (press the red button on your remote while  in Videos).  However, if you are initially connecting a drive, I would wait for the the media library to compile because there are issues with the media library and if you watch a movie before it compiles I have found that it does mess up the media library.

I set Media Library off in setting and so far so good for an hour so far. Otherwise, it hangs within 20 mins