WDTV doesn't work on my pre-amp when firmware is upgraded

I just bought a WD TV Live and it worked great when connected to my pre-amp until I upgraded the firmware with the notification that popped up. If I bypass the pre-amp and directly connect the WD TV to the Telivision then it works. I had to rollback the firmware to version 1.12.14 and it worked again when connected to my pre-amp.

Here is the hardware I’m using:

WD TV Live

Marantz AV 7701 Pre-Amp

Panasonic VT25 connected to Monitor 1 on Pre-Amp

Panasonic VT25 connected to Monitor 2 on Pre-Amp

Sony TV (not sure of the model) connected to Xone 2 on Pre-Amp

I would also like to note that this issue exists with the WD TV Live Hub as I bought that also to expirement and see which one would work better but it had that same exact issue. I rolleback the firmware on the WD TV Live Hub to 3.08.14 in order to work again with my Marantz Pre-Amp.

Any suggestions of fixes for getting WD TV to continue working on future firmware upgrades would be nice. For now I have disabled firmware update notifications so I’m not tempted to upgrade.


When you upgraded the firmware, did you reset the device to clear the cache of the media player?

It is always recommended to reset the media player before and after an upgrade.

Hows it connected?

If it through hdmi or digtal you often have to go into setup/audio video and pick your audio menthod and run the scan with the equipment on.

See if that helps fix the problem.

After weeks of messing around, I got it working. The fix was to upgrade my firmware on my Marantz AV7701 pre-amp and then I resetted the WDTV. When the WDTV came back on, I just did a firmware upgrade and it is still currently working while connected through the pre-amp.

Note: The reset on the WDTV was probably unnessary but that’s what I did and it worked in my case :slight_smile: