WD5000AAKX on a SATA1 (1.5Gb) controller

I need to install a hdd (500GB WD5000AAKX SATA3 6.0 Gb) on a old mobo with SATA1 controller (VT8237), but it doesn’t detect the hdd due to SATA1 controller limitations (see here ))

I tried to configure the hdd on a newer pc using wdsspd utility (WdSSpd- that allows to limit max speed to 1.5 Gb (SATA1)

wdsspd detects my hdd but it can’t set SATA1 speed (gives the “drive not suported” error ) - also - ATA speed negotiation is unknown on detection.

I tried with other hdd (1TB WD10EZRX): wdsspd works fine (I downgraded hdd from SATA3 to SATA1) and the hdd is recognized from VT8237 chipset (in other words, is really wdsspd + WD5000AAKX that don’t works).

Is there a newer or other version of wdsspd that can work with this drive ? Or a other solution?


Hi and welcome to the WD community

have you tried checking the jumper settings on the unit? You can try checking the jumper settings.

This link might help you out, I hope it helps you:


Lets see if someone with more experience can help with this matter. 

Hi ArMak,

Thanks for reply.

Alredy tried with jumpers… With jumper on pin 5 and 6, hdd switch from 6.0 to 3.0 Gb/s, but utility reply me to the same way.

I suspect that WdSSpd modifies 1 or 2 bytes in the firmware. By comparing the firmware modules before and after applying WdSSpd, we could determine exactly where the changes are written (probably module #02).

You could retrieve the firmware modules with the following tool: