WD30EZRX MBR to GPT - lost Partition

Hello !

Short explanation of the situation:

  • Bought a WD30EZRX a month ago and installed it in my computer (MB= Intel DP45SG extreme)
  • BIOS recognized HDD correctly with full capacity (2.7xx GB, xx stands for " I don’t remember ")
  • Win7x86 recognized the Disk correctly with full capacity, no problems
  • formatted the HD with MBR, NTFS, 4KB-Sectors (Quickformat), 1 partition over full capacity
  • everything worked fine, I stored a lot of files on it, no problems at all (neither writing nor reading)
    It is NOT the System-Disk, I just used it for storage, maybe 60% used

Two days ago win7 did an update and after that it says “restart you computer” and so I did

While starting the System a black screen appeared and did something with the disk.
I don’t know exactly what, because I was not nearby and I only saw the screen for a second, then win7 started as usual.
As result disc was shown as “RAW”, Partition lost, Win7 says: “Disk unformatted, do you want to format it now?”
I did not.
After a second restart disc shows some folders and files, but they are not usable.
Did some investigation (with tools, but no writing actions) and discovered the disk is now GPT-format.


  • Is there a way to get my datas back ?
  • HOW ??

PLEASE: No blablabla-answers, what I should have done from the start (format it in GPT and so on) and what I did wrong. We can talk about this after the Questions are answered.
It’s not the thing that I want to use it in future the same way - I can save datas to another drive and install/format the EZRX after that in the correct way.

Would be very nice if you have a solution.

Thanks in advance to all you Gurus
and best greetings from Austria

PLEASE: No blablabla-answers, what I should have done from the start (format it in GPT and so on) and what I did wrong. We can talk about this after the Questions are answered.

You should be more polite when you are looking for help.

Just saying :manwink:

I don’t know how to be more polite than saying “PLEASE”.
You do? Tell me PLEASE
But extortion is even not very polite too…

Oh !
You did a edit on “click the star” and “accept solution” ?
So I take back my complaint :wink:

See, I surfed the Net a lot in this case, and 99,99% of people gave answers like “why dont you have a backup”, or “make a screenshot…”, or “I dont know, but try this or that …”
To prevent the thread of that, I wrote: PLEASE DO NOT…

Trust me, I’m a very polite person, just see the ending of my first post

I wish I could help, but I have a similar problem.

3tb data drive, installed using GPT, full size visible and filling up over the last few months.

Wednesday there was a windows update and when i rebooted I had lost the drive (shows in disk management as 746gb drive, unknown and needing to be initialized).

Now I’m trying to figure out how to recover my data, so I’m subscribing to this thread in case any solutions appear…

GL ombobombo

Thank you !

Exactly as here - all the tools (testdisk, easus, scavenger and so on) tell the drive is 746gb and won’t work.
I’m glad that the data on the drive are not that important…

I myself will do some investigation to save data
and if I’ll be successful I’ll post it here for sure !

toi toi toi (means good luck) to you too

Data-Rescue-Solution found !

After trying a lot of tools ( File Scavenger, EaseusPM, PartitionWizard, TestDisk and others) to restore the HD’s Rootfiles, I gave up this target and tried to restore the data only.
First Tool I tried was “PHOTOREC_WIN” by CGSecurity and it was successful.

You need:

  • basic knowledge how to navigate without a mouse
    - a second HD to restore/copy the files to
  • a lot of time and patience

All what comes now belongs to the circumstances as described in my first post !

  • Download Testdisk/Photorec from   CGSecurity Website. No install required, just start Photorec_win.exe as Admin (right-click - start as Admin, answer warning with “yes”)
  • Navigate to the disk you want to restore and make the settings that fits to your installation. After that set the target disk.
  • Start restore and wait (no writing actions will be made by Photorec on the source disk, be sure)

Result: You get all the files back, but they are renamed by Photorec.

The whole action takes about 7 hours, but you can abort and continue even with a computer-restart. Photorec does a protocol and next time when you start it asks if you want to continue.

The renaming may be bad and it is a lot of work to rename the restored files - but so far I have not noticed lost data. Restored approx. 500 movies, all work fine…