Wd2go can't access anymore

Hi all, I finally changed the MBL to a static ip and set up port forwarding on my router I did this due to the download speeds being really bad for my parents overseas, 3mb fles taking 40+ mins, the trouble is now ive changed it nobody is able to connect, I’m presuming this has somehow broken the connection but would appreciate any help I can get. I should explain that the MBL says the port forwarding is all connected.

edit: so I cant even access this from the mobile app ether, I have deleted and recreated my own user, it wont connect via 3g, which it used to, and will only connect from the app over my own wifi, interestingly it does tell me in the settings area that t is connected, but withour 3g connection it wont be a not a lot of use for me, I really could do with some help on this now as this will quickly be a waste of time for me.

Thanks Fraser

Review the steps from the link below in case you forgot to forward one of the ports.


sorry, been travelling and not been able to reply.

I have checked and double checked, and I still cannot get it to work

Internet connection shows good

IP is a static address of

remote access says connected and port forwarding connection established 

wd2go ports are set at 80 and 443 in wdbook live

router has port forwarding set for TCP for both 80 and 443 for

Nobody can access unless they are on the actual network itself, so even my mobile app over 3g wont go to it, once on the wireless network its fine, nobody going through WD2go can get to it anymore, I have deleted and reset everyone, but nothing seems to allow me access.

any other suggestions would be great, as I am now having to use Microsoft Skydrive, and that seems a waste of buying this and holding my files at home (although my mother loves skydrive, its really fast and simple to use!)

I’m convinced there’s a problem with the Dynamic DNS that Wd2go is using.  My remote access was working fine for about 50 days until I ended up disconnecting the network port on my drive.  When I plugged the drive back in it switched to relay.  Periodically it will switch to direct, but the dynamic address (the mybooklive.device######.wd2go.com address, when ###### is your device id number) won’t update to my home ip address.  So if I try to connect it says it can’t find the drive.

If your drive says port forwading is enabled, most likely you’re running into the same problem as me where the ip address is still referring to the relay ip address and not your home ip address.  In my case though the drive will switch back to using the relay ip address for awhile.  When it does that you should be able to connect.

I wish there was a way to force update the ip address since that would get things working.

well, there is definately something wrong, I am certain I have everything configured right, I guess until either miracles happen or somebody from WD tells me what is wrong I am stuck using it as a media server and microsoft as my cloud storage.

Come on, someone from WD, Tony, anyone, please have a think about what is wrong, I know these are the community forums but I also know you read them!




I encouter the same problem last week (where I just purchased the WD MBL), the WD2GO was never successfully until now.  The WD support advice me to reset everything, using Full Factory restore, I tried, it show connection status was Ready, when I tried to configure the WD2GO, the connection status changed back to “Connecting”.

I had done many reset, nothing successful.  So far, no reply from WD support yet.  Good to know that it wasn’t a unique case to me.  I had been suspecting firmware issue, because even I disable the Remote Access, the connection status still shown as “Connecting”  :confounded:

Let see how fast WD support can resolve the problem for us.


Hi all, I am having the exact same issue as the rest of you.  I decided to upgrade my router to the Belkin AD1000 and spent several hours yesterday setting up all of the necessary configurations including port forwarding.  Now netiher the mobile WD2GO apps or the WD2Go website access are able to access the MBL drive.  When I attempt to use the mobile apps, specifically WDPhotos when not attached to my wireless network, I get a File not found on device (404) error.  When I or my partner attempt to access the drive through the web interface we get the following:

Http status 404 = TCP relay fialed - address for target domain not found

type:  Status report

message:  TCP relay failed - address for target domain not found

description:  The requested resource (TCP relay failed - address for target domain not found) is not available

Apache Tomact / 6.0.32

I also am getting a certificate warning notification that I never used to get. 

When I upgraded my routed I switched from Linksys to belkin and I know that the IP address ranges have changed from 192.168.1.X to 192.168.2.X.  Is this the problem?  I have turned off the firewall on the belkin router, and when I am logge into the MBL dashboard it tells me i am connected with port forwarding enabled and connected.  HELP PLEASE!!!

I’m having the same problem. I’ve tried just about everything.  In all permutations, the MBL dashboard tells me I’m connected and port forwarding is working.  I can successfully log into wd2go, but when I go to View Shares, I get the HTTP Error 404.  I’m using a Cisco WVRS4400N router.   I’ve tried the following:

  1. MBL Static IP and DHCP. 

  2. Desktop with Windows 7 Ultimate 64 bit and IE9, Desktop with Windows 7 Home 32 bit and IE9, Laptop with Windows 7 64 bit and IE9, netbook with Windows 7 Starter and Chrome

  3. Router firewall turned on and off.

  4. Windows firewall is off in all permutation above.

Interestingly, I installed the mobile app on my iPhone 4S, and everything works fine.

I called tech support today and the level 1 tech was quite anxious to help, but in the end could not.  I have a case number and will call in to level 2 support on Monday. I’ll post resolution here if there is one.


How did you with the level 2 call?

I can log into wd2go.com and I can see my external. When I click on it to open it asks for my NETWORK DRIVE PASSWORD. I have tried all the passwords that I have, to no avail. I then reset it. Logged in again from wd2go.com, and the same problem occurs.

The App works fine on my Galaxy Tab, and I can access my files (except I haven’t worked out which format the movies need to be in for me to watch).

I am working from a ‘Lamborghini’ laptop.

Any help please.

I’ve had two calls with the level 2 techs. Neither could solve the problem. The had me do a system configuration dump and send it to them so their engineers could try to duplicate. That was on Tuesday 9 Oct 2012. Haven’t heard back from them yet.  I’ll post the reply here.