WD WP Pro and Macbook Air M1

Hi

I’m having trouble connecting my new MacBook Air M1 to my WD Wireless Passport Pro 2TB. I connect it with an original USB-A to USB-C adapter, but the hard drive does not appear on the screen, it just starts charging, just like if I had put it to a charger.

I thought I had tried everything. I’ve formatted the hard drive, I’ve tried various adapters, and I’ve also looked for it in Disk Utility, but it does not appear.

Is there anyone who has experienced the same, and who possibly. have a fix?

Thanks in advance
Fred

3 Likes

Hello,

please refer to the following KBA article: https://support-en.wd.com/app/answers/detail/a_id/8416

Logan what kind of answer is that?do you even read what he saying?? jesus

Sounds like I have a similar issue with my Wireless SSD

I have the same problem. Only my old Macobook Pro (later 2011, High Sierra) mount the disk by usb connection. But not my new MacBook Pro (2017, Big Sur).

The disk is ok. I can use it from my old computer. But from Big Sur only can work with the wireless way (slower and unstable connection).

Please, help. :slight_smile:

I have the exact same problem. My WD Wireless pro is the 4TB version and the same M1 Macbook Air . Really annoyed with this problem. connected as NAS is really slow and connected by USB didn’t do a thing. It just charged my WD WP. According to Google, this problem already exist since the 1st time M1 Mac launched but WD seems blind to it. However, this post on other website caught my attention:

Will try it the 1st time I got the chance. Hope a firmware update from WD can fix it. the last firmware update from WD for Passport Wireless Pro was years ago.
Note: My HDD WD Elements runs on the M1 Air.

Now is the may 8th and Wester Digital still didnt do something about the M1 Wireless SSD PROBLEM! I am sooo disappointed about Western Digital.

As a professional photographer I bought the WD Wireless SSD and can´t use it now on my M1 Mac, which is incredibly annoying.

Obviously I did research the problem and dived into it myself.
What did I find out? - The problem is the operating system of the harddrive.

I did format the disk (just as a normal harddrive on a “no m1 mac”.
Than it worked with the M1 - but obviously, I then don´t have the SD Card import function!!

So Western Digital has to UPDATE the OS on these SSD drives (with SD card slot!) to work on the m1 mac´s.

But they just seem to ignore the problem! → bad service, sorry. :frowning:

1 Like

I have exactly the same problem. My passport wireless pro & MacBook Air M1 connected but doesn’t mount, just charges battery. I think the problem is to do with PD power. If I connect the WD device to the MacBook via a USB2 hub the drive mounts & doesn’t charge-but of course the speed is very slow. I am still trying to get WD to understand the problem. It should not be this difficult!

Over the past ten years, I have tried more than 4 computers. I actually spend some money to see what computer is worth it. I had problems with each one, but I didn’t find a solution for all of them. Still, the best one, I think, is the Macbook. I once had a small probme, but the guys from starlabs helped me fix it. All the friends that own a MacBook and had some logs went to this main service. They work so well and professional. Indeed I would recommend them. Plus, they repair and phones, which is kind of convenient.

When I download the M1 ARM processor Install WD Discovery for My Cloud Home for Apple M1 ARM Processor It seems that it won’t be worked, cause it stopped at 50% of the download.

Hi, as anyone find a fix or something? Ive got the same issue
Thanks

Hello guys, so I finally can say, that with my M1 Macbook the WD My Passport Wireless SSD is working. What did I do? Actually, nothing ! I was playing around with hanging the SSD to my HooToo USB-C Hub (with USB-A) and tried both USB-C ports on my Macbook. With the first try, it didnt work, it was mounting somehow “over network” (but Wifi is NOT connected!) … obviously it didnt work. So than I disconnected the USB-A connection and tried it with a different port (both on the USB-A port(s) and on the USB-C port on my Macbook). And what can I say - it worked! The SSD is mounted now with USB-A, and NOT over Wifi. Really nice ! I am so happy ! Works perfectly with my M1 Macbook Air.

So I would recommend to everybody, try your different ports, while the SSD is on (not in charging mode, but ON) and try switching the USB-A ports on your HUB and your USB-C port on your M1 Mac while the drive is running and wait at least 5-10sec for the system to recognise the drive.

2 Likes

I confirm, this method works with Ugreen 4k60 hub

2 Likes

So as i understand my passport wireless sss is not working with macbook m1 on any port. I have to have type c hub to solve problem

Hey Western Digital where are you ??? I can’t use my passport Wireless SSD on my MacBook Pro M1… It doesn’t work with my usb-c hub… It only work on an old MacBook.
Please help us ! Your product is unusable if you do nothing… In this case you would be crooks ! :frowning:

I can also confirm that the method with the USB C hub works, in my case I used the HyperDrive 3v1 USB-C Hub 4K HDMI. So I guess, you have to try and pick the one that works …

This is really annoying issue, and I am really glad that I found this post, special thanks to @diesel_d2!

I guess for now, this is how we would solve this is issue, it’s better than not using the external disk at all …

With UGREENS 4k 60hz perfectly works with macbook air m1
And even with ipad air, which is supercool

I am having a very hard time registering my new WD My Book 4TB hard drive. Cannot get my receipt pdf to get loaded what do I need to register the hard drive. Can I mail you the information . this is crazy

please reply