WD Wireless Passport problems

Hi, I got a 1TB Wireless Passport this week.
Few issues :

  1. It says, update firmware, but nothing happens, when I click.
  2. I have AUTO COPY feature enabled in the settngs page, but when I insert the card, the auto copy doesnt happen.
  3. If I connect the card and then connect the drive wirelessly to my computer, and click on COPY< then copy happens fine, but in the end shows some error.

How to fix those 3 issues ?

Hello,

Have you tried resetting your drive? if not, please try that. See page 47 of the user manual for detailed information about it.

Hi, resetting it doesnt help.

  1. How do I update firmware ?

I guess if firmware is upgraded, it might solve ?

Have you tried to upgrade the firmware using the SD method?

No, Im not aware of the firmware update from SD card method.
Please share how

Follow this link: https://support.wdc.com/downloads.aspx?g=227&lang=en

You will find the procedure at the bottom.

@soamz

If you do not have the complete MPW user manual you need to find it on your drive or download it from WD. Without it, you are utterly clueless and wasting your time and others who try to help you.

I have upgraded it.
Still the auto import doesnt work at all

Have you referred to the user manual at all; it does not appear so.

yes.
And even in the web panel, I have auto copy enabled.
Still nothing happens, when I connect the card

I suggest you contact WD Support.

Hi could somebody please help me… I cant access my files stored in the external drive… the light is on when I plug it in my pc but it wont appear on the windows explorer but it appear on the safely remove hardware and eject media

You should contact support as shown above.